WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] In the process of changing directory - No site! (46 posts)

  1. Milsie
    Member
    Posted 1 year ago #

    I have been following the instructions here: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    ..to change my site location to the domain name I bought through the same hosting package. The domain name is http://www.touchtitanium.com which is at this minute displaying without the theme applied.

    I have tried changing the index.php file in the root back to the original and have deleted the .htaccess file I created manually to update the permalinks in there. (wouldn't update automatically even though permissions were set fine).

    So now I am staring at a non-functional site with no style and no access to the admin panel. When I type in the old admin address it redirects quickly to touchtitanium.com/admin which says 'Internal Server Error'.

    Any ideas guys?

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

  3. Milsie
    Member
    Posted 1 year ago #

    I saw it and I tried method 1 and 3. Neither worked.

    I am seeing a white browser window on method 3 (the Relocate Method)

    I don't get it. I've changed everything back to how it was before. The only part that's wrong was set in the admin panel under the General settings and they were the Site addresses.

  4. Milsie
    Member
    Posted 1 year ago #

    I need to get back in to the admin panel in order to change the Site links back to their original longer names. That should put everything back to normal. Can you tell me which .php file holds this information so I can edit manually?

    Really appreciate your help by the way. I'm stressing a bit. :D

  5. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    I need to get back in to the admin panel in order to change the Site links back to their original longer names

    No - you do not! Read that page carefully.

  6. Milsie
    Member
    Posted 1 year ago #

    esmi, I am getting some Warning and Fatal error messages now that I have restored the .htaccess file to it's previus state. I think it is conflicting with the database. Something about 'line 17'. Can I contact you directly by email? No worries if not.

  7. Milsie
    Member
    Posted 1 year ago #

    Looking at this point now: Changing the URL directly in the database

    I am looking directly at the database, showing all and doing a search for 'siteurl'. It's not there.

    This is very confusing. I'm going to try posting somewhere else. I'm not good with code, which is why I enjoy WordPress.

    Thanks for your time.

  8. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    It's not there.

    Yes - it is. Try looking in the wp_options table.

  9. Milsie
    Member
    Posted 1 year ago #

    No - it's not. I was looking and am looking again on the wp-options table. Showing up to 800 entries and 5 containing the word 'url'.

    The site is obviously still there, but it doesn't know where any of the files are so non of the images are linking up and the theme is not being applied and there is no admin panel access.

    So supposing there is no 'siteurl' entry, what then?

  10. Milsie
    Member
    Posted 1 year ago #

    If this is the exact location of my config file, shouldn't I be seeing something on this page?

    http://s414604449.websitehome.co.uk/touchtitanium/wp-config.php

  11. Milsie
    Member
    Posted 1 year ago #

    Just raised my search to 1000 rows on the database and the 'siteurl' entry has appeared. Yes, you told me so :P

    I don't really want to tamper with this but I guess if it's the only option...

  12. Milsie
    Member
    Posted 1 year ago #

    I've done what it said and changed both entries to:

    http://s414604449.websitehome.co.uk/touchtitanium/blog

    Does that look correct, esmi?

  13. Milsie
    Member
    Posted 1 year ago #

    Didn't work so I've changed it to:

    http://touchtitanium.com/touchtitanium

    .. this was what I originally had in both General settings.

    Still doesn't work.

  14. Milsie
    Member
    Posted 1 year ago #

    hold on, that's wrong.

    http://s414604449.websitehome.co.uk/touchtitanium/

    Now I got a page for a second, an error 404! But no admin panel...

  15. Milsie
    Member
    Posted 1 year ago #

    Do the new addresses have to have an http:// at the front?

  16. Milsie
    Member
    Posted 1 year ago #

    Surely my .htaccess folder is now out of date...

  17. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Do the new addresses have to have an http:// at the front?

    Yes.

    Surely my .htaccess folder is now out of date...

    Your .htaccess file should have nothing to do with it.

  18. Milsie
    Member
    Posted 1 year ago #

    This is interesting.. my Siteurl and Home entry on the database both revert back to the unwanted URL's after I have visited the site. Are these being controlled by the index.php file in the root or perhaps the .htaccess file in either the route or the sub directory?

    I changed both Siteurl and Home to:
    http://s414604449.websitehome.co.uk/touchtitanium/
    ..and got an error 404 page all reading perfectly with theme applied. But now it's reverted back to:
    http://touchtitanium.com/touchtitanium/blog

    I have altered both index.php and .htaccess files a bit - whilst following the instructions.. possibly not accurately. Any thoughts?

  19. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    I changed both Siteurl and Home

    Which method did you use?

  20. Milsie
    Member
    Posted 1 year ago #

    Changing the URL directly in the database

    [No bumping. If it's that urgent, consider hiring someone.]

  21. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    What do you have in your.htaccess file? It shouldn't need editing.

  22. Milsie
    Member
    Posted 1 year ago #

    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  23. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Remove any .htaccess file in the root folder and ensure that the file in the blog folder contains:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>
    # END WordPress
  24. Milsie
    Member
    Posted 1 year ago #

    Thanks for the instructions. I have done this but am getting the following results:

    No change on the display of the site. Still no stylesheet/theme applied.
    No content loading correctly, showing Error 404.
    Admin panel not accessible, it's just showing a small square with a while fill which is so useful I'm overwhelmed.

  25. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    No - http://touchtitanium.com/touchtitanium/blog is now showing an error 500.

    Where, exactly, is WordPress installed is relation to the root domain?

  26. Milsie
    Member
    Posted 1 year ago #

    Same has happened again, the MySQL database has reverted back to the address which doesn't work:
    http://touchtitanium.com/touchtitanium/blog

    ..instead of the correct one which is:
    http://s414604449.websitehome.co.uk/touchtitanium/

  27. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Where, exactly, is WordPress installed is relation to the root domain?

  28. Milsie
    Member
    Posted 1 year ago #

    The root domain seems to be:
    http://s414604449.websitehome.co.uk

    I have WordPress installed in:
    http://s414604449.websitehome.co.uk/touchtitanium/

    I would really like it to point to:
    http://www.touchtitanium.com

    ..which is what I was trying to do but now I'm trying to just fix it.

  29. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    1. Remove any copies WordPress files from the root domain folder.

    2. Change the urls back to http://s414604449.websitehome.co.uk/touchtitanium/ using one of the methods described in Changing_The_Site_URL

    3. Update the WordPress .htaccess file to:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /touchtitanium/index.php [L]
    </IfModule>
    # END WordPress
  30. Milsie
    Member
    Posted 1 year ago #

    ok. Now I load the page and it displays error 404 with correct styling. Reload that same page and it displays without a stylesheet and both the sireurl and home entries in the database have reverted back to:
    http://touchtitanium.com/touchtitanium/blog

    There is now no .htaccess in the root, and the one in the sub matches yours above.

Topic Closed

This topic has been closed to new replies.

About this Topic