WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] In IE8, 9 Jetpack reduces iFrame YouTube, Vimeo Video Into Thumbnail (14 posts)

  1. something07
    Member
    Posted 1 year ago #

    I installed Jetpack this a'noon in my blog, and surprisingly all the iframe embedded YouTube and Vimeo videos got reduced to the size of thumbnail with lots of space above in IE 8 & 9. I uninstalled Jetpack and everything became normal.

    This thing is happening with a few other plugins as well...and in IE. FF and Chrome work fine.

    Pl suggest what could be the reasons.

    My website: http://hubskills.com/

    http://wordpress.org/extend/plugins/jetpack/

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Deactivate the Photon module in Jetpack.

  3. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks for the report.

    We're aware of the issue, and we have now fixed it. The fix will be available in the next Jetpack release.

    In the meantime, @esmi is right, you should disable the Photon module in Jetpack.

  4. something07
    Member
    Posted 1 year ago #

    Thanks esmi and Jeremy.

    The problem remains. Photon came 'deactivated' by default. Upon your suggestions, I ensured that it remains deactivated. Yet the problem in IE remains.

    Example: http://hubskills.com/wordpress-modal-feedback-form-to-collect-visitor-comments/

    Incidentally, this problem is arising with a few other plugins as well...and that too only in IE.

  5. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you let me know how you embedded this video?

    Did you paste the video URL on a separate line, as explained here?
    http://codex.wordpress.org/Embeds

    Or did you use one of Jetpack shortcodes, as described here?
    http://en.support.wordpress.com/videos/youtube/

  6. something07
    Member
    Posted 1 year ago #

    I used the usual YouTube/Vimeo iframe code as under:

    <iframe width="560" height="315" src="http://www.youtube.com/embed/K3xm6XB680Q" frameborder="0" allowfullscreen></iframe>

  7. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Can you try using oEmbed, by just pasting the video URL on a separate line, lie so:

    http://youtu.be/K3xm6XB680Q

    Let me know if that helps.

  8. something07
    Member
    Posted 1 year ago #

    Appreciate your help Jeremy...but I only have bleak news.

    I tried all of the below...to no avail.

    1. Pasted the above video URL in a separate line

    2. Installed 'Enable oEmbed Discovery' plugin

    3. Added the code if ( ! isset( $content_width ) ) $content_width = 600; in functions.php file

    4. Unchecked 'Crop thumbnail to exact dimensions' at Settings > Media Settings in my blog admin

    5. Increased Medium size to 600x600 at Settings > Media Settings

    But none of the above could ensure proper display ofvideo in IE.

    I've also observed the following:

    1. Every time I open or refresh a page in IE 8/9, the video displays properly, and then shrinks to a size 0f 300x150 as the full page is uploaded. This perhaps means that when the browser comes across a specific code as the page is loaded, the video shrinks to 300x150 size.

    2. Just FYI, as I mentioned before, the same problem occurs with a few other plugins like for example, Usernoise modal feedback.

  9. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you try to disable all the active plugins on your site, one at a time, and see if one of them has an effect on the embeds?

  10. something07
    Member
    Posted 1 year ago #

    Jeremy, I'll test and come back..

  11. something07
    Member
    Posted 1 year ago #

    Sorry Jeremy for reporting late. I did test by disabling the plugins I'm using one by one. As it turned out there are quite a few plugins that conflict with Jetpack. One of these - related posts plugin - I really want...and so I've rather kept that in my blog..

  12. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you clarify this for me? By deactivating some of your plugins, including a related posts plugin, you've managed to solve the issue with the display of youtube videos on IE?

    Could you post links to the different plugins that cause issues with videos when they're enabled?

    Could you also try to disable the Shortcode module in the Jetpack menu, and see if that helps?

  13. something07
    Member
    Posted 1 year ago #

    What happened is like this.

    1
    I have been using a number of plugins, and also using the iframe embed code for my YouTube videos in the blog posts. The embedded videos were displaying ok in all browsers including IE.

    2
    The fist trouble arose when I installed the Usernoise plugin (http://wordpress.org/extend/plugins/usernoise/). With this plugin activated, the embedded YT videos reduce to 300x150 pixel size in IE. I raised this issue in the Usernoise plugin support, but haven't received any reply. So I deactivated the plugin.

    3
    Next, when I installed Jetpack, the same problem arose in IE. This prompted me to raise this issue in this forum.

    4
    Upon your suggestion Jeremy, I deactivated all plugins except Jetpack. The video is displaying ok in IE. Then I started activating one plugin at a time to see when the problem comes. I found that the problem is coming with the following plugins:

    5
    Since I need the related posts slider, I am using this plugin and also 'dynamic to top', and I'm not using Jetpack now. I'm not using the WP Video Lightbox also.

    6
    I am not using shortcode to embed the video. I am either using the iframe code or just the YouTube URL.

  14. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks for providing more details about your problem, it's very helpful.

    Your theme, as well as the plugins you mentioned, all include their own version of the jQuery Easing library. While the library itself might not be the source of the issue, you might be experiencing jQuery conflicts on your site.

    Could you to the Jetpack menu in your dashboard, and disable the Shortcodes module? Even if you don't use the shortcodes in your posts, I would like to make sure that the module doesn't conflict with one of the other plugins.
    You can find out how to disable Jetpack modules here:
    http://jetpack.me/support/#turn-off-jetpack-modules

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic