WordPress.org

Ready to get started?Download WordPress

Forums

Display Widgets
[resolved] Improper Namespacing (6 posts)

  1. Luke Mlsna
    Member
    Posted 1 year ago #

    I've been informed by a couple users that this plugin clashes with one of mine, the Custom Meta Widget. Your plugin inserts HTML inputs using the namespace of whatever widget it is modifying instead of using its own namespace. With a large number of very simply titled options names, this plugin has a huge potential for breaking a large number of widget based plugins.

    It would be a best practice for you to append your own plugin's namespace to these HTML input's names and would probably fix half the support questions here. When you're modifying other authors' widgets in ways they can't predict, it's up to you to make sure those changes aren't breaking things. Using 'displaywidgets-login' instead of 'login' as an option name means you won't break every single widget that happens to have a login option.

    I'd be happy to help you make the necessary changes if you'd like. Thanks.

    http://wordpress.org/extend/plugins/display-widgets/

  2. davereed42
    Member
    Posted 1 year ago #

    Thanks for posting about my whiny complaint over there. Actually, it's been so long now that I don't remember what problem I had. Funny, that.

    I do appreciate the time and effort it takes to make these things.

    Best regards

  3. Luke Mlsna
    Member
    Posted 1 year ago #

    No problem, it looks like this plugin hasn't been updated for awhile so I'm just trying to get a hold of the author to fix it since I've had two reports on my plugin's support page.

  4. sswells
    Member
    Plugin Author

    Posted 1 year ago #

    @bitacre, we've updated this in v1.23, but you can change naming in your plugin as well.

  5. singfa
    Member
    Posted 1 year ago #

    I have a problem to show the Custom Meta widget only for Logged-out users.
    If i check in Custom Meta login: Show "Register/Admin and Show "Log in/out" link after i save automaticaly both of Show only for Logged-out users and Show only for Logged-in users is checked.
    What can i do ?

  6. sswells
    Member
    Plugin Author

    Posted 1 year ago #

    You can update.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic