WordPress.org

Ready to get started?Download WordPress

Forums

Easy Recipe
[resolved] Impossible to install? (15 posts)

  1. MarkasKR
    Member
    Posted 1 year ago #

    Warning: Invalid argument supplied for foreach() in /var/www/vhosts/removedmydomainame/httpdocs/wp-admin/includes/class-wp-upgrader.php on line 558

    :/

    http://wordpress.org/extend/plugins/easyrecipe/

  2. AshlAr_Marketing
    Member
    Posted 1 year ago #

    Same here.

    I was running the plugin for a while. I wanted to do the update today, which didn't go as planned.

    The updating process started hanging. I removed all files through FTP and uploaded it again through FTP, since installing within WP didn't work.

    After uploading all files the plugin doesn't show in the plugins list. When I search for the plugin through "Plugins->Add New" it says "Installed".

    I'm stuck with this. Got a bunch of work lined up because of this now. All recipes need manual review.

  3. oprisra
    Member
    Posted 1 year ago #

    Same issue here. Would love to hear a solution. I'm new to this...how do you remove files from FTP? And what is FTP?

    I've tried installing the zip file even though the Plugins page says it's installed. However, when I try to look for it in my Plugins, it's not there. Would love to hear a response to this.

  4. trampli1
    Member
    Posted 1 year ago #

    I'm having the same trouble...Everything was fine this morning, when I did a post. Then I did the update, a few hours later went to work on something else, and now my plugin's missing. I've since deleted the plugin files, and am trying to reinstall it. And it doesn't seem to be going well.

  5. RTM Communications
    Member
    Posted 1 year ago #

    Same problem here - installing directly from WordPress results in this error:

    Installing Plugin: Easy Recipe 3.2.1211
    Downloading install package from http://downloads.wordpress.org/plugin/easyrecipe.3.2.1211.zip…

    Unpacking the package…

    Installing the plugin…

    The package could not be installed. No valid plugins were found.

    Plugin install failed.

  6. ErinD
    Member
    Posted 1 year ago #

    I'm having the same issues. I even ran wget to the zip file and installed manually at the command line, but the plugin isn't showing up at all in my plugins list. Further, when I try to install it from WP itself, it just times out trying to download.

    It looks like today's update broke a lot of stuff - one site's unupdated plugin wouldn't even show up in her plugins list anymore.

    This is a serious issue for many of my customers.

    Thanks for any help!

  7. Jayce53
    Member
    Plugin Author

    Posted 1 year ago #

    This issue should be fixed with the latest build (1213)

  8. ErinD
    Member
    Posted 1 year ago #

    When searching for Easy Recipe from the Add New page, it finds the plugin, but there is no install link.

  9. ErinD
    Member
    Posted 1 year ago #

    Belay my last - it's showing up now, thank you.

  10. oprisra
    Member
    Posted 1 year ago #

    I'm still not seeing the Install link. Easy Recipe is also not showing up on my installed Plugins. When I try to download the latest build 3.2.1215, it gives me an error. Where can I find the 1213 build to install that?

  11. ErinD
    Member
    Posted 1 year ago #

    oprisra - have you removed the old files? you may have to do it via FTP or from the command line, if you have access to it. it will be in your wp-content/plugins directory, in a directory itself called easyrecipe.

  12. Jayce53
    Member
    Plugin Author

    Posted 1 year ago #

    If you're having problems updating, use ftp or your server control panel and delete the "/wp-content/plugins/easyrecipe" directory. You won't lose any data.

    The latest version is now 3.2.1215

  13. ErinD
    Member
    Posted 1 year ago #

    This does beg the question, though, of whether the plugin update 3.2.1212 was "tested in production."

  14. Jayce53
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin is fine - we run every release through an automated test suite that checks that we haven't broken previous fixes and also checks compatibility with over 40 themes.

    The install problem wasn't with the plugin itself - it was that some idiot (me!) copied the wrong directory to the WordPress repository.

  15. ErinD
    Member
    Posted 1 year ago #

    Hey, thanks for the honesty! I know things like that happen (er, not that I've ever had anything similar... heavens no!)

    Much appreciated. :)

    It's been That Kind of Week, for sure.

    Thanks for the quick fix!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.