WordPress.org

Ready to get started?Download WordPress

Forums

Impossible see my page templete :O (5 posts)

  1. Andrea Barghigiani
    Member
    Posted 4 years ago #

    Hey folks! I have little troubles trying to add a Page Template for my WordPress installation online (I've got also a local installation of it and the directories are sync.

    So until now should sound good! But when I create my new page template gallery.php and I add the following code:
    <?php /* Template Name: Gallery */ ?>

    The online doesn't show nothing but instead on my local installation everything works fine! I see the section Template with his drop-down menu...

    Am I missing something???

    The folder sync is only the template, shall I check some config file of WP looking for differences? Can u advice me where?

    BTW the version of wordpress is 2.9.2 but i didnt find the voice in the menu

  2. henkholland
    Member
    Posted 4 years ago #

    Gallery or gallery (no caps).
    I mean: <?php /* Template Name: Gallery */ ?> or <?php /* Template Name: gallery */ ?>
    And the one on the server is visible in your themes folder?

  3. simplethemes
    Member
    Posted 4 years ago #

    Probably stating the obvious here, but did you check to make sure the Gallery page template is selected in the edit panel of the online page entry?

  4. Andrea Barghigiani
    Member
    Posted 4 years ago #

    Ok ok,
    I usa gallery.php as a file name instead i'm using Galery to describe the name of the Template Page (also in the WordPress Docs they are showing that is possible create a page like snarfer.php and call it like Snarfer in the declaration of the Template Name.

    To show you better that I don't have that option in my page entry edit pannel, I mede some screenshot :D

    I hope that after gave a look at those images you can help me a bit more :D

    @henkholland: what do you mean with "And the one on the server is visible in your theme folders?". Maybe you mean if the file is present in the directory of my theme or which kind of permissions the file has got?

    BTW hanks till now guys!

  5. henkholland
    Member
    Posted 4 years ago #

    Hi Pr0v4
    Now it's clear and this is very strange. Because what you saw in your local installation, you offcourse knew exactly that you were missing the Template Select box under Attributes. That box is always visible, even if you have no own page templates.

    I would suggest re-uploading the complete wp-admin and wp-includes folders.
    If that does not help, you could switch to the default theme and de-activate all your plugins (but this is just guessing, because I have never heard of this problem).

Topic Closed

This topic has been closed to new replies.

About this Topic