WordPress.org

Ready to get started?Download WordPress

Forums

Importing from another WordPress install - stops randomly (6 posts)

  1. pad
    Member
    Posted 6 years ago #

    Hi all

    I've successfully exported my wordpress .xml file from the Manage > Export section. Not thinking there would be problems, I deleted the entire database.

    Now, importing into a new install, WordPress only imports 240 pieces of imformation. It asks me to map users and stuff, but when it gets going it stops at 240. Checking the .xml file, all my posts and comments are in there.

    Any ideas why it stops?

  2. pad
    Member
    Posted 6 years ago #

    Sorry to bump but this is sort of an urgent issue!

    I feel stupid for deleting the database but this import feature just is NOT working! The .xml file is complete and right, at around 5mb! It only imports 240 or so of my thousands of posts!!

    Please help!

  3. Trent Adams
    Member
    Posted 6 years ago #

    If your host maxfileupload is less than the size of the file, it will get stuck. Sometimes shared hosts will also die if the import file is too large.

    You might have to do what I have had to do on occation. Break the file up so that you are trying to upload many smaller files rather than one big one.

    Just make sure each file has:

    <rss>
    <channel>
    <item>
    </item>
    </channel>
    </rss>

    Obviously break the files up around the <item> tags.

    Trent

  4. laslo
    Member
    Posted 6 years ago #

    Well if worths for something: I'm trying the "breaking into pieces the big XML file", one of 29MB. So far it worked fine with 3 XMLs, of 2, 3 and 4MB. But now with one of 5.3MB the importing process is stuck in "importing post #556.."

    And I configured my php.ini to support even bigger files...

    Looks like WP chokes with files bigger than 5MB. Or someone else had luck with bigger files?

  5. llworldtour
    Member
    Posted 5 years ago #

    Hi -
    I'm having the same problem. I get this message when i try to import my XML file: The uploaded file exceeds the upload_max_filesize directive in php.ini.

    Can someone PLEASE please walk me through how to find and change the 'php.ini' file. I'm very new to this.
    I'm trying to find help and my blog is stuck in limbo until i do.
    Thanks so much-
    LLworldtour.com

  6. llworldtour
    Member
    Posted 5 years ago #

    Hi all-
    Just want to let you know that finally BLue Host (my server) folks helped me. AND i did not have to split my XML file into smaller files. All i can say is this is what the support tech said he did:

    I went through and cleared all the php.ini's. I disabled FastCGI. I then created a brand-new php.ini.default; I fixed the parameters, renamed it, and put it in the proper folders. Logged out and logged back in...
    Set php5 again to take effect of the changes

Topic Closed

This topic has been closed to new replies.

About this Topic