WordPress.org

Ready to get started?Download WordPress

Forums

Imported WordPress and my websites appear blank in browser (8 posts)

  1. jorgepi
    Member
    Posted 2 years ago #

    Hi:
    I am moving 2 wordpress blogs to a new webserver. I have a backup of the 2 databases. In the new server, I copied my public_html folder to my server and created the databases and users using instruction provided by wordpress:
    $ mysql -u adminusername -p
    Enter password:
    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 5340 to server version: 3.23.54

    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

    mysql> CREATE DATABASE databasename;
    Query OK, 1 row affected (0.00 sec)

    mysql> GRANT ALL PRIVILEGES ON databasename.* TO "wordpressusername"@"hostname"
    -> IDENTIFIED BY "password";
    Query OK, 0 rows affected (0.00 sec)

    mysql> FLUSH PRIVILEGES;
    Query OK, 0 rows affected (0.01 sec)

    mysql> EXIT
    Bye
    $

    Then, I accessed my server through phpmyadmin and imported each of the databases. No errors were shown during import. When I try to access my webpage of any of the 2 blogs, I get a blank screen in the browser, no errors are shown.

    The database names, usernames and passwords are the same in the old and new server. So, I didn't change anything in the wp-config.php file.

    Thanks for your help!

  2. danhgilmore
    Member
    Posted 2 years ago #

    Have you:

    - disabled all plugins?
    - checked your webserver's error laws?

  3. jorgepi
    Member
    Posted 2 years ago #

    I didn't disbled pluggins before backing up.
    I just enabled display_errors in the php.ini file and when accessing website through browser, the following error is shown:

    Warning: require(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Anguilla' for 'AST/-4.0/no DST' instead in /var/www/virtualdomains/domain1.com/wp-settings.php on line 21 Warning: require(/var/www/virtualdomains/domain1.com/wp-includes/load.php): failed to open stream: Permission denied in /var/www/virtualdomains/domain1.com/wp-settings.php on line 21 Warning: require(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Anguilla' for 'AST/-4.0/no DST' instead in /var/www/virtualdomains/domain1.com/wp-settings.php on line 21 Fatal error: require(): Failed opening required '/var/www/virtualdomains/domain1.com/wp-includes/load.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/virtualdomains/domain1.com/wp-settings.php on line 21

    I have another domain in this server and WordPress is running in that one without problems, but it is a new installation and a new database.

  4. danhgilmore
    Member
    Posted 2 years ago #

    Per "Warning: require(/var/www/virtualdomains/domain1.com/wp-includes/load.php): failed to open stream: Permission denied in /var/www/virtualdomains/domain1.com/wp-settings.php on line 21" your web server doesn't have rights to read the required WordPress files.

  5. jorgepi
    Member
    Posted 2 years ago #

    What can I do? Change folder permission?

  6. jorgepi
    Member
    Posted 2 years ago #

    Ok, the timezone error got fixed by adding the following line in the php.ini file with my time zone:
    date.timezone = "America/Anchorage"

    The Permission denied error, still getting it.

  7. danhgilmore
    Member
    Posted 2 years ago #

    Not sure how your host does it, so I can't give you the exact answer, but all of the WordPress files/folders need to be owned by the account that your server uses to read/write/execute PHP files. In my case, it's Apache.

  8. jorgepi
    Member
    Posted 2 years ago #

    I am hosting my own webserver. I have Apache installed, so I guess it can be the same as your case.

Topic Closed

This topic has been closed to new replies.

About this Topic