WordPress.org

Ready to get started?Download WordPress

Forums

Imported and new images don't appear (4 posts)

  1. citizensagaainst
    Member
    Posted 7 years ago #

    I moved over to WP from Blogger this past weekend and none of my images are loading.

    The page (heresyourwater.com/wordpress) takes a long time to finish loading, probably because it's looking for images.

    I hosted my Blogger blog on Dreamhost, my web server provider, so the images not showing up is especially strange.

    And the two times I've uploaded images to new posts via WP, they don't show up either. Just "links" to the images, but clicking the link produces an error.

    The "uploads" directory exists, I have shell access...what's going on? I'm not getting any errors from WP, so this lack of feedback is making troubleshooting even harder. Any ideas?

    Thanks in advance!

  2. ccoupe
    Member
    Posted 7 years ago #

    Two problems. Looking at the view source, I suspect you don't want '/> 'at the end of the img tag. Try '>' and see what happens.

    When when I click on it. Safari barfs up with "Too many redirects occurred trying to open “http://www.heresyourwater.com/hotlink.gif”

    Which is nothing like the link it should be, but it does explain the slow loading. If I had to guess you set up some .htaccess level redirects that aren't working like you want.

    If enter "http://www.heresyourwater.com/wordpress/wp-content/uploads/2007/06/toofunny.jpg" in the browser bar I get the picture - late 1800's B/W/

    Try the default theme and disable plugins and see if it the img and links work. Then enable the plugins until it breaks and if it doesn't it's a theme problem.

  3. citizensagaainst
    Member
    Posted 7 years ago #

    Ah - ha!! Thank you thank you thank you!

    I was having a lot of trouble with hotlinking so I disabled that with the .htaccess file. I'll worry about that later.

    I never even thought of that - you've been a great help.

    I didn't hand code the images, so the "/> was put in automatically. Plus isn't that W3C best practices?

    I'm not running any plugins.

    Thanks again!

  4. ccoupe
    Member
    Posted 7 years ago #

    If the '/>' works now, great. I'm not a stickler on "proper" or "not proper". WP does a lot things under the covers to hide errors. It has it's own set of rules.

    Completely off topic. I've had some hot linking problems in the past and I fixed them by putting up a new image with "You're stealing my picture, learn how to copy it" photoshopped across it". The words became harsher as the violation got worse. I dup'ped the real picture with a different file name and changed my blog post to point to that dup'ped (original) so real readers go the unedited picture. Sometimes a little Social Engineering works wonders.

    .htaccess can be a chainsaw when a cordless drill is all that's needed.

Topic Closed

This topic has been closed to new replies.

About this Topic