WordPress.org

Ready to get started?Download WordPress

Forums

Import not working (5 posts)

  1. towerone
    Member
    Posted 6 years ago #

    I am importing from a wordpress export (xml) 111 posts. When I import all 111 are listed. however when I manage posts only 48 are shown. I have seen a post refering to MySQL queries ( http://wordpress.org/support/topic/117623?replies=4 ) but I am a relative newbie and certainly not a programmer. the attraction of WordPress is that it is simple to use!

    Any help appreciated.

  2. theapparatus
    Member
    Posted 6 years ago #

    usually when folks have an issue with importing one of those xml files, it's because the file is huge as they've also exported out their comment spam. If you're using akismet or another anti comment spam plugin, it's suggested that you deal with the spam queue first before exporting. That may be your issue.

  3. MichaelH
    Member
    Posted 6 years ago #

    towerone--that thread you point to makes the point that in your wp_posts table there is a field called post_type and that field had no value on the imported posts.

    If you use something like phpMyAdmin and look at your wp_posts table do you see your imported posts (all of them)?

    And the ones that don't appear in Manage->Posts, what value is in the post_type (column) for each of those records (rows)?

  4. towerone
    Member
    Posted 6 years ago #

    Thanks to you both. I have looked at phpMyAdmin and see only 48. The question is therefore why when I import do i see 111 imported (and each is individually identified)on the post import tool, but only 48 appear?

  5. doorlight
    Member
    Posted 6 years ago #

    Must be your internet connection? I always encounter this every time I make a back up using the EXPORT inside WP. What I do is, after I downloaded the EXPORT file, I search (CTRL F) the last post I made and if it is not there, my export fails.

    same thing with IMPORT.

Topic Closed

This topic has been closed to new replies.

About this Topic