WordPress.org

Ready to get started?Download WordPress

Forums

import my WXR (XML)file to wordpress (5 posts)

  1. nazakatali32
    Member
    Posted 7 months ago #

    Hi, I am trying to import my WXR (XML)file to wordpress. it starts importing and after few minutes it stops importing. When i check pages,posts,library there are few pages and post which are not imported.I tried again and again but it does not import contents completely. WordPress does not show any error.
    What is the problem? The size of WXR file is 4 mb. If any one know the reason please help me?

  2. ClaytonJames
    Member
    Posted 7 months ago #

    I'm just taking a guess here, but the import interruption might be related to the maximum file upload size allowed by your PHP settings. It's usually around 2MB by default.

    Locate your php.ini file and find these two entries:

    upload_max_filesize = 2M

    ...and

    post_max_size = 8M

    Try changing both of those values to 10M, save the changes, and see if that makes any difference. For the changes to take effect, you may need to restart apache after you finish editing the php.ini file.

  3. nazakatali32
    Member
    Posted 7 months ago #

    In my php.ini file settings are:

    upload_max_filesize = 128M and post_max_size = 8M
    Now, what i will do? Please tell me solution?

  4. Pioneer Valley Web Design
    Member
    Posted 7 months ago #

    You can put any # you want in the ini file, what matters is what the limit is as set by the host config. Contact host.

    See this also:

    http://www.wpbeginner.com/wp-tutorials/how-to-split-large-xml-files-in-wordpress/

    Also, see this on how to review what your php settings are:

    Create a phpinfo.php file which simply contains:

    <? phpinfo(); ?>

    And upload to the root of your WP install, then browse to the file:

    myblog.com/phpinfo.php

    http://codex.wordpress.org/Finding_Server_Info

    Review (or post link once done if unsure).

  5. ClaytonJames
    Member
    Posted 7 months ago #

    @nazakatali32

    Since you posted your question in "Localhost Installs", we'll be making the assumption that you have full access to the server-side php.ini file, and "contact your host" does not apply.

    "upload_max_filesize = 128M and post_max_size = 8M"

    Let us just take a minute to review what we have talked about. You have said that your WXR file is only 4MB. I have suggested that you change both of the above settings to 10M each. If that is the problem, that should be sufficient to make it work.

    While you have chosen to change the settings to: upload_max_filesize = 128M and post_max_size = 8M, that will probably also work - if it is the problem. One thing you may need to do after making those changes, is restart apache - or whatever web-server you use - to make sure the changes take effect.

    Now, what i will do? Please tell me solution?

    Restart the web server and try to import the file again. If that still won't work, you may want to read this information and see if any of the suggestions you find there might help: How do I Import a WordPress WXR file when it says it is too large to import?

Reply

You must log in to post.

About this Topic