WordPress.org

Ready to get started?Download WordPress

Forums

Import Blogger: Unable to login (26 posts)

  1. Addict
    Member
    Posted 8 years ago #

    I'm trying to import my posts from Blogger using the Import > Blogger feature in WP 2.0. When I enter my username & password in the importer it errors out with: Failed to connect to 66.102.15.100: Permission denied.

    Any ideas? I have CURL enabled and I can log into the Blogger site. Thanks...

  2. simonpockley
    Member
    Posted 8 years ago #

    I have another problem.

    I want to set up a blog with an email address that I have previously used at WordPress but cannot rememeber where I used it.

    How do I cleanse WordPress of my past?

  3. Addict
    Member
    Posted 8 years ago #

    What does that have to do with my topic?

    Hopefully someone has some ideas for this one.....

  4. rustifer
    Member
    Posted 8 years ago #

    You don't specify whether you've upgraded to 2.0.2 yet; I tried with my 2.0.1 install, and was able to log in. If you get the password wrong, you get an "invalid password" screen, not an "access denied" message.

    Have you tried this again? Maybe Blogger was having some problems?

  5. Addict
    Member
    Posted 8 years ago #

    I've upgraded to 2.0.2. I still have the same issue as of about a minute ago.

    Any ideas?

  6. HannahIm
    Member
    Posted 8 years ago #

    I have the same problem. My webhost (Yahoo) automatically imstalls all WP updates, so I guess I'm also using 2.0.2. Whenever I try to login to the importer with my Blogger ID, I get this message "Login failed. Please re-enter your username and password." I definately have entered my info correctly,so. . . What to do?

  7. Chris_K
    Member
    Posted 8 years ago #

    Addict - just to make sure I understand. You can log in as admin to your wordpress blog, but it is the blogger import that's giving you the error? Is your error message same as HannahIm's?

  8. Addict
    Member
    Posted 8 years ago #

    Yes I can log into the WP Admin. I can also log into Blogger without issues (via the Blogger site).

    There's two error message that appear in the blogger import.
    One at the very top that says:
    Failed to connect to 66.102.15.100: Permission denied

    And one near the username/password fields that says:
    Login failed. Please re-enter your username and password.

  9. Chris_K
    Member
    Posted 8 years ago #

    I can only offer two guesses.

    1) The interface to blogger for importing has changed and WP is out of date.

    -or-

    2) Blogger is blocking access to the interface.

    Hopefully somone brighter will wander by.

  10. Addict
    Member
    Posted 8 years ago #

    That was kind of my thinking. Guess we'll see if anyone else has an idea.

  11. Addict
    Member
    Posted 8 years ago #

    It looks like it may be a web host issue. Apparently they don't allow socket connections to remote hosts. Sucks for me.

    Here's a simple PHP script that can be used to test this.


    <?php
    $ch = curl_init();

    curl_setopt($ch, CURLOPT_URL, "http://www.google.com/");
    curl_setopt($ch, CURLOPT_HEADER, 1);
    curl_setopt($ch, CURLOPT_VERBOSE, 1);
    curl_setopt($ch, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_1_1);
    curl_setopt($ch, CURLOPT_USERAGENT, 'Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)');

    $result = curl_exec($ch);

    echo '<pre>INFO';
    print_r(curl_getinfo($ch));
    echo '</pre>';

    echo '<pre>RESULT';
    print htmlentities($result);
    echo '</pre>';

    echo '<pre>CURLERR';
    echo curl_errno($ch) . ' ' . curl_error($ch);
    echo '</pre>';

    echo '<pre>CURLVERSION';
    echo curl_version();
    echo '</pre>';

    curl_close($ch);
    ?>

    Just thought I'd post back to this in case anyone else has this same issue. I imagine my web host isn't the only one that doesn't allow remote socket connections.

  12. Odyssean
    Member
    Posted 8 years ago #

    I am having the same problems as Addict -- anyone working on this? I'd love to finally flee Blogger and fully transition to WordPress.

    Also, being a novice PHPer, can you tell me how to "run" that script testing the socket connection?

  13. Addict
    Member
    Posted 8 years ago #

    Copy the text (from <?php to ?>) and paste into a file. Name the file test.php. Upload it to your server. Access it via your web browser (http://www.yoursite.com/test.php).

    It will show you the output.

  14. sueeeus
    Member
    Posted 8 years ago #

    Apologize in advance if this is a repeat, but I'm a novice too and having trouble importing from blogger. I'm still getting the "Please enable the CURL extension for PHP and then reload this page" message, even after my host/provider said they enabled curl for me. They said CURL support enabled, CURL Information libcurl/7.10.5 OpenSSL/0.9.7b zlib/1.1.4.

    Any ideas why it's not recognized? I just installed wp yesterday, so assume it's the latest version... Thanks.

  15. Odyssean
    Member
    Posted 8 years ago #

    Addict, I ran the script as you suggested, and it gave me:
    RESULT
    CURLERR7 Failed to connect to 66.102.7.147: Permission denied
    CURLVERSIONlibcurl/7.15.1 OpenSSL/0.9.7d zlib/1.1.4

    Do I have a similar socket connection issue as yours? And, if so, is there no way around it?

  16. Poco
    Member
    Posted 8 years ago #

    What worked for me when I had import problems was to do the import to a local PC server. The idea is to import to your own server and then copy the Database as described here http://codex.wordpress.org/Moving_WordPress. See this thread http://wordpress.org/support/topic/60220?replies=4.

    I still haven't gotten around to copying those posts to my real blog since I also started working on a photo importer to go with it here http://notions.okuda.ca/wordpress-plugins/blogger-image-import/.

    I really should get around to proving out this technique by actually copying my DB tables to my real WP blog. I just never have the time. It is still a viable idea though.

  17. sueeeus
    Member
    Posted 8 years ago #

    I gave up and followed the threads Poco posted, installed easyPHP on my own local machine, etc etc etc, and eventually, finally, got my blogger stuff migrated to wp. Thanks for the tips. I used the image import plugin too, and it seems to have worked.

  18. daiko
    Member
    Posted 7 years ago #

    Any ideas on the CURLERR7 ?

    I have my own LAMP installation with PHP 5.1.4 and CURL 7.15.5 Apache/2.2.2 on Fedora Core 5.

    How can I fix this in my own server environment?

  19. Poco
    Member
    Posted 7 years ago #

    From the original error message it looks like CURL is enabled but not able to access blogspot. Do you have any access restrictions on your server or perhaps restrictions on the user used to run the server?

    Sorry I can't help more. I eventually documented the process that I used to do the import with a Windows PC here, but that probably won't help you.
    http://notions.okuda.ca/wordpress-plugins/from-blogger-to-wordpress/

  20. daiko
    Member
    Posted 7 years ago #

    Well that is the question.... What restrictions might it be? I have a firewall with iptables, but turning that off doesn't help. I have otherwise searched the web for hours to find possible explanations. As I have full access and SSH/root to my server it should be possible to find ...

    PHP info reports curl installed and enabled.

    The test.php above fails.... with the CURLERR7 message.

    The suggestion above that the host might not allow remote socket connedtions was a hint, but I haven't found any apache or php settings that would do that... At least that is in effect on my installation.

  21. alexstanhope
    Member
    Posted 7 years ago #

    daiko, I think I have a solution to your problem. If you're using Fedora Core 5 then you may have SELinux disabling outgoing remote connections.

    I've put together a simple fix here:
    http://www.lightenna.com/news/tech_report/selinux_will_mess_with_your_curl

    Cheers, Alex

  22. Dave P.
    Member
    Posted 7 years ago #

    I'm also having this issue...can't login when trying to import from Blogger. I have tested it from my server as well as locally...same deal.

    I tried the php script and it pulls in the Google data just fine.

    When I try to login to Blogger I keep getting this:

    Login failed. Please re-enter your username and password.

    Any other ideas?

  23. darylt
    Member
    Posted 7 years ago #

    I too am having thjis problem - would it have anything to do with the recent change from blogger to blogger beta (that they are now calling blogger again!)

  24. AndyMogendorff
    Member
    Posted 7 years ago #

    Folks, I think the issue is to do with the new version of Blogger. My understanding is that now that the login is more integrated with Google's login the import wizard for WordPress hasn't yet been updated. There are other threads here which describe some workarounds. Hope that helps

  25. darylt
    Member
    Posted 7 years ago #

    Can anyone tell me how to manually insert comments into the wp db?

    As the import wont work I have added the posts from RSS, I am able to cut copy and paste the comments from my Blogger Blog and want to know where to insert them rather than me adding them using my identity - I only have a few to do!

  26. cellobella
    Member
    Posted 7 years ago #

    How much do I hate Blogger - oh let me count the ways...

    On the bright side - eventually once we work out the workarounds - it's WordPress's gain.

Topic Closed

This topic has been closed to new replies.

About this Topic