WordPress.org

Ready to get started?Download WordPress

Forums

Implement maximum word length limit warning in Write Post area (6 posts)

  1. ryanmosby
    Member
    Posted 5 years ago #

    I have some posts that contain absolutely no html, just text, that won't show up at all on my blog, except for when I'm editing them. At first I thought perhaps a symbol was upsetting the html of the rest of the page, but after some tests, I realized it was due to the length of the post.

    I found to get around this I have to divide the entry into multiple posts for the text to display. Just to find the point that will allow the maximum length of the entry takes me around a dozen tries to get right.

    Now some may say you can comment out "add_filter('the_content', 'wpautop');" in "wp-includes/default-filters.php" or use the PHP Exec plugin and add <?php remove_filter('the_content', 'wpautop'); ?> to the top of the problem pages or posts, but the first means getting no line breaks in your post, and the second means allowing php in the posts, which I do not want to allow.

    Being that this a problem that anyone and everyone could encounter at any time, and so easily, I thought I'd bring it to light for WordPress developers.

    My suggestion for WordPress is to either have:

    1. something that counts down how many characters are left to use in the entry, or
    2. for when the user publishes the entry, have a message tell them that the post is too long and excess content will be displayed in an extra post. That way if he or she has a very long entry, there would be two or more posts of it, with the same title and something like (Part I), (Part II), appended.

  2. ryanmosby
    Member
    Posted 5 years ago #

    Has this been considered at all?

  3. seankelley
    Member
    Posted 5 years ago #

    I'm having some trouble with this page-length limit as well. Anyone have any input/response to Ryan's post?

  4. UBenzer
    Member
    Posted 4 years ago #

  5. Abel Braaksma
    Member
    Posted 4 years ago #

    The "temporary" bit can be removed, I updated the page to reflect recent insights in the issue: the default PHP.INI settings are too strict for the regular expressions backtracking and recursion limit. Mere size hits the backtracking limit, different plugins, esp. with [ code ] (square brackets) hit the recursion limit. See my post for how to solve both of them, for always.

    It would be nice of the WordPress team gave some instructions when this error happens: they can catch the error instead of showing an empty page. Because the problem is so common (most people install php with the defaults), I believe it warrants special treatment.

    See: same post renewed.

    -- Abel --

  6. chartinael
    Member
    Posted 4 years ago #

    Well, my provider won't change php.ini ... any other solutions?

Topic Closed

This topic has been closed to new replies.

About this Topic