WordPress.org

Ready to get started?Download WordPress

Forums

IMonline making my wordpress load slow (10 posts)

  1. glassofshutup
    Member
    Posted 6 years ago #

    When I enable imonline and then place the widget in my sidebar it makes my blog take a long time to load. (a minute or more).

    But if I take it out of the sidebar my webpage loads very fast.

  2. mutube
    Member
    Posted 6 years ago #

    glassofshutup: In what way is it slow? Is the page slow to load (i.e. for anything to show up) or does the page load, but it takes while waiting for the images to appear?

    As a first test I'd double check your settings for the accounts and make sure the right one is selected. If it attempts to get your status and doesn't get a sensible response it tries a different server (up to 3). If none of these return anything sensible it will not cache the result so will keep polling them each time the page is loaded.

    It could also be that the setup of your server is preventing the connection required to check the online status. It needs cURL or fopen support (ask your host!)

    Anyway, have a look and if you get no further I'll see what I can figure out.

  3. glassofshutup
    Member
    Posted 6 years ago #

    I have both Curl and fopen support so that cant be it.

    It takes while waiting for the images to appear but they never do. Even if I am online.

  4. mutube
    Member
    Posted 6 years ago #

    Are the online/offline images (from inside the IM Online installation zip file) in their right place, and is the plugin installed in /plugins/im-online/ with those online/offline images available at /plugins/im-online/images/

    Check all the files are in the right place & if that's not the problem (strike 2!) can you give me the URL to your site for a closer look? Thanks.

  5. glassofshutup
    Member
    Posted 6 years ago #

    Yes they are in the right place, but still has problem.

  6. glassofshutup
    Member
    Posted 6 years ago #

    I found something interesting, If I am offline it works fine (it states I am offline, but still no images, just the word Offline.)
    But if I get online on my yahoo account and refresh my page it times out finally and gives this error

    Fatal error: Maximum execution time of 30 seconds exceeded in C:\wamp\www\blog\wp-content\plugins\im-online\im-online.php on line 247

  7. mutube
    Member
    Posted 6 years ago #

    glassofshutup: Well, at least people will know when you're online ;)

    Seriously though that's a bit strange, the plugin should be ensuring it doesn't overrun the time limit. I'll have a look into this and see if I can find a problem and patch it up.

    Thanks for the feedback.

  8. archon810
    Member
    Posted 6 years ago #

    I'm having the same issues. For the past month I've been observing erratic behavior on my blog with load times 10-60+ seconds. I didn't pay enough attention to it as it didn't happen all the time and even sometimes blamed it on mysql but until I've disabled the im-online plugin, things didn't improve.

    I'm imagining the refresh-on-the-fly approach here is really bad, due to checking servers being potentially slow to respond. A much better approach would be to have a cron-like asynchronous way to do this with the plugin just picking up the data from mysql, without doing any additional requests.

    What do you think?

  9. archer1
    Member
    Posted 6 years ago #

    I got the same thing, it made my entire system really slow - even just going to the section where you can add or remove widgets takes a minute to load instead of being instant

  10. mutube
    Member
    Posted 6 years ago #

    I've released a version 4.6 which should solve this problem. Can you test and get back to me whether it's worked for you? Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags