WordPress.org

Ready to get started?Download WordPress

Forums

Images won't show previews... (32 posts)

  1. abonoda
    Member
    Posted 4 years ago #

    I installed this theme and noticed that the images were not being shown in the preview boxes on the first page of the blog..How do I fix this?

  2. Shane G
    Member
    Posted 4 years ago #

    Hi,

    Please provide your theme name and blog address here in order to get related comments..

    Thanks,

    Shane G.

  3. wazza32
    Member
    Posted 4 years ago #

    I installed the "Brightness" theme and have the same problem as abonoda above.

    When I upload images to the posts, they appear only in the post when you open it but not as a thumbnail on the homepage, it just displays the default "No Image" on the homepage no matter what I try.

  4. Baza06
    Member
    Posted 4 years ago #

    I would also like to know how to get the images working on the home page, i aint sure where the images go. I ain't seen a readme file anywhere.

    Thanks.

  5. Ryan S
    Member
    Posted 4 years ago #

    the images are uploaded in your wp-contents/upload folder. Make sure this folder is created and your images are there..

    I dont think this is issue with the theme

  6. Baza06
    Member
    Posted 4 years ago #

    I'd already made the folder anyway, but how do i get an image to show on the home page in them boxes?

    Thanks.

  7. Baza06
    Member
    Posted 4 years ago #

    Found a help page for the theme, it's under arras theme.

  8. Ryan S
    Member
    Posted 4 years ago #

    Do you want to show the image in your posts? While creating a new post, you will find an option to add images to your post.

    Or if you want to add image to your theme, you can do this by editing the header, or index.php file and your CSS file. you need to have a fair knowledge of PHP and CSS

  9. web_guy
    Member
    Posted 4 years ago #

    Ryan,
    we are having the same issue, with thumbnails not showing up on the front page or the slideshow. I'm going to check if using content/uploads works. If not, I'll be back. (Because the theme does seem to imply that images attached to each post will appear as a thumbnail. THat doesn't happen.) I'd be happy with either thumbnails of images showing up on the front page OR categories having a banner instead. Either works for me. And the slideshow working too.

  10. web_guy
    Member
    Posted 4 years ago #

    I want the home page to NOT show a black blank over each post. And I'd like the slideshow to work. Input please?

  11. annaj
    Member
    Posted 4 years ago #

    I've this same problem (arras theme 1.3.4 on WP 2.7.x). The slide show doesn't work (images aren't slide, just text-box) and I've black blank boxes without imeges too.
    I uploaded images into wp-content/uploads but this still doesn't work.
    Someone can help us?

  12. annaj
    Member
    Posted 4 years ago #

    Yeah, I found this: http://i43.tinypic.com/4ida3n.jpg
    It's works!

  13. LSU2009
    Member
    Posted 4 years ago #

    thanks for that link annaj. hmm, i still don't get it to work on my site - http://www.merkreativamoten.se - i've checked around in the php to see if there is some defined 'get' that is pointing to something else, but, not being an expert, i can't seem to find it...

    do i need to spot the thumbnail generator and re-define some snippet of code?

  14. vapvap
    Member
    Posted 4 years ago #

    LSU2009 has right. Same problem I saw same situation after run on web server. We need to know why "thumb" if all procedure done correct - are not displaying on frontpage. Images are in good folder, paths are okey.

    For example code is:

    <img title="Welcome World" alt="Welcome World" src="http://www.projekt-design.pl/wp-content/themes/arras-theme/library/timthumb.php?src=http://www.projekt-design.pl/wp-content/uploads/2009/06/A860-2.jpg&w=630&h=250&zc=1"/>

    Where problem can be?

    On local server ewerything working fine.

  15. vapvap
    Member
    Posted 4 years ago #

    I think I found the problem:):):)

    To solve this remember, after copying from local to web your webpage, check correct permissions for folders and files.

    How to:

    1. check file premissions for folder "cache":
    /wp-content/themes/arras-theme/library/library/cache/
    Remember must be 777.

    Should be work!

  16. jessewisnewski
    Member
    Posted 4 years ago #

    This has been a beneficial topic. First off, I'm new to blogging and trouble shooting theme's. Second, I've just uploaded the "Arras Theme" for my blog at http://pre-em-i-nence.com Finally, I'm having the same problem that others are having.

    I'm following the instructions provided by arras themes in posting thumbnails (http://www.arrastheme.com/wiki/post_thumbnails); however, I'm having a similar problem that others are: the images are not showing up at all.

    For vapvap: how do I access the folder that you refer to in order to see that my "cache" is 777? Thanks in advance for your help!

  17. grundic
    Member
    Posted 4 years ago #

    same problem, and i found that index.php is empty, how is that possible?

  18. dwinfrey
    Member
    Posted 4 years ago #

    Couple of notes.
    vapvap, your address has library twice, which resulted in an error in my case.
    With the address:

      http://www.your-domain.com/wp-content/themes/arras-theme/library/cache/

    I could generate an index, which had two links, one of which was parent directory.
    I could not find anything there that could be 777 or reset to 777. Thanks in advance for any help.

  19. Siljin
    Member
    Posted 4 years ago #

    Hello, I have read and re-read this entire thread looking for solutions to this problem but to no success. I have followed the instructions on http://i43.tinypic.com/4ida3n.jpg to the letter but it does not work. I uploaded my image which can be viewed here http://guerillamarketingblog.info/wp-content/uploads/2009/07/cateyes.jpg as you can see it is working correctly. When I create a custom field called thumb and use the url for the image as the value then save and update, it does NOT appear on the blog. What is wrong? Please help me!

  20. annaj
    Member
    Posted 4 years ago #

    So, after link - it works on WP 2.7.x. I was updated WP to 2.8.x and theme to newest and tadaaam - thumbnails dosn't work. Why? I don't know. I tried everything and nothing works :/
    Is there a simple solution to the problem? Who knows?

    Hey, Siljin - I see that your thumb works. How you do it?

    --Edit--
    I don't know how... but I changed the permission folder wp-content and all folders in it on the 755 (recursive) and it works!

  21. surfwinds
    Member
    Posted 4 years ago #

    Hello,everyone
    I have tried two different host on this theme.
    All test on a new install.
    WP ver.2.8.2
    This theme ver.1.3.5
    On my another host is present ok.
    But on HostGator , both the first and second featured post thumb is not displayed.
    Maybe there are some specific functions only provide on certain host.

  22. howb
    Member
    Posted 4 years ago #

    what worked for me was removing the bit before wp-content so instead of http://www.yourdomain.com/wp-content/uploads/2009/08/images.jpg you just have /wp-content/uploads/2009/08/image.jpg

  23. mattstat
    Member
    Posted 4 years ago #

    I had all the same difficulties, but it turns out the problem was the missing (in my case) GD library.

    See this post.

  24. cesaric
    Member
    Posted 4 years ago #

    I just installed this theme and it worked pretty seamlessly after I set the "cache" folder permission to 777 as vapvap had stated above. I do have the GD library installed on my server and I made sure that all my images were JPG's. It may work with other image formats but I haven't tested.

    To get the images to show up, you need to follow the directions annaj gave above (http://i43.tinypic.com/4ida3n.jpg)

    I refreshed my page and sure enough, there they were. You can see it at http://cesaric.com.

    If anyone is having trouble feel free to email me and I can shoot phpinfo screenshot or maybe post a quick how to article with screenshots if that would help.

    BTW, I'm running WordPress version 2.8.4 with the Arras theme version 1.3.5.

    Amazing Theme! Thanks Melvin for contributing this!

  25. TVThink
    Member
    Posted 4 years ago #

    howb said:

    what worked for me was removing the bit before wp-content so instead of http://www.yourdomain.com/wp-content/uploads/2009/08/images.jpg you just have /wp-content/uploads/2009/08/image.jpg

    That worked for me too. I think the way the domain is hosted may confuse WP - ie: My main domain is not the domain I have WP on - so having the leading domain info confused things. Change the thumb url to remove as howb said and it worked great! Thanks!

  26. thedailyeater
    Member
    Posted 4 years ago #

    Nothing is working for me. The link to my photo works in my browser, but won't appear on the front page. Photos appear inside the article without a problem.

    What is going on? This is quite frustrating!

  27. Zumo
    Member
    Posted 4 years ago #

  28. sajinseethi
    Member
    Posted 4 years ago #

    where do i create the custom field. I mean where is its option to create one. And please check my site. http://www.mymobilescoop.com
    its on wp 2.9.1
    image thumbnails not showing up. :-(

  29. sajinseethi
    Member
    Posted 4 years ago #

    ok i just found out where the create custom field option is !!
    so do i have to always add these links n do so. is there a plug in that does the job ??

  30. dsignr
    Member
    Posted 4 years ago #

    Hey everyone I have one solution to this that worked for me.
    In order for a post to use an image as a thumbnail, the image has to be attached to the post/page through the Media Libary.

    To add files to your Media Libary:
    1. On your dashboard, click on the Media tab, then click Add New.
    2. Click Select Files and upload your image. Once you've edited the info click Save All Changes.
    3. Your image should be listed under "File". Under "Attach To" your image is currently (unattached). Click attach. Search the post or page you want your image attached to. Once you find it click Select.

Topic Closed

This topic has been closed to new replies.

About this Topic