WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] Images Suddenly Not Light-boxing (8 posts)

  1. r.sumerall
    Member
    Posted 1 year ago #

    I've been using Easy FancyBox for a while now, and it's always worked smoothly. All of the sudden today images that were previously light-boxing are now just redirecting to the page they're in.

    I've checked each image's settings, and they are still linked to the media files.

    The plugin is still working because I have inline content that is still visible through FancyBox.

    What can I do to fix this?

    This is the site in question & best page to see issue: http://gandyprinters.com/brochure-for-bowstern/

    Thanks so much!
    Rebecca

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. r.sumerall
    Member
    Posted 1 year ago #

    Also, forgot to mention that all the images are housed in WordPress galleries.

  3. esmi
    Forum Moderator
    Posted 1 year ago #

    Are these images in a gallery? If so, you may be hitting a known bug in WordPress 3.5.1 in which all gallery images are being linked to their attachment page rather than the raw image file.

  4. r.sumerall
    Member
    Posted 1 year ago #

    Ok, thanks. What can I do to fix that?

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    OK - looks like we inadvertently cross-posted. :-)

    This bug should be fixed in the next WordPress update but, for now, you have two options that might work:

    1. If you have been using the Text editor to edit your Posts & Pages then locate the [gallery] shortcode and amend it to [gallery link="file"]

    2. Try editing the relevant Posts/Pages and creating the galleries again but, this time, toggle the "Link To" dropdown from Media File to Attachment page" and back again.

  6. r.sumerall
    Member
    Posted 1 year ago #

    Thanks so much! I'll try those to see if they help. If not, I'll just count down till the next update.

    Thanks Esmi!!

  7. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    I suppose that did the trick? Thanks Esmi, for jumping in :)

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    No problem. I was using the native fancybox script in a theme and this new bug totally threw me at first too.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic