WordPress.org

Ready to get started?Download WordPress

Forums

Images on sub-domain not getting indexed on google (4 posts)

  1. Mohammed Mazhar
    Member
    Posted 1 year ago #

    HI Guys, I've got a blog BornVirtual.com, I use all in one SEO by yoast and the sitemap also is made by this plugin, and the images [CACHED ON MAXCDN]are hosted on a sub-domain like http://cdn.bornvirtual.com/media/2012/10/wordpress-nginx-html-url-permalinks-error-solution.png, and in my webmasters tools section all my images are submitted but not indexed there is an error shown by google webmaster tools saying that images are blocked by robots.txt. How do you get images hosted on a sub-domain to index on google ? I've spent a lot of days to figure this out.

    My Robots.txt file is as shown below:

    User-agent: *
    Allow: /media/
    Disallow: /wp-includes/
    Disallow: /wp-content/
    Disallow: /wp-admin/
    Disallow: /recommends/
    Disallow: /comments/feed/

    Sitemap: http://bornvirtual.com/post-sitemap.xml
    Sitemap: http://bornvirtual.com/page-sitemap.xml
    Sitemap: http://bornvirtual.com/category-sitemap.xml

    I have tried almost possible variation possible. Can any one Give me a suggestion on this. Awaiting Help. Thanks in advance.

  2. dfunkydog
    Member
    Posted 1 year ago #

    Having the same problem, did you find a solution.

  3. Mohammed Mazhar
    Member
    Posted 1 year ago #

    Nope, i haven found the solution, but i noticed that some of my images are indexed on google images. but it does not reflect on webmasters tools. Do you have any ideas about this?

  4. jasjotbains
    Member
    Posted 8 months ago #

    Try removing Disallow: /wp-content/ from the robots.txt file

Topic Closed

This topic has been closed to new replies.

About this Topic