WordPress.org

Ready to get started?Download WordPress

Forums

Autoptimize
Images not working after enabled Optimize JS (16 posts)

  1. 4rez
    Member
    Posted 5 months ago #

    When i enable the Optimize HTML and JS, none of the images are showing. Then I disabled one by one and still not working. However, I have checked these options "Force Javascript and Look at script" and those are working without problem. I want to enable JS option to get best result.

    Kindly help.

    https://wordpress.org/plugins/autoptimize/

  2. Frank Goossens
    Member
    Plugin Author

    Posted 5 months ago #

    Hi 4rez; that means you use a plugin that uses javascript to display images? A lazy loader perhaps?

  3. 4rez
    Member
    Posted 5 months ago #

    Yes, i am using the lazy loader.

  4. Frank Goossens
    Member
    Plugin Author

    Posted 5 months ago #

    In that case you'll have to exclude the javascript-file that the lazyloader uses to load the images (and probably jquery as well) from being aggregated/ optimized.

  5. 4rez
    Member
    Posted 5 months ago #

    I have tried to add the file name in exclude list in JS column, but still it was not working. I am using the plugin called "Onepress Social Locker". I contacted the developer and they replied me those files which they are using to show the social locker. I have excluded those files by adding this - jquery.op.sociallocker.min.030204.js

    The actual path of the file is - http://your.domain/wp-content/plugins/sociallocker-next/assets/js/jquery.op.sociallocker.min.030204.js

    Please help.

  6. Frank Goossens
    Member
    Plugin Author

    Posted 5 months ago #

    did you also exclude jquery itself (either jquery.js, jquery.min.js or jquery-min.js, depending on your theme)?

  7. 4rez
    Member
    Posted 5 months ago #

    Now Optimize JS code is working, when i checked that option. However Optimize HTML code is still not working, that plugin was again not working when i checked html code option.

  8. Frank Goossens
    Member
    Plugin Author

    Posted 5 months ago #

    what happens when you check "optimize HTML"? what do you see?

  9. 4rez
    Member
    Posted 5 months ago #

    Social locker not showing. While unchecked the feature of optimize HTML, social locker again starts working.

  10. Frank Goossens
    Member
    Plugin Author

    Posted 5 months ago #

    Ah ok. Weird. Could you provide me (futtta at gmail dot com or here) with the URL for your blog so I could have a look at the social locker output without HTML optimization?

  11. 4rez
    Member
    Posted 5 months ago #

  12. Frank Goossens
    Member
    Plugin Author

    Posted 5 months ago #

    Hmmm, I see a _lot_ of stuff from social locker in the HTML, but cannot say for such what is causing the breakage.

    I might install the plugin to test and will get back once I have results.

    In the mean time I would run without HTML optimization (which is the least important one anyway).

    frank

  13. 4rez
    Member
    Posted 5 months ago #

    OK i will be wait with the solutions.

  14. Frank Goossens
    Member
    Plugin Author

    Posted 5 months ago #

    Installed social locker but couldn't get it to work, even without Autoptimize, so I won't be able to troubleshoot this I'm afraid. But as I already stated, optimizing HTML is by far the least important option, so if you need Social Locker then just leave HTML as is.

    frank

  15. 4rez
    Member
    Posted 5 months ago #

    no problem. I can able to manage A Grade score on Google speed. Can you able to integrate "served scale images" features because most of the downgrade score on google showing from served scale images.

  16. Frank Goossens
    Member
    Plugin Author

    Posted 5 months ago #

    Well, for optimizing images I'd recommend http://wordpress.org/plugins/ewww-image-optimizer/. Great plugin!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.