WordPress.org

Ready to get started?Download WordPress

Forums

Images not uploading to localhost wordpress 3.3.1 (5 posts)

  1. poprunna
    Member
    Posted 2 years ago #

    I've been trying with great difficulty to resolve this issue.
    First, I moved a few sites from the web to my localhost (Mac OS 10.6). I also installed a fresh wp site for testing plugins, etc. All sites have the same problem: the media uploader goes through the motions, shows as a successful upload, generates a url, but the image isn't there. It has no thumbnail, either. It does not show errors.

    The sites on the web never had this issue, nor have I ran into anything like this, and there are no forum threads showing this specific problem with a solution.

    I went through the applicable troubleshooting steps provided here:
    http://wordpress.org/support/topic/25-imagemedia-uploader-problems?replies=1

    No luck. Somebody please make my day!

  2. poprunna
    Member
    Posted 2 years ago #

    Not sure if this is related but I am also having trouble importing posts from my online sites' wp-exports.

  3. webmystery
    Member
    Posted 2 years ago #

    I'm seeing the same thing after switching from MAMP to MAMP Pro. I suspect it is a permissions issue. - the Pro version is stricter- Will post more when I figure it out.

  4. webmystery
    Member
    Posted 2 years ago #

    Yes - changing permissions on upload directory to 777 fixed it. I had tried setting local host permissions in Mamp Pro but it didn't take.

    See the solution here: http://wordpress.org/support/topic/not-uploading-images-on-local-wp-site?

    I was able to use Dreamweaver to change file permissions by setting up the ftp client to view the files in the remote view:

    Host directory: / (/Applications/MAMP/htdocs/ doesn't work for me)
    Hostname: localhost
    Username: your OSX user account ID
    Password: your OSX user account password

  5. Matthew Gedeon
    Member
    Posted 2 years ago #

    For me the solution to the problem was to change to "run apache server as user/user" instead of www/mysql as it suggested. Of course, then I had to restart MAMP pro (as in quit the program completely) before it worked correctly. It's something to try anyway.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.