WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Images not uploading Error (26 posts)

  1. CellaScarpi
    Member
    Posted 1 year ago #

    Is there a way to just go back to the previous version of WordPress?

    When trying to upload images I receive the following message:
    An error occurred in the upload. Please try again later.

    I tried Deactivating all plugins which I HATED doing cause this site is live and it is the middle of the day.

    Even with No active plugins it still did not work.

    I can not switch themes to see if it is a theme error, so is there a way to just go back to the previous version?

    Or something else I can try because I have got to get this fixed as soon as possible. Thank you.

    http://www.sdwr.org

  2. webmistress666
    Member
    Posted 1 year ago #

    This is happening to me with Magic Fields 2; seems to be a compatibility issue. I just rolled back by replacing all the wordpress files (except config.php and the wp-content folder) with the earlier version of wordpress, at least until a fix is found.

  3. CellaScarpi
    Member
    Posted 1 year ago #

    Where did you get the files from the previous version?
    I don't have the Magic Fields 2 plugin, none of my plugins are causing it.

  4. webmistress666
    Member
    Posted 1 year ago #

  5. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

  6. CellaScarpi - You can install the older version of WP ontop, but we can't promise it'll work (which is why we always suggest backups).

    When trying to upload images I receive the following message:
    An error occurred in the upload. Please try again later.

    That's from the in-line editor, right? What happens if you go to wp-admin/media-new.php and upload there?

  7. CellaScarpi
    Member
    Posted 1 year ago #

    Yes I've read through the Master list.

    It was not helpful in this situation.

    The only Plugin I have that should have been affected is Roles but it seems to be working just fine.

    The only thing I haven't tried, but will not try is swapping back to default theme. My theme is child themed, but I have found no one else posting issues about this with the parent theme... so far.

  8. CellaScarpi
    Member
    Posted 1 year ago #

    @Ipstenu (Mika Epstein)

    That worked for uploading the media!

    But I am unable to set featured images, I can post just fine this way using coding once the images are up on my website.

    The Media Library though via insert featured image or image into post shows as being empty, and even adding image via URL does nothing.

    I've tested Chrome, Firefox, and IE.

    Chrome and Firfox have this issue. IE doesn't even open the popup to attempt to add media, and does not show the kitchen sink above the content box for editing posts. (Not that I care about that, I prefer chrome) I figure I'd include this detail in case it can help with figuring out the issue.

  9. CellaScarpi
    Member
    Posted 1 year ago #

    I tried to post screenshots but the links were not working. :(

  10. CellaScarpi
    Member
    Posted 1 year ago #

    Found the issue, but I have no way to resolve it that is going to be an easy fix.

    For anyone else wanting to know....

    I started up a new wordpress site for testing, added my theme and problem still existed. Removed my theme added twentytwelve. It worked perfect.

    So here is the problem.

    Several commands that call things into action were changed to work with the new media uploader/ editor.

    One being the way resized images are being called. (If you teach a dog come and then say over here, he won't come.) So with the calls changing, anytime my theme uses the old commands it does nothing.

    Now the solution options for anyone else with this issue:

    Wait for the Theme you are using to fix the issue (Don't hold your breath, this could take a while.)

    Start a new wordpress website running 3.4.2 and don't upgrade until your theme fixes the issue.

    Switch to TwentyTwelve, start from scratch at rebuilding/ redesigning your theme to work for you.

    Sadly the last option is the route I am choosing to take. It's not gonna be easy, cause I have NO idea where to start, but I'm gonna take it little by little and pray.

    Currently My theme is a child theme of a theme I liked, but then twisted and turned and warped it into my own. So waiting for updates and changes do me very little to no good.

  11. esmi
    Forum Moderator
    Posted 1 year ago #

    Several commands that call things into action were changed to work with the new media uploader/ editor.

    Would you care to elaborate with some examples?

  12. CellaScarpi
    Member
    Posted 1 year ago #

    My theme calls the stock WP "image_resize" function, which has been depreciated in favor of "WP_image_editor::resize". I would just modify my code to work with WP_image_editor, but there's no documentation available for it yet. So I am forced to rebuild my theme using TwentyTwelve as the base.
    image_resize isn't the only function that was depriciated but it is one that has caused issues for my theme.

  13. Mike Schroder
    WP Contributing Dev.
    Posted 1 year ago #

    image_resize() is deprecated, but should continue to work as it did previously. Backcompat is included.

    There will be more documentation forthcoming, but you can check out the syntax for WP_Image_Editor::resize() here:
    http://core.trac.wordpress.org/browser/tags/3.5/wp-includes/class-wp-image-editor.php#L82

  14. rulethenation
    Member
    Posted 1 year ago #

    i cant upload anything either, i tried in the media section and i get this error

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/content/70/6550770/html/wp-content/themes/gonzo/includes/widget_areas.php on line 154 and defined in /home/content/70/6550770/html/wp-includes/wp-db.php on line 990

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/70/6550770/html/wp-includes/wp-db.php:990) in /home/content/70/6550770/html/wp-admin/async-upload.php on line 32
    21190

  15. rulethenation
    Member
    Posted 1 year ago #

    line 154 is

    $widgetized_pages = $wpdb->get_col($wpdb->prepare("SELECT DISTINCT meta_value FROM $wpdb->postmeta WHERE meta_key = 'omc_page_sidebar'"));

  16. esmi
    Forum Moderator
    Posted 1 year ago #

    As per the Forum Welcome, please post your own topic. Your problem - despite any similarity in symptoms - is likely to be completely different.

  17. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    @rulethenation

    Please start your on post as per the Forum Welcome. Tacking on to a resolved issue will get you no help.

  18. jsros86
    Member
    Posted 1 year ago #

    I'm also getting this error, but only on custom post types created with Magic Fields 2. I can upload directly to the media library without issue.

    So it sounds like it very well may be related to Magic Fields 2

  19. CellaScarpi
    Member
    Posted 1 year ago #

    @jsros86 I have never had Magic Field 2

    And saddly my plan to fix it has still resulted in pain and turmoil.

  20. jsros86
    Member
    Posted 1 year ago #

    I was able to downgrade to 3.4.2 very easily without issue, fixed the image uploading error http://wordpress.org/wordpress-3.4.2.zip

  21. paullee357
    Member
    Posted 1 year ago #

    Getting the same error. Thank you for posting the rollback link.

  22. drew
    Member
    Posted 1 year ago #

    Not a solution per se, but I've found the Faster Image Insert plugin (http://wordpress.org/extend/plugins/faster-image-insert/) useful for circumnavigating the errors with the 3.5 media manager.

  23. paullee357
    Member
    Posted 1 year ago #

    Not sure how to explain this. I deactivated all plugins and problem resolved.

    I reactivated each one to find the culprit (via half splitting) 12 of 24, then the next 6, then the next 3, and finally the last 3.

    Each time, the image resizer kept working.

    Not sure why it was not working temporarily

  24. H3llas
    Member
    Posted 1 year ago #

    Downgrading to 3.4.2 was only solution for us.

    Changing theme to default and deactivating all plugins did not worked.

  25. Donna Fontenot
    Member
    Posted 1 year ago #

    I've already started a new thread on this (with no replies yet), but I thought I would mention here that I've narrowed this problem down on our site to one of roles.

    Admins can upload fine.
    Authors cannot.

    (We don't use a role manager plugin but I may try one to see if I can find a workaround).

    In any case, I thought that may help some of you to at least check and see if logging in under an admin account would make a difference or not.

  26. crusch
    Member
    Posted 1 year ago #

    Yes, downgrading to 3.4.2 was only solution for us.
    Changing theme to default and deactivating all plugins did not worked. Even Admin account cannot upload.

Topic Closed

This topic has been closed to new replies.

About this Topic