WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] images not uploading correctly (8 posts)

  1. nicolasshonfeld
    Member
    Posted 9 months ago #

    Hi there,

    I had a wordpress installed and all was working fine for a few months. Then for no apparent reason, when i am trying to upload images (either by dragging them from desktop to media gallery, or, the conventional file uploader) the file seems to upload, but then it greys out and a preview/thumb of the image is not visible in the gallery. If i select to insert into a post it shows the small error square icon in the place where the image would normally go, within the post.
    I deleted the entire wordpress and installed wordpress again, but I still have the same issue.

    Any help appreciated. Nic.

  2. nicolasshonfeld
    Member
    Posted 9 months ago #

    this is my site - http://nicshonfeld.com/diary/

    i have made an example post - just in case that is any help!

    thanks in advance,

    Nic.

  3. kmessinger
    Volunteer Moderator
    Posted 9 months ago #

    Thanks for posting an example. When you check the url for the image it shows You don't have permission to access /diary/wp-content/uploads/2013/11/Lara-Stone-Paolo-Roversi-5-235x300.jpg on this server.

    So somewhere the permissions are wrong.
    http://codex.wordpress.org/Changing_File_Permissions

  4. nicolasshonfeld
    Member
    Posted 9 months ago #

    ah, thank you, but Im afraid im in too deep with that! I am to all intent and purpose a novice in that respect. I uploaded wordpress via my hosting website (123-reg) which has an apps section. It does it all for you, so to speak.

    Thanks again.

  5. kmessinger
    Volunteer Moderator
    Posted 9 months ago #

    You should be able to see and change permissions using whatever file manager your host provides on c panel.

  6. nicolasshonfeld
    Member
    Posted 9 months ago #

    Ok thanks loads for that. I found a tool called "Check site permissions' on the control panel in my hosting site which I have done. It seems to show every single file i have for my seperate website, and then at the bottom is a few wordpress file. Next to each file is a drop down menu with a recommended setting - i have changed them all to the recommended settings (they all had 'skip' selected previously, as do all my other seperate website files). I have reinstalled wordpress and still nothing.

  7. kmessinger
    Volunteer Moderator
    Posted 9 months ago #

    i have changed them all to the recommended settings

    All directories should be 755 and all files 644.

  8. nicolasshonfeld
    Member
    Posted 9 months ago #

    all sorted. Thank you very much. nic.

Reply

You must log in to post.

About this Topic

Tags