WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Images not showing up in Media Library (12 posts)

  1. JohnSmith1
    Member
    Posted 2 years ago #

    Hello,

    I'm running the latest version of WordPress. My problem is that under Media Library the images which uploaded through WordPress Upload is not showing up. More exactly it is the same problem at is described on this link: http://stackoverflow.com/questions/8438193/wordpress-images-not-showing-up-in-the-media-library

    I have tried the "solutions" described on the above link, but none have worked.

    Are there any other solution for this problem?

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Check your uploads path in Settings->Media. It should be blank in most installs.

  3. JohnSmith1
    Member
    Posted 2 years ago #

    Thanks for answer.

    Im afraid that it didnt work either. Both these fields I set to empty:

    - Store uploads in this folder
    - Full URL path to files

    Nothing different happened.

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Are the images being uploaded to wp-content/uploads? Have you checked by FTP?

  5. JohnSmith1
    Member
    Posted 2 years ago #

    Thanks again.

    Yes, they are. I can se the images under "Media > library". But they are not shown under "Featured image" under any page. When clicking "Set featured image > Media Library > Images".

    Weird problem.

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

  7. Solomonc
    Member
    Posted 2 years ago #

    During the uploading of your image in your post or page edit screen, you must click the "Use as featured image" link (beside the "Insert into post" button) before it can show as 'featured image" in your homepage.

  8. JohnSmith1
    Member
    Posted 2 years ago #

    Hmm, when activating twenty ten it worked. So it must be something with the theme. Any good idea where I should start debug? I haven't create the theme by myself.

  9. esmi
    Forum Moderator
    Posted 2 years ago #

    My best guess is that the theme is using javascript that is incompatible with WordPress. I've even come across theme that have disabled WP's core jQuery - thus crippling some aspects of WordPress.

  10. JohnSmith1
    Member
    Posted 2 years ago #

    I found the error, somehow a register taxonomy was the problem in the functions.php.

    Thanks for all the help!

  11. Damonji
    Member
    Posted 1 year ago #

    Hi, I have the same problem, I made my own Theme and everything was working fine, but now, I click on "set featured image" and there is no images on my library (also no numbers are showed to tell me how many images I have in my media library)

    How can I change taxonomy for images as you are telling here?

    Could be any permissions folder problem?

    Thanks in advance

  12. Andrew
    Forum Moderator
    Posted 1 year ago #

    @Damonji, create your own thread.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.