WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Images not showing up in IE8? Why? (22 posts)

  1. sparklogix
    Member
    Posted 11 months ago #

    Everything works fine everywhere else, but in IE8, the images just aren't showing up.

    Here's an example

    Why is this happening? It's possible I've been staring at this for too long and the simple answer has been staring me in the face the whole time... :|

  2. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 11 months ago #

    Which images?

  3. sparklogix
    Member
    Posted 11 months ago #

    All of them. If you view that site on FF, Chrome, even IE9, you'll see a bunch of images on that homepage. I don't see them at all in IE8.

  4. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 11 months ago #

    This is what I see in IE8 http://snag.gy/Nl3W2.jpg

  5. sparklogix
    Member
    Posted 11 months ago #

    Right, that's a slider. There are image to the right of it and all down the bottom of the page. Have you seen it on FF or Chrome? All the images show up there. I'm trying to figure out why they don't show up in IE8.

  6. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 11 months ago #

    Looks like it's because of your width of 100% styles on the images that aren't showing.

  7. sparklogix
    Member
    Posted 11 months ago #

    So I took out the width:100% in Firebug and when I do that, the image does not auto-scale down to the container size, but expands beyond it.

    How can I have the image auto-scale while still having it show on IE8?

  8. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 11 months ago #

    Try max-width?

    max-width: 100%;
  9. sparklogix
    Member
    Posted 11 months ago #

    Sorry, should have mentioned that's what I used in place of the width:100% and the image didn't auto-scale.

  10. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 11 months ago #

    Can you also confirm that my hypothesis was correct, that the 100% width was causing the issue?

  11. sparklogix
    Member
    Posted 11 months ago #

    Still working on that. I have to find a computer with IE8 since my minutes on SauceLabs ran out today.

  12. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 11 months ago #

    Let us know when you get your IE8 machine again.

  13. sparklogix
    Member
    Posted 11 months ago #

    Ok, got on IE8, finally!

    I added this to my ie8.css file:

    a.rs-gen-img.thumbnail > img, div.thumbnail > img {
    	max-width:100%;
    	width:auto;
    }

    The images show up, but are definitely bigger than the container they're in.

  14. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 11 months ago #

    I can't see that issue, can you link to a screenshot of it to illustrate it?

  15. sparklogix
    Member
    Posted 11 months ago #

    This is what it should look like: http://snag.gy/y0wFJ.jpg

    This is what I'm seeing in IE8: http://snag.gy/Hew10.jpg

    I had to reduce the resolution on the IE8 screenshot to get it all in one window, but you can see how the images go past the edge on the right side now. The edges are indicated by that horizontal rule below the images.

  16. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 11 months ago #

    Could you try adding min-width: 100%?
    E.g;

    a.rs-gen-img.thumbnail > img, div.thumbnail > img {
    	max-width: 100%;
    	min-width: 100%:
    	width: auto;
    }
  17. sparklogix
    Member
    Posted 11 months ago #

    Tried it, they're still too big :(

    By the way, thanks for helping me out with this. I really appreciate it!

  18. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 11 months ago #

    Sorry, forgot to say:
    Can you add this style too;

    a.rs-gen-img.thumbnail {
     display: inline;
    }

    ?

  19. sparklogix
    Member
    Posted 11 months ago #

    I just did, purged caches, still not changing the image sizes.

  20. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 11 months ago #

    I think you added it to the wrong element.

  21. sparklogix
    Member
    Posted 11 months ago #

    Andrew, today you are my hero! Thank you so much. My eyes couldn't take staring at IE8 anymore. Thank you so much for all the time you took to help me out!

  22. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 11 months ago #

    And thank you for contributing to the WordPress community :)

Reply

You must log in to post.

About this Topic