WordPress.org

Ready to get started?Download WordPress

Forums

Postie
[resolved] Images not showing up anymore (11 posts)

  1. rigsnet
    Member
    Posted 1 year ago #

    Hi,

    Recently I updated to Postie 1.4.34 (had several versions old installation before that) then images didn't show up anymore. Analyzing the HTML I see that src is missing.

    However, if clicking Run Postie before Postie has automatically fetched the mails then it works, src is correctly there.
    Strange, what differ between the automatic and manual fetch?

    Test Config doesn't indicate any fault.
    I'm running WP 3.5.1 on Linux LiteSpeed, PHP 5.3.21.

    Any ideas?

    BR /Goran

    http://wordpress.org/extend/plugins/postie/

  2. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    That does sound strange as there isn't any difference between cron or interactive other than there is a logged in session.
    If you send a sample email to postie-test@devzing.com I can see if there is anything strange happening.
    You can also try enabling debug logging as described here
    http://postieplugin.com/enabling-debug-output/

  3. rigsnet
    Member
    Posted 1 year ago #

    Thanks, very kind of you.

    I'm using Cforms for generating a form (in Swedish), on submit sent to a "sectret" e-mail account, finally fetched by postie. I'll add you as admin e-mail so you'll receive a proper copy.

    I'll also do a debug later when returned home after work.

  4. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    I was able to successfully process your email with text and images via manual run, cron and remote cron.

    Please try turning on debugging and sending me the log file.
    http://postieplugin.com/enabling-debug-output/

  5. rigsnet
    Member
    Posted 1 year ago #

    I was delayed with the debug test, it disturbed my theme... but now when I upgraded to your newest release of today then it seems to work properly! Great, thanks!

  6. rigsnet
    Member
    Posted 1 year ago #

    Sorry me again, there seems to be a conflict with the plugin W3 Total Cache (or if the problem is by W3 Total Cashe?). When I turn it on then Postie will not fetch the mails any more, only manually when clicking Run Postie.

  7. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    In searching the W3TC support forums there seems to be a lot of complaints about cron not working (Postie depends on cron to fetch emails). The most recent message is unanswered - http://wordpress.org/support/topic/latest-update-breaks-cron-job

    I haven't tried this but you may be able to fix this by adding "wp-content/plugins/postie/get_mail.php" to W3TC "Never cache the following pages" on the "Page Cache Settings tab"

  8. rigsnet
    Member
    Posted 1 year ago #

    Not easy for a "Newbie" like me :-)
    There seems to be two problems: 1. not able to fetch the mails, and 2. not attaching the images.

    1. Even if I deactivate all plugins, besides postie, it will not fetch any mails (only manually).
    Sometimes the fetching works ones. I haven't digged into finding the exact reason but probably when I deactivate/activate, or set the fetching occurrence, of postie.
    So the remaining root cause of the problem must be either the newly changed Linux environment to LiteSpeed V6.1, or the also newly changed php to 5.3.21 (if not WordPress itself, I use 3.5.1 and theme Atahualpa 3.7.11).
    Now I have given up and signed up for a free account at SetCronJob, as a workaround to trigger get_mail.php, for the time being at least.

    2. The problem by not attaching the images is verified being related to W3 Total Cache. Besides that the images are not attached due to missing src the titles have been added with "Uncategorized".
    When I add "/postie*" (without the quotes) in W3 Total Cache "Database Cache" in the field "Never cache the following pages:" then it works.

  9. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Glad you have it working.

  10. Orakel78
    Member
    Posted 1 year ago #

    Just a little update for others who might google and have the same issue.

    I had to add the /postie* to the database cache as well.

    Strange issue since everything is in there except the src= parameter for the image.

  11. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the update.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags