WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Images Not Showing; How Can I be Sure It's Set Up Correctly? (7 posts)

  1. 785mack
    Member
    Posted 1 year ago #

    This is (was) my second attempt at doing this which again was disrupted and buggy I do not reacall evertyhing I did to get things to work. It is a subdomain install using wildcard DNS at Hostgator.

    Today was the day I was going to rip out WPMS and go back to regular. Then someone posted a fix for the looping log in issue:

    http://wordpress.org/support/topic/weird-problem-multisite-admin-login-not-successful?replies=4#post-2854118

    It worked! Then I decided to start testing the sites. (Main site + 2). Added a post w/image -- no image. I can see it was uploaded and all the file permissions are ok -- just can't see the picture.

    Of course I'd like to solve that issue. More importantly I'd like to feel confident that everything is set up correctly. Just because things *seem* to work does it mean it's right?

  2. Well... that other problem really isn't fixed 'right.'

    See, WordPress multisite is a picky little thang, and it really wants you to run it out of where the base install is. So if you want sites to look like this:

    sitename.blog.mysite.com

    Then you install WP here:

    blog.mysite.com

    And use subdomains.

    So we need a little more information here :)

    What's your setup? Subdomains or sub-sub-domains or subfolders?

    Can you give us your real URLs?

    What's the error? A 404, an image with a red X?

    What's in your .htaccess?

    Is allowoverride set to all in your httpd.conf file?

  3. 785mack
    Member
    Posted 1 year ago #

    I just knew you were going to want more info :-)

    Setup:

    Subdomains, wildcard DNS at Hostgator
    main site http://oldfocals.com
    sudomains http://metrofocals.com (site id 5) http://globalfocals.com (site id 6)

    image with redx

    I was having a 404 problem early on then it went away.

    Is allowoverride set to all in your httpd.conf file?

    I do not know and I flagged another thread where you brought this up and was waiting on that answer :-)

    fyi - had a heckuva time getting the first one, metrofocals.com set up working and then mapped. after I got the fix for the looping login and added globalfocals -- piece of cake in terms of mapping and accessing. then I thought better start to work these things to see if they really work! and encountered this image problem.

    and -- true confessions -- since I had pretty much decided before this that I was going to go back to regular WP I was rather indiscriminate about "things" I was changing. That's why I'm hoping there is some kind of checklist I can run through from begining to end for how it should be.

  4. 785mack
    Member
    Posted 1 year ago #

    and another thing -- SSL certificates. There is supposed to be one installed can all the sites on the network use it?? ...maybe what I ought to do is read your book! :-)

  5. 785mack
    Member
    Posted 1 year ago #

    ok -- trying to be a little more scientific about this to see if it well help figure out what I'm doing wrong:

    1. changed DNS to host's DNS
    2. Parked the Domain
    3. Typed in newparkeddomain.com and it went to:
    oldfocals.com/wp-signup.php?new=newparkeddomain
    4. Logged into network and added site to network
    now goes to newparkeddomain.oldfocals.com
    5. Settings: Domain -- mapped the domain to newparkeddomain.com -- works
    6. Site Settings: Info - change url from http://newparkeddomain.oldfocals.com to Http://newparkeddomain.com
    7. Changed Permalink settings to just postname

    File upload path is : wp-content/blogs.dir/7/files
    File upload URL is http://newparkeddomain.oldfocals.com/files

    things that may or may not be relevant:

    * I've only parked domains -- did not create add-ons. (I think I did that on the first go around and then removed it becuase of 404 errors....)
    *in public_html, where WPMS is installed, there is also an additional directory named oldfocals (nothing in it)
    * in wp-content/blogs.dir there are the 2 folders for the last domains I set up I'm not seeing one for the first one metrofocals.com

    ok -- I sure hope there is something in all that that is useful and of course is a super easy fix :-)

  6. Okay, the httpd.conf you gotta ask your webhost if you don't know. But the majority of the time, that's why you get the red X in images on subsites.

    Start there.

    Also did this work before you mapped domains? I'm guessing not, and that's 'good' in that it really points to httpd.conf :)

    6. Site Settings: Info - change url from http://newparkeddomain.oldfocals.com to Http://newparkeddomain.com

    Ow. Okay you should be using the domain mapping plugin - http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

  7. 785mack
    Member
    Posted 1 year ago #

    yes, mapped domains using the plugin.

    here's the thing.....it's amazing what happens when you forget the DOT on your .htaccess file ... add it in et voila everything seems to work! so, I'm a little embarrassed by that but VERY happy I can get on with the project :-)

Topic Closed

This topic has been closed to new replies.

About this Topic