WordPress.org

Ready to get started?Download WordPress

Forums

Images not showing (Blue Question Mark) (12 posts)

  1. jeremyliang
    Member
    Posted 2 years ago #

    Hi everyone,

    I built my website (using the Genesis Framework) on a local server, and just uploaded it 'live' only to find my images are not showing. In their place there is a blue question mark.

    However, the images only show when I am using my work computer (i.e.the one I used to build the website). Not sure if that is just coincidence. I have searched the forums, but found no conclusive advice. Can someone please point me in the right direction ?

    website url: http://www.learntennisnow.com

    Thanks in advance,
    Jeremy

  2. jnhghy
    Member
    Posted 2 years ago #

    Hi,
    How did you linked the images?
    You used a plugin to upload and attache them?
    Have you inserted them throw wordpress(directly to the post)
    Or have you linked them throw html?
    Regards

  3. jeremyliang
    Member
    Posted 2 years ago #

    Hi jnhghy,

    I inserted through WordPress (on local server, before I upload the whole database)

    Cheers,
    Jeremy

  4. jnhghy
    Member
    Posted 2 years ago #

    Ok, I'm not 100% sure why this happened but the images doesn't have the right id or location, html is not showing the correct location of the file/ can't locate the file.
    The thing to do is to upload the files again with the site published. if you don't have to many images to upload.
    No need to bother with anything else but if you have too many files then we will have to figure something else :)
    Let me know if you can re-upload the files.

  5. jnhghy
    Member
    Posted 2 years ago #

    check this :) didn't catch it you have your answer :)
    http://wordpress.org/support/topic/error-message-122?replies=2

  6. jeremyliang
    Member
    Posted 2 years ago #

    Hi jnhghy,

    At least I have something to work with now. :)

    Trying it out. Will let you know if it works. Thanks very much. Appreciate your help.

  7. jeremyliang
    Member
    Posted 2 years ago #

    Hi jnhghy,

    It works ! Yes I was looking through my html before I saw your link, and realized the links was 'localhost'. what a Noob mistake ! Thanks for pointing me in the right direction.

    I am quite new to WordPress. Just realized that some of my other links are ALSO 'localhost'. What did I do wrong during the export process ? Or is this totally normal ?

  8. jnhghy
    Member
    Posted 2 years ago #

    This is totally normal, in dashboard -> Settings -> General :
    you have Site Address -> this is the address that wordpress adds to links I am guessing you forgot to change this to the current site and you left it pointing to localhost. Verify this and make sure it's correct other thing you may have the images saved in your database with the old link -the one that where on your localhost. verify the first idea and let me know. :)

  9. rhoi
    Member
    Posted 2 years ago #

  10. jnhghy
    Member
    Posted 2 years ago #

    Thank you rhoi, I saw your other post about this and linked above :) good eye :) I missed it the first time.
    Regards

  11. jeremyliang
    Member
    Posted 2 years ago #

    No it is not the first one. My site is pointed to the correct place. Menu links all work fine. Just a few random links point to localhost. For future reference, how do you change the image database to the new address before exporting ? How do u ensure that all links are correct before exporting ?

  12. jeremyliang
    Member
    Posted 2 years ago #

    Thanks rhoi for the fix. :)

Topic Closed

This topic has been closed to new replies.

About this Topic