WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] images not showing - 404 (11 posts)

  1. btard
    Member
    Posted 4 years ago #

    I have all my images in wp-content/uploads

    I can verify them all via FTP, yet when I call the direct URL of the image, I get a 404 error.

    It works for all types of images and even in the posts themselves, they are not present. Any ideas, anyone?

    some examples:

    xhttp://nostatus.com/2008/09/24/bela-lugosi-as-dracula/bela-lugosi-as-dracula/

    xhttp://nostatus.com/2007/02/14/montreal-canadiens-new-era-cap/

    You can see the spot where the image is, except, there's no image there.

  2. Samuel B
    moderator
    Posted 4 years ago #

    what happens if you temporarily chmod /wp-content and /uploads to 777?

  3. btard
    Member
    Posted 4 years ago #

    hi samboll,

    nothing at all happens. i even chmod'd the image itself (lol).

    weird problem.

  4. Samuel B
    moderator
    Posted 4 years ago #

    how do you have it set up in
    admin - settings - miscellaneous
    ?

  5. btard
    Member
    Posted 4 years ago #

    xhttp://farm3.static.flickr.com/2792/4420316138_f2f084b0f3_o.png

    a picture speaks a thousand words :)

  6. Samuel B
    moderator
    Posted 4 years ago #

    well that normally works
    have you tried any of the other options? Like full url? or the organize options to see if the server will automatically create a folder?

    otherwise, I'm at a loss.

  7. btard
    Member
    Posted 4 years ago #

    yeah, tried it all :)

    here was my last resort.

  8. Mark / t31os
    Moderator
    Posted 4 years ago #

    Did you implement any custom rewrite rules?

    Your upload folder returns a 404 ..
    nostatus.com/wp-content/uploads/

    EDIT:Was your site previously exploited, your URL turned up one or two fishy results, it could be a left over problem if your site was previously compromised..

  9. btard
    Member
    Posted 4 years ago #

    there was a SQL inject attempt that just meant I had to SSH and flush hosts on my DB.

    as for a custom rewrite: /%year%/%monthnum%/%day%/%postname%/

    edit: there is a .htaccess file in there with these contents:

    Order Allow,Deny
    Deny from all
    <Files ~ "\.(jpe?g|png|swf|gif)$">
     Allow from all
    </Files>Options -MultiViews
    ErrorDocument 404 //wp-content/uploads/includes.php

    ^ alas, even when removed I get the same 404...

  10. Mark / t31os
    Moderator
    Posted 4 years ago #

    Well this looks wrong to start with.

    ErrorDocument 404 //wp-content/uploads/includes.php

    No such file exists in that folder for WordPress (since the upload folder does not exist at the time of installation, and still does not exist until you make your first upload), if any such file exists in that directory it has nothing to do with WordPress..

    I would be inclined to think at this point, that you still have infected files on the site, flushing the database will only fix problems in the database, if files are infected, it won't clean them.

    Did you replace your WordPress files with those from a fresh copy? (matching version of course)

  11. btard
    Member
    Posted 4 years ago #

    did a clean install and it's all working properly. The SQL inject compromise put a lot of junk everywhere and I thought I had cleaned it all up, alas, no.

    fixed tho. thanks for your help and suggestions guys.

Topic Closed

This topic has been closed to new replies.

About this Topic