WordPress.org

Ready to get started?Download WordPress

Forums

Images not showing (32 posts)

  1. Johanhorak
    Member
    Posted 4 years ago #

    Hi I have installed a multi site on one of my wordpress sites and am now having problems with images not showing.

    I have uploaded screenshots of the story.

    My file upload url is http://directory.spiritpathwaysfoundation.com/files
    I have uploaded an image here http://directory.spiritpathwaysfoundation.com/files/2010/08/directory.jpg

    It exists and it does not exist.... It does not exist at the above url but when I click on edit image in the Media manager I can see it. The best way to explain is to look at the screenshot

    1) Edit Image (visible) http://spiritpathwaysfoundation.com/temp/editmediaedit.png
    2) Thumbnails of images (blank)http://spiritpathwaysfoundation.com/temp/editmediafrontpage.png

  2. this is the default behaviour. It's supposed to upload the image to one location on the server and rewrite the URL to the second one.

    this is done via the .htaccess file. Go double check it. if it's fine (just like what it should be under Tools -> Network) then go tell your webhost you made htaccess changes and they are not being read.

  3. Johanhorak
    Member
    Posted 4 years ago #

    @Andrea_r you are a star. Amazing. Thanks for the support. I knew I had to say something to my host but did not know what. Txs

  4. Johanhorak
    Member
    Posted 4 years ago #

    Hi Just for info. I did what Andre_r suggested. It took a while for my host. Eventually my host got back and said:

    RewriteBase /snapshots/
    Was causing this error. I have commented out this directive and the image is accessible.

    All working.

    Thanks again for helping me out.

  5. shazzam
    Member
    Posted 3 years ago #

    I commented out:

    # RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]
    on blue host, .htaccess in addon domain folder

    and BINGO!!! :)

    Thanks Heaps :)

  6. bobjom
    Member
    Posted 3 years ago #

    @ Johanhorak: i'm really happy for you... I got the same problem..can you give me specific details on how you commented out? not savvy really... thanks

  7. bobjom
    Member
    Posted 3 years ago #

    @shazzam: please help me:got the same problem but i dont know where to start solving it..
    thanks

  8. bobjom - Don't double post.

    What's the full content of your .htaccess file?

  9. shazzam
    Member
    Posted 3 years ago #

    RewriteEngine on

    RewriteCond %{HTTP_REFERER} !^http://othersub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://othersub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://sub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://sub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.othersub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.othersub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.sub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.sub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.maindomain.com$ [NC]
    # RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    # END WordPress

    -----------------------

    OK this is on bluehost, and it has a main domain that is your public_html folder.

    each subdomain is a folder in that folder.
    You can install and copy installs of wordpress from your cpanel, i copied one i think, i am going back some time now.
    so.... othersub/(in the htaccess file above) is the one that is not the one for this install.

    This is also an MU (multi user) install... so, you may have multiple blogs in subfolders of your wp folder.

    Mine is installed in the root of the subdomain sub/ (in the htaccess file above)

    So you may only need to change the line in your .htacces file as follows:

    # RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]

    or

    if you want a MU install as well, copy other wp stuff.

    You may PM me if you want more help, and i can give you my email address :)

    Hope this helps for blue host :)

    Shazzam

  10. I would remove (or comment out) this whole section

    RewriteCond %{HTTP_REFERER} !^http://othersub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://othersub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://sub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://sub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.othersub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.othersub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.sub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.sub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.maindomain.com$ [NC]
    # RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]
  11. shazzam
    Member
    Posted 3 years ago #

    Yep, but save it as .htacces_old first, to make sure you can go back when ever you like :)
    Good Luck
    Shazzam

  12. bobjom
    Member
    Posted 3 years ago #

    thanks for your overwhelming response guys:
    my .htaccess is:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

  13. bobjom
    Member
    Posted 3 years ago #

    thanks ipstenu and shazzam: By the way my setting is sub category: maindomain.com/site1/ does this will matter?i will try this today...hope i will be getting luck this time...

  14. Your htaccess looks fine. What's your URL?

  15. bobjom
    Member
    Posted 3 years ago #

    my main URL:http://www.loudounstyle.com and my sub site: http://www.loudounstyle.com/events/ i'm using or chose trhe sub category when installing the wordpress MU.

  16. bobjom
    Member
    Posted 3 years ago #

    even if i single post only..still it wont show up...is there like we need to activate something?

  17. Theme images ARE showing up. What plugin are you using for the slider?

  18. bobjom
    Member
    Posted 3 years ago #

    @ shazzams..i will try also yours: but is ok with setting domain.com/sub/?

  19. Don't change your htaccess file, bob, it's fine. That's not your problem. Please list your plugins.

  20. bobjom
    Member
    Posted 3 years ago #

    the slider is built in with the theme MediaPress. its part of his features..on the main site when we post something the uploaded images are showing up..but when we add other sites and posting, the uploaded image is save but the image wont show up in slider..

  21. bobjom
    Member
    Posted 3 years ago #

    the loudounstyle.com/events/ is link to the main site loudounstyle.com does this affect?

  22. bobjom
    Member
    Posted 3 years ago #

    ok will not change my htaccess..thanks

  23. bobjom
    Member
    Posted 3 years ago #

    i have 3 plugins: akismet,hello dolly, and i installed buddypress...

  24. Turn of BuddyPress for now, as a test. See if the images show.

    Also try the default TwentyTen theme.

  25. bobjom
    Member
    Posted 3 years ago #

    sorry for the late reply Ipstenu...ok i will try..i will let you know as soon as possible..thanks

  26. bobjom
    Member
    Posted 3 years ago #

    wow...ipstenu the image i post show up/is this with the buddypress or the theme? i'm using twenty ten theme on my sub site.. but is there a way to solve it with my MediaPress theme..your so great ipstenu...thanks on this one atleast it shows progress. I'm very happy..

  27. This is good :) NOW we know it's NOT your install, but a theme/plugin issue. I know for a fact that BuddyPress works fine, so let's reactivate BuddyPress and KEEP the TwentyTen theme.

    If THAT works, then it's your theme. You may need to try using the BP Template Pack (http://wordpress.org/extend/plugins/bp-template-pack/ ) with your sit, or ask the MediaPress support (this is a PAY FOR theme after all) for help.

  28. bobjom
    Member
    Posted 3 years ago #

    Ok ipstenu i will follow your advise:thanks for your wonderful and fruitful time. I will let you know about the progress as soon as possible. I will definitely contact MediaPress support on this matter. Thanks Ipstenu.

  29. bobjom
    Member
    Posted 3 years ago #

    Good Day Ipstenu...I already installed the BP-template-pack but still the same problem..I'm still contacting the author but for now no feedback yet from them..Bad Author?hehehehe...joking! hope i could get updates on them..thanks Ipstenu..

  30. Did everything work when you were on TwentyTen with BuddyPress?

    If so, again, it's your theme. You paid for MediaPress. Ask them for help. They may not support that theme with BuddyPress. And if so, congrats, you're on your own.

Topic Closed

This topic has been closed to new replies.

About this Topic