WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Images not loading, getting 404 error (4 posts)

  1. hjsproductionsguru
    Member
    Posted 1 year ago #

    All of my images that I've previously uploaded (wp-content/uploads/2012...) and any new images I try to upload and put into a post/page, they do not display, i just get a little broken page icon. When i try to follow the link path to the image directly, i get a 404 page not found error. For example http://www.hjs-productions.com/wp-content/uploads/2012/10/ticket.png

    However, i know these files are still in their correct folders by going through my FTP and confirming they're there. My theme is up to date, as is my wordpress. This has only been happening for a day or two.

    What's going on and how do i fix it?

  2. It sort of sounds like you might have an .htaccess permissions problem. First, check in your wp-content folder to see if you have an .htaccess file there. If you do, delete it. If that doesn't solve the problem (or you didn't have one in wp-content), try deleting the .htaccess file in your site's root directory, then visit Settings > Permalinks and re-save your permalink configuration.

  3. hjsproductionsguru
    Member
    Posted 1 year ago #

    I've checked my wp-content folder and my root directory and there are no .htaccess files in either. Updated my permalinks configuration and still am having the same problem.

  4. hjsproductionsguru
    Member
    Posted 1 year ago #

    Upon accessing the root directory via my hosting ftp program (go daddy) i was able to see there were .htaccess files in both the uploads folder and main root folder. I could not see them in my in browser plugin (FireFTP). Deleting these files resolved my issue.

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic