WordPress.org

Ready to get started?Download WordPress

Forums

Post By Email
Images not loading (6 posts)

  1. mande01
    Member
    Posted 10 months ago #

    Hello,

    Before i say anything, this is a great plug in!

    Ok...

    I've got it all set up an going, emails going in as expected.
    Except for images, images are not loading up correctly.

    so I send an email from outlook or gmail or whereever,
    goes to email set up as imap,
    then via the plugin get posted.

    I'm set up on bluehost.com and the email is in there also.

    Your help would be great!

    Thanks,
    Der

    http://wordpress.org/plugins/post-by-email/

  2. Kat Hagan
    Member
    Plugin Author

    Posted 10 months ago #

    Hi! There are some known issues with images getting posted that I'm still trying to track down, so thanks for letting me know. If you're embedding the images in the email (like by dragging them in or copy-and-paste), can you try just attaching them as files to see if that gets them to show up?

    Thanks!

  3. mande01
    Member
    Posted 10 months ago #

    Hello, Thanks for the reply.

    Attaching them did not work. Is there something i could do to give you more information, or is there more I can do to help my self!

    Thanks,
    Derry

    Correction:
    From a selection of png's, bmp, jpeg, jpg, gif. Only small little png got put into media library.
    I thought the attachment was to go straight into the post? Or is it supposed to go to the media library first?

  4. mande01
    Member
    Posted 10 months ago #

    Hi,
    More information.

    The first image attached to the email is getting added to the media library. The reminder are not, is this correct?

    How can I get the image/attachment to automatically get added to the post? am i missing something from the manual?

    Thanks,
    Der

  5. mande01
    Member
    Posted 10 months ago #

    Hi,
    More info.

    I'm not 100% on what this paragraph suggesting:
    "Any files attached to an email will be uploaded to the Media Library and added to the post as a gallery. You can specify gallery options, or its location within the post, by including a gallery shortcode in your email. If no gallery shortcode exists, it will be added to the end of the post."

    If i add the gallery shortcode the first attached image turns up in the post, but no others.

    If there are multiple attachments they do not appear to be attached either.

  6. Kat Hagan
    Member
    Plugin Author

    Posted 10 months ago #

    Hi, sorry you're having so many problems. Can you forward an example email to postbyemailplugin@gmail.com so I can look into it? Any one of the ones you tested that didn't work would be great.

    It would also help if you could find out what version of PHP and WordPress you're using.

    As for your question about the Media Library, all images have to be uploaded to the Media Library in order to be attached to a post. That's the same thing WordPress does if you add an image to a post via the admin dashboard. See also:Codex: Media Library.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.