WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Images not display in 2011 widget area (12 posts)

  1. befree22
    Member
    Posted 2 years ago #

    Hi Folks,

    I have a 2011 WordPress child theme on my site. 2011 has at least 7 widget areas, 3 of them on the bottom div#supplementary.three

    I've tried adding the following code to the middle widget area of the div#supplementary.three but the image just isn't displaying on the site:

    <img src="http://mysite.com/wp-content/wp-content/themes/business/images/callmeagain.png" width="150" height="120" />

    Could someone tell me what I'm missing? I am using a text widget but it's only taking text, not image files.

  2. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    /wp-content/wp-content/ - is that on purpose?

  3. befree22
    Member
    Posted 2 years ago #

    My bad. I did have the correct file path on the widge http://mysite.com/wp-content/themes/business/images/callmeagain.png

  4. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    I've tried adding the following code to the middle widget area of the div#supplementary.three

    by directly editing the sidebar-footer.php template?

    if so, please paste the code into a http://pastebin.com/ and post the link to it here.

    a textwidget should normally take the image html code as you posted it in your question.

    can you post a link to your site?

  5. befree22
    Member
    Posted 2 years ago #

    The sidebar-footer.php code is in the parent 2011 theme and I pasted it here for you http://pastebin.com/U5fp619x

  6. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    no need to paste the sidebar-footer.php code if you haven't edited it;

    what is the exact content of the text widget with the image that does not show?

    a link to your site might help to make more suggestions.

  7. befree22
    Member
    Posted 2 years ago #

    My site is prosocialroi.com

    <html>
    <body>

    Call 321-600-6366 today.

    </body>
    </htm>

  8. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    I see the 'speech bubble' image in the center footer widget - have you solved the problem?

  9. befree22
    Member
    Posted 2 years ago #

    For some reason, the speech bubble isn't appearing in the center footer widget on my end. I emptied my cache but if it's working for you, then I'll leave it alone. Thanks for your help.

  10. befree22
    Member
    Posted 2 years ago #

    I viewed the site on desktop computers and the speech bubble image isn't appearing in the center footer widget either. I wonder why is the image displaying on your end but not mine?

  11. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

  12. befree22
    Member
    Posted 2 years ago #

    I was missing a > tag so that's why the image didn't display.

    <html>
    <body>
    
    <a href="http://www.prosocialroi.com/contact-us"><img src="/images/callmeagain.png"  width="180" height="180" alt="Call me today."></a>
    
    </body>
    </htm>

    FYI: Some folks use the following code for images but my image was hyperlinked to another page:

    <a href="/"><img src="<?php bloginfo('template_url'); ?>/images/sidebar/sidebox.jpg" width="236" height="226" alt="Titan WordPress Theme" /></a>

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.