WordPress.org

Ready to get started?Download WordPress

Forums

Images not being uploaded properly & not appearing on site (7 posts)

  1. emmettjones
    Member
    Posted 6 years ago #

    I'm not even entirely sure where to look to try to resolve this problem. I've seen a couple of the posts on Images and I've tried to follow the same structure for uploading your files and such, but nothing seems to be working.

    My problem is that I cannot see any files that I upload onto wordpress, either by going through my database. I can get a picture to appear if i link to the photo from a different site, but not anything from my own site. I've checked the phpMyAdmin to look at my wordpress and blog URL's but i seem to have that stuff done correctly.

    any help would be greatly appreciated.

    my site is http://sportsbusinessdigest.com
    and a test picture post can be found at http://sportsbusinessdigest.com/?p=116

  2. moshu
    Member
    Posted 6 years ago #

    Images are not in the database. They are in the wp-content/uploads/ folder (or its subfolders by year and months).

    I can see you image on the main page, here:
    http://sportsbusinessdigest.com/

  3. emmettjones
    Member
    Posted 6 years ago #

    Um...the image on the page that you can see is the one I linked to from somewhere else.

    Where in my database should I be putting the images then?

    and even if i fix that problem, i still can't get images to show up on other things. For example, I'm using amazon affiliates on the site, and i chose to show images, but I can't see the image, only a link to the product (a book) and not the image and the text link.

    Thanks again for any help you can provide

  4. moshu
    Member
    Posted 6 years ago #

    1. You need to brush up your reading skills...
    Repeated wrong question:
    Where in my database should I be putting the images then?
    Answered earlier: Images are not in the database. They are in the wp-content/uploads/ folder (or its subfolders by year and months).
    That's where you upload them from the Write > Write Post subpanel.

    2. I can perfectly see your amazon images.
    Maybe it's time to take a closer look at your browser...

  5. emmettjones
    Member
    Posted 6 years ago #

    sorry. that is where i originally uploaded the pictures to. they are located in wp-content/uploads/folder/2007/10

    Based on the wording of your answer, I thought you were saying that my pictures were already in that folder, and they needed to be moved onto the database. I wasn't sure what that meant, which is why I asked the question in my second post.

    "Images are not in the database. They are in the wp-content/uploads/ folder (or its subfolders by year and months)." Read that to yourself, and tell me if its not possible for that sentence to have more than one meaning. If it isn't, then I wholeheartedly apologize.

    It is obvious I do not have the same technical skill that you have, but I don't see how sarcastic comments help either one of us.

    I don't know what could possibly be wrong with my browser, unless your implying i need to clear my cache or something...but I will just figure that out on my own. thanks again.

  6. moshu
    Member
    Posted 6 years ago #

    Well, that was an answer to your statement "I went through the database"... when looking for the images. See your initial post. OK, the more exact answer should have been: images are never stored in the database, they are in etc.
    Keep in mind I am not a native English speaker :)

    If I can see your images in your blog... I can't think of anything else that there is something wrong at your end. I can't tell since I am not there, sorry. It might be cache, might be your ISP, might be a proxy server - God knows.

    [my style is part of the package]

  7. Lozz
    Member
    Posted 5 years ago #

    perhaps test php upload is on.

    Create text file and call it checkmyphp.php

    With in the file have the code <?php phpinfo(); ?>

    ftp the file and open it in the web browser so as to check your settings. Look within phpinfo( ); file uploads set to On

    After that it may be something to do with WP.

    Hope that was useful to someone.

    Now I have a problem, its probably something very simple.

    On WP when I go to Miscellenous the first part of the sub panel is not there. The only thing that appears is the settings for the images as in size of thumbnail etc.

    Where the hell do the first go, and where do I go wrong? Thank you in advance.

Topic Closed

This topic has been closed to new replies.

About this Topic