WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Images not appearing (87 posts)

  1. hermida
    Member
    Posted 4 years ago #

    I just upgraded to WordPress 3.0 from WPMU. The images on the site are not appearing: http://thethunderbird.ca/

    The images are in the directory:
    /thethunderbird.ca/html/wp-content/blogs.dir

    Could someone suggest which instruction I need to change to make the images work again?

    Many thanks.

  2. anitaea
    Member
    Posted 4 years ago #

    I am having this same problem. In the media listing and the post edit pages, the text attached to all the images is there, but the images are not. When I upload a new image, everything acts the way it should, but the image itself does not appear. I upgraded from 2.9.2

    Thanks in advance.

  3. memitch08
    Member
    Posted 4 years ago #

    Hi,

    I think I'm having the same issue - all across the board on all of my WP installs.

    The problem seems to be that the directory blogs.dir is inaccessible. My host is BlueHost - and I've contacted them asking about the ownership of the directory, but they say it is a problem with WP - and all they can offer me is restoring my account to a backup.

    I found this thread where a host fixed the problem with a script.

    I've tried everything - even renaming the blogs.dir directory and changing permissions - but the image files won't even show up on the net. Just re-directs to the WP 404 page.

    It's like WP can't see this directory?

    Help!

  4. memitch08
    Member
    Posted 4 years ago #

    Found this here:

    The issue here with 3.0 is that if an existing WP 2.9.2 install with uploaded media upgrades to 3.0 and enables the network the blog option for the upload_path can’t be changed to the blogs.dir folder because the existing media becomes inaccessible.

    But what I don't know is - How is it fixed?

  5. memitch08
    Member
    Posted 4 years ago #

    I tried to upload new images, and they don't work either - so I don't think the problem is only with existing media.

  6. Best way to start troubleshooting is to look at the source URL

    http://thethunderbird.ca/files/cache/9690_NpAdvSubFea.jpg

    random one off the homepage. When I look it just gives me that url printed on the screen.

    the not found could mean it's not reading the image url rewriting in the htaccess file. When you upgraded from MU, you should have seen two mesages. One was about blogs.php how was moved and that you needed to update your htaccess.

    Did you do that?

  7. hermida
    Member
    Posted 4 years ago #

    I removed the blogs.php file as instructed and then updated the htaccess to the details below:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>
    # END WordPress

    Thanks

  8. memitch08
    Member
    Posted 4 years ago #

    I thought that blogs.php was no longer needed - and to be deleted?

    I did update the htaccess file this is what it says:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    My host ran a script to fix any potential ownership problems with the files, and this did nothing but delete my already created htaccess files.

    Now here's something interesting:

    If I put the file in the blogs.dir directory without any subdirectories then the file is accessible.

    See here: http://hanover4square.org/wp-content/blogs.dir/4sqlogo.jpg

    It is still fine here: http://hanover4square.org/wp-content/blogs.dir/1/4sqlogo.jpg

    But if I move the same file to the files sub-directory within blogs.dir it is not accessible?

    See here: http://hanover4square.org/wp-content/blogs.dir/1/files/4sqlogo.jpg

    But if I create a sub-directory called file1 the file is accessible?

    See here: http://hanover4square.org/wp-content/blogs.dir/1/file1/4sqlogo.jpg

    The permission on blogs.dir/1/files was 777 - so I changed it to 755 - but that didn't help.

    There must be an issue with the upload path somewhere in the code?

  9. Just noting this is the relevant line.

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

  10. memitch08
    Member
    Posted 4 years ago #

    In ms-sites.php (through Super Admin - Sites - Edit Site) I see this:

    Upload path: wp-content/blogs.dir/1/files
    Fileupload Url: http://hanover4square.org/files

    I'm not sure if that has anything to do with this or not?

    Also found the old WPMU rewrite rule was:

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    Where blogs.php was actually a file in wp-content.

    ms-files.php doesn't exist - even in wp-includes?

  11. hermida
    Member
    Posted 4 years ago #

    Thanks Andrea. I don't understand why the image path is not updating. Is there another php file that needs to be changed/updated?

  12. No, there isn't.

    There must be an issue with the upload path somewhere in the code?

    If it was in the code then everyone would have the same problem, right? :)

    ms-files.php doesn't exist - even in wp-includes?

    Then maybe you didn't get a full upgrade?

  13. Tigers X
    Member
    Posted 4 years ago #

    Same issue here, started another thread about it.

  14. memitch08
    Member
    Posted 4 years ago #

    Thanks Andrea for helping!

    If it was in the code then everyone would have the same problem, right? :)

    Well, it seems that a lot of people are experiencing a similar issue - and I wonder if it could be restricted to multi-site installs?

    There are a lot of threads about images not showing up, images disappearing, media library empty? It's not just me, but most folks (including me) don't know why - I just realize that it has something to do with the path. For some reason blogs.dir/1/files is not accessible? But blogs.dir/1/file1 is? Same permissions. And if I change the name of file1 to files it is no longer accessible either.

    Then maybe you didn't get a full upgrade?

    Ha! Ha! I found it! Didn't see it before - but it's there now!

  15. Tigers X
    Member
    Posted 4 years ago #

    BTW mine is a single site install

  16. Tigers X
    Member
    Posted 4 years ago #

    all files are in wp-content/uploads directory. Files are all there but like you said memitch if I try to look at them I get a 404 error.

  17. olahill
    Member
    Posted 4 years ago #

    all my existing images are fine on the site and in the media library. my problem is that i cannot insert any new images and if i use Tiny MCE to insert an image from url, i can't edit or reposition in wordpress. please help!

  18. memitch08
    Member
    Posted 4 years ago #

    Funny thing is - my wp-content/uploads directory is accessible! But then again I'm running a multi-site installation - which is probably the difference.

  19. olahill
    Member
    Posted 4 years ago #

    mine's single site.

  20. sandists
    Member
    Posted 4 years ago #

    I have a single site and my images are not showing up either.

  21. sandists
    Member
    Posted 4 years ago #

    Update -

    I have my media upload set to wp-content/uploads, adding year and month
    In the visual screen I can see the image.
    I can see the image with ftp.

    For example - the image is http://www.sandists.com/WordPress/wp-content/uploads/2010/06/il_430xN.1518709641.jpg

    If I try to look at it in the browser address, I get page cannot be found.

    The properties of all of the folders is 755.

    So the question is - why can't the browser see the file?

  22. olahill
    Member
    Posted 4 years ago #

    My problem's now solved. It seems one pesky plugin was the problem. See:

  23. sandists
    Member
    Posted 4 years ago #

    It was recommended that I try a different theme to see if the one I was using was having a problem with the new version. I tried several themes and didn't see any difference, the images are still missing.

  24. memitch08
    Member
    Posted 4 years ago #

    @ olahill - what plugin? Thanks!

  25. kentucky
    Member
    Posted 4 years ago #

    I'm having the same issues. After updating to 3.0 today, all my pictures uploaded and sitting on server are no longer visible. As with everyone else, they are on the server, I just cant use them. All externally linked pics previously inserted are there, but I cant insert new external pics either. I've viewed my blog in Firefox and IE. Also checked using my iphone. None will show the pics.Its not a browser issue, Ive done all the steps here just to make sure http://en.support.wordpress.com/browser-issues/

    I read a similar issue happened last year http://en.forums.wordpress.com/topic/the-insert-in-post-button-wont-work
    It was closed and never resolved. I'd really rather not have to downgrade. I was hoping this was a glitch with new software.
    I was going to try changing themes, but I see Sandists already tried that. Frustrating.

  26. kentucky
    Member
    Posted 4 years ago #

    Tried disabling all my plug ins, but no difference in my issues. Tried again to insert pic using a URL, it shows in the Visual Edit window like the others, but nothing after publishing it.

    Reinstalling 3.0 manually now to see if that does anything. Maybe there was an issue with automatic update.

  27. kentucky
    Member
    Posted 4 years ago #

    http://wordpress.org/support/topic/411987?replies=8#post-1559348 Stated deactivating Headspace2 plug-in solved a few peoples problem. I don't use that plug-in and I already tried deactivating everything to no avail.

  28. sandists
    Member
    Posted 4 years ago #

    Kentucky - the problem is that the upgrade has changed the location of the images from WordPress/wp-content/uploads to WordPress/wp-content/uploads - not the change of case in WordPress.

    I guess this only affects those who named their blog folder WordPress - so many others probably just had a folder called Blog, or some such thing.

    I read that you need to change the site settings from WordPress to WordPress before you change the name of the folder. I'm not sure where that has to be done, and I've asked my host. If you have any info - let me know.

    Of course changing the name of the folder requires a change to the main site .htaccess file to redirect.

  29. sandists
    Member
    Posted 4 years ago #

    not the change of case in WordPress.= note the change of case in WordPress.

  30. mrmist
    Forum Janitor
    Posted 4 years ago #

    See http://core.trac.wordpress.org/ticket/13971 which may be affecting you.

Topic Closed

This topic has been closed to new replies.

About this Topic