WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Images not appearing (87 posts)

  1. sandists
    Member
    Posted 4 years ago #

    Yes, I've seen that discussion before - I don't want WordPress changing the names of my files, images, etc. If it were just a simple solution of changing the main folder name - it would be easy - but I don't think that's the case. I think no matter what I do, there are going to be some underlying issues that will pop up.

  2. kentucky
    Member
    Posted 4 years ago #

    SOLVED- For me anyway. Sandists, yes I ran across your idea too and that fixed it for me. Thanks for the input, I should have checked back here sooner.

    I FTPd to my site and changed the name of the directory from Wordpress to WordPress and now the pictures show up. Now I have to decide how best to finish this correction though. If I keep WordPress renamed as is, I have several links to it I have to change etc.

    I could just make another directory JUST for pictures since I dont have that many. Like /WordPress/wp-content/uploads/2010 . This may cause other issues later than I have not foreseen though. There may be an easier way to attack this, I have to research it some though. Ill post back after I decide on the best way. I appreciate any ideas anyone else has to correct this as well. By the way, I don't remember naming this directory, I swore my original install was through my host providers Admin page.
    Ken

  3. sandists
    Member
    Posted 4 years ago #

    Ken, if you have other people linking to your blog or your blog is found in the search engines - you will need a redirect statement in the .htaccess file in the root of your site.
    than you can change links at other sites where you are registered as you can. Hope that makes sense.

  4. sandists
    Member
    Posted 4 years ago #

    Ken, I tried just changing the name of the folder and it does not work. Oh, it may be able to see the images now - but in order to use a link to the blog - it gives a 404 - page cannot be found. Have you tried using a url to get to a page?

  5. sandists
    Member
    Posted 4 years ago #

    Went to my host and there are several things you need to do to the mysql database if that's what you are using for WordPress.

    Some of the tables have to be changed to reflect the new folder name vs the old.

  6. mrmist
    Forum Janitor
    Posted 4 years ago #

    Please see the link I posted. The changes are due to a "feature" of 3.0 and you can (currently) use a plugin to override the behaviour, which would save messing around changing directory names or database entries.

  7. kentucky
    Member
    Posted 4 years ago #

    I am somewhat familiar, but I don't usually have to alter .htaccess file. I did alter is some when I was fighting spam in the beginning so know how to edit it and some syntax.

    I used the redirect statement.
    redirect /Wordpress/ http://www.mysite.com/WordPress/

    There's probably a better syntax for internal to internal, but I kept getting errors so internal to full URL seems to work. With my host and shared space the internal URL is probably going to be something weird like /home2/etc etc. redirect /Wordpress/ WordPress/
    No time to play with that till I know this works.

    That appeared to work until I try to access the admin panel. It comes up but after I log in it just keeps reloading the admin panel. Anyone have any ides?

    Thanks Mrmist, I missed your post. Ill tried the plugin suggestion and it seems to be a temp fix.
    Ken

  8. sandists
    Member
    Posted 4 years ago #

    Ken the redirect won't work unless you change the data in the database from the old name to the new.

    I put the .htaccess file back to the way it was and put the folder name back to the way it was and I'm still looking at the database. I'm going to look at the filter again and see if it's worth doing anything with before I change the data in the database.

  9. sandists
    Member
    Posted 4 years ago #

    mrmist - can you repost the link?

  10. kentucky
    Member
    Posted 4 years ago #

    Sandist, this was his link, http://core.trac.wordpress.org/ticket/13971 It basically said install "Remove WordPress to WordPress filter" plugin. Just search for in in your plugins area of Admin. Heres link for them too if you do you plug-ins via FTP: http://wordpress.org/extend/plugins/remove-wordpress-to-wordpress-filter/

    I installed it and after it turned off the case sensitive stuff, all is well in my world. Im still testing it too. All seems fine so far. Like he said, they should patch that up next update.
    Ken

    PS Sandist, is that a commerce theme you use? How easy is it to run the online store thing?

  11. sandists
    Member
    Posted 4 years ago #

    this is funny - I can't log in now to run the plugin - Ken did you have any problem with that?

  12. sandists
    Member
    Posted 4 years ago #

    well, it seems as if the database changed anyway - probably when I attempted before the correct the folder name. So I will not be using the filter/plug in - I'm logged in to the new folder name and seeing the images.

    thanks for everyone's help.

    Ken the theme I use has nothing to do with commerce. My website is commerce based.

  13. jcaynes
    Member
    Posted 4 years ago #

    I followed the 3.0 upgrade instructions and didn't have any wordpress references in previous version. I do not have the HeadSpace2 plugin installed and I am unable to insert images into my posts. When I start the insert image feature, I no longer get a pop up window and the images are set in the library but not in the post. Is there a permissions feature related to the post?

  14. chandlerwhite
    Member
    Posted 4 years ago #

    I installed the plugin. It worked the first time I did an image widget (my main prob, so I hope). Subsequent times it did not.

  15. chandlerwhite
    Member
    Posted 4 years ago #

    Incidentally, my issue is the same as jacynes', except my prob is with image widget. I'm sure it'll be with a post if I write tonight.

  16. chandlerwhite
    Member
    Posted 4 years ago #

    jcaynes - sorry.

  17. kentucky
    Member
    Posted 4 years ago #

    Sandist, yes when I changed the Directory to WordPress, it all seemed to work (picture wise) except Admin login. Thats why I was trying to figure out the best redirect etc to repair that. I changed it back to WordPress and used that plugin so Ill just wait for the bug fix.

    Thanks, I installed Ecommerce, but only to play with it for now.
    Ken

  18. kentucky
    Member
    Posted 4 years ago #

    chandlerwhite, I disabled plug-ins first (verified I could post correctly with pics) then I enabled all of them one at a time. I did this after MANUALLY updating to 3.0 after using automated update. My admin interface looks slightly different so I have to assume that the automated one did not successfully update all files. Follow directions carefully if you do that. especially backup and update individual files on wp-content.

    I do use the media plug-in http://wordpress.org/extend/plugins/post-rich-videos-and-photos-galleries/
    and its works as well.

  19. memitch08
    Member
    Posted 4 years ago #

    I tried the WordPress to WordPress plugin - and it didn't do anything for me? I do not have a directory named WordPress or WordPress.

    Still a no-go to my files. :(

  20. kentucky
    Member
    Posted 4 years ago #

    memitch, you have the same exact problem about your pics not showing up in your posts after update and also not being able to post new pics?
    What folder is your WordPress under? Renaming the file folder to WordPress worked for me too, but I then had an issue, like Sandists, where I couldn't log into Admin anymore. I was just stuck there and login only brought me back to login page. There is probably further modification that needs to be done if you take that route, some was described in earlier posts here. I didn't get that far since the plug-in worked for me.
    Ken

  21. memitch08
    Member
    Posted 4 years ago #

    My entire media library disappeared from wordpress. All it shows is the links. If I try to upload new media it is also inaccessible.

    My install is for multi-site - and my files are in blogs.dir/1/files - the "files" directory is the only one that is inaccessible for viewing. Every other directory is accessible - ie blogs.dir, blogs.dir/1/ and even blogs.dir/1/file1.

    I tried the plugin suggested - but it didn't do anything for me - although I didn't log-out and try to log back in.

  22. dazza202
    Member
    Posted 4 years ago #

    Well I am quite new to wordpress and I can upload the image but I cannot insert into the post, my browser states it is done but nothing happens. I tried installing the plug in as suggested but nothing happened. Very confusing for a newbie. I hope wordpress find a solution unlike the last time and it was just closed with no solution.

    I would appreciate any further comments to resolve this issue.

  23. kentucky
    Member
    Posted 4 years ago #

    memitch08, I was only working with a single site. When you FTP to your site, the media library is gone or its just gone from within WordPress Admin when trying to post pic? Have you tried disabling all plug-ins and see if you still have problems? I reinstalled 3.0 manually too just to make sure all files were on there. If WordPress is changing Wordpress to WordPress on your site, would that effect your picture locations (ie break the link to them)? Worst case revert back for now. I think I posted links earlier on how to do that. If not, its easy to Google it.
    Sorry if that's not much help.

    dazza202, so you are unable to insert pictures into post in the WordPress Admin area? Nothing appears, not even a white box? The plug-in only works if you were not able to see your pictures after posting them in 3.0. You could see them while editing. WordPress was changing the directory name. As above, you might try a manual install to make sure no files are corrupt or missing.
    If you are new and just installed WordPress, you might want to delete it then go get the previous version from their archive section. Install that until a few bugs are worked out of 3.0.

  24. memitch08
    Member
    Posted 4 years ago #

    No - I have a multi-site install. The files are there in the FTP - but cannot be accessed via the url path to the image/file.

    Tried disabling all plugins - no-go.
    Tried manual install - no-go.
    Tried fixing htacess - no-go.
    Tried WordPress to WordPress plugin - no-go.

    The funny thing is that I was running 3.0 RC1 & RC2 - and did not have any issues with the files until 3.0 came out with the auto upgrade from RC2.

  25. dazza202
    Member
    Posted 4 years ago #

    Kentucky

    Hi Mate I removed a plug in now I can insert the image, but all I see is the white box but no image. If I click on the image it takes me of to a page with a hyperlink then If I click on this I got error 404.

    Darren

  26. The funny thing is that I was running 3.0 RC1 & RC2 - and did not have any issues with the files until 3.0 came out with the auto upgrade from RC2.

    Something got renamed in there... if only I can remember the trac ticket...

    This was the down side of running the beta. you'll have to go change something in your image URLs but I need to remember what I forgot. :D

  27. memitch08
    Member
    Posted 4 years ago #

    Hey Andrea -

    The problem is with the word "files" specifically -

    Any directory that I create is inaccessible if it is named "files"

    Can I just change the name from "files" to "file" or "uploads" and get around it that way?

  28. toutsursam
    Member
    Posted 4 years ago #

    I have the same issue about memitch08
    For your information my browser display the following pathmy : blogs.dir/1/files/...
    Pictures don't appear. However on ftp it's the same path.

  29. memitch08
    Member
    Posted 4 years ago #

    I think I have it fixed toutsursam -

    here's what I did:

    I changed the word "files" to "uploads" and now everything is accessible.

    I also changed the Fileupload Url and Upload Url Path as well as the the .htaccess - all instances of "files" to "uploads".

    This seems to make the files accessible

  30. toutsursam
    Member
    Posted 4 years ago #

    @memitch08
    Unfortunatly it doesn't work for me :(

    When You said you changed the word "files" to "uploads". Wich word ? From the files in FTP ?
    In htaccess Fileupload Url and Upload Url Path seem missing. I haven't instances whith files.

Topic Closed

This topic has been closed to new replies.

About this Topic