WordPress.org

Ready to get started?Download WordPress

Forums

Customizr
[resolved] Images not appearing (11 posts)

  1. Rick Lavoie
    Member
    Posted 4 months ago #

    Hosting: Managed WordPress hosting on GoDaddy.com
    Customizr theme
    http://tellicokats.com
    WordPress 3.8.1
    WordPress, Theme & Plugins are all up to date
    Firefox Browser 27.0.1
    Mac OS 10.6.8
    Location: USA

    All was working fine, until this morning I created a new post, added a photo (upload media from the media library) to my text, the photo did NOT appear. When I switched from "visual" to "Text" tab, I can see the HTML code for the uploaded photo is there! I also have several static pages, and I am now having this same problem with images on static pages too. This is only a problem with images I want to add to the text (body) as of this morning. All images posted on the static pages prior to today are still working fine. However if I go to edit images on a page or add images, then the problem exists.
    Also, Slider images are not affected by this issue, they work fine.

    I have not overfilled the 3 GB capacity of the uploaded images, and the image I am uploading is just 500 pixels wide. I can't find any other support or FAQs which answer my problem.

    Example of image problem...
    http://tellicokats.com/blog/
    On the Blog page, you'll find 2 postings.
    "Happy St. Patrick’s Day" is the newer posting and it shows the problem I'm having.
    The older post shows that photos were working fine!
    Happy St. Patrick’s Day - posting
    http://tellicokats.com/2014/03/happy-st-patricks-day-2/

  2. d4z_c0nf
    Member
    Posted 4 months ago #

    I can see this in your page source:

    <a href="http://tellicokats.com/wp-content/uploads/2014/03/leprechaunBrownie500.jpg"><img class="alignleft size-medium wp-image-194" alt="Leprechaun Brownie" src="http://tellicokats.com/wp-content/uploads/2014/03/leprechaunBrownie500.jpg" width="1" height="1"></a>

    The problem is that width="1" and height="1" .
    Are you sure you didn't accidentally changed those values while editing the article?
    If you're sure, could be a problem with some plug-in...

  3. Rick Lavoie
    Member
    Posted 4 months ago #

    Hello,
    Thanks for your help...
    Yes, it appears that
    width="1" and height="1"
    is my problem.
    I have not accidentlly modified the pixel settings for width & height to 1 pixel.
    But, here is what I have just discovered!

    There are about 40 images that were uploaded prior to March 17th.
    These images all work fine.

    If I upload a new image, then the problem exists... the width="1" and height="1"
    I just noticed that "Size" (when using "Add Media") is NOT there!

    Add Media -->
    under: Attachments Display Settings:
    Alignment, Link To, Size
    "Size" does NOT show up

    This would explain why the image is being set to the lowest default
    the width="1" and height="1"

    Any ideas as to what is going on?

  4. d4z_c0nf
    Member
    Posted 4 months ago #

    Yeah, that could be the reason.
    My guess is that some plug-in could cause that, so what you have to try is disable all your plug-ins and try to add a media again.

  5. ElectricFeet
    Member
    Posted 4 months ago #

    Could you:
    - delete the image
    - then make sure that retina support is switched on in the Images section of Customiz'it
    - then re-upload the image.

  6. Rick Lavoie
    Member
    Posted 4 months ago #

    Thank you so much!!!!!!!!!!
    That was the problem.
    Customiz'it: Images --> "retina support" - ON

  7. d4z_c0nf
    Member
    Posted 4 months ago #

    mm, so you switched it off some days ago?

  8. Rick Lavoie
    Member
    Posted 4 months ago #

    By the way...
    GoDaddy "Managed WordPress" default File PERMISSION Settings are:
    Images (JPEG, etc.), uploaded files (PDFs) set to 604
    Directories set to 705

  9. Rick Lavoie
    Member
    Posted 4 months ago #

    Yes, thinking back on it, here is what happened:
    The Customizr default image settings were all on, including "retina support". I had uploaded images via WP Media Add New.
    Thus all those images worked fine, because the file sizes "2x" etc. were all ok. 2 days ago, for some reason, I re-visited all the Customizr settings, and turned off all 3 settings for images, including "retina support". I had no clue that "retina support" needed to be turned on. Thus all images that I uploaded from that point on were "corrupt" and displayed at 1 x 1 pixels.

    I am so glad you responded with the solution to my issue. I was about to uninstall all the plug-ins! Thanks again!!!

  10. d4z_c0nf
    Member
    Posted 4 months ago #

    uninstall all plugins? drastic!
    Anyway many thanks to ElectricFeet, who solved another problem :D

  11. ElectricFeet
    Member
    Posted 4 months ago #

    Thanks @banjorick for the extra info. There really does seem to be a bug in non-retina image upload.

    @nikeo: looks like the non-retina option continues to cause problems.

    @nikeo and @anyone else: Why would a user want to turn retina support off (except if they don't know what it does, as above)? Surely everyone should want the higher-res display for users with fancy screens (which will be considered the default screens pretty soon). Could @nikeo simply* remove this option and give retina support by default?

    * I know that with code, "simply" is rarely simple...

Reply

You must log in to post.

About this Theme

About this Topic