WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Images missing from subscriber e-mails (8 posts)

  1. TheRewardBoss
    Member
    Posted 2 months ago #

    Hello,

    I usually attach a photo at the top of my posts but these do not appear in the subscriber emails.

    I saw this post from about a year ago which appear to discuss the same problem but I can't figure out what I'm doing wrong.
    http://wordpress.org/support/topic/images-missing-from-subscriber-e-mails-jetpackwp?replies=27

    My site is http://www.therewardboss.com.

    Also, is there any way to control the length of the email? Would it be by changing the setting to "full text" instead of summary and using the "more" tags? If so, are there instructions somewhere on how to do this?

    Thanks

    https://wordpress.org/plugins/jetpack/

  2. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 2 months ago #

    Howdy,

    Yes, you can set the break point in the e-mail using the More Tag. Details on how to add this can be found at http://en.support.wordpress.com/splitting-content/more-tag/

    The setting to change from summary to full-text is found via Settings->Reading.

    Are the images not working in any post or only on certain ones? If on certain ones, could you send me links to those that are not working?

    Cheers!

  3. TheRewardBoss
    Member
    Posted 2 months ago #

    I dont ever get images in the email notifications.
    Here's an example:
    http://www.therewardboss.com/2014/04/30/its-back-3-free-first-class-1-way-domestic-tickets-worth-up-to-4200-with-the-premier-miles-more-world-mastercard/
    There is a logo at the start of the post. I can forward you the NEW POST notification by email - seems only text would paste here.

  4. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 2 months ago #

    I just followed your blog so I'll see the next post you create (please do make a post here after you do so I'm on the look out for it).

    I tried a post on my test site borrowing the same HTML as your post and didn't have any problems with it.

    Cheers!

  5. TheRewardBoss
    Member
    Posted 2 months ago #

    Brandon,
    I just posted an article a few hours ago.

  6. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 2 months ago #

    Ah, it would appear you have the Settings->Reading setting set to only use excerpts in your feed. We respect that setting for e-mail subscriptions and excerpts within WordPress don't include images.

  7. TheRewardBoss
    Member
    Posted 1 month ago #

    Thanks you!!! I will give that a shot. Will this also allow my avatar to show? I used to have it show up next to my posts but since I switched to self hosting, i can't get it to appear.
    This is my avatar:
    https://en.gravatar.com/rewardboss

  8. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 1 month ago #

    Hi,

    Regarding that, be sure that the e-mail address associated with your user name on your self-hosted site is added to your Gravtar account. Within Gravatar, you can add multiple e-mail addresses and assign the same (or different if you choose) avatars per e-mail address.

    Cheers!

Reply

You must log in to post.

About this Plugin

About this Topic