WordPress.org

Ready to get started?Download WordPress

Forums

Images Linked By Default? (11 posts)

  1. nickaster
    Member
    Posted 4 years ago #

    Hi - when using the media uplonder and inserting images into posts, the default behavior seems to be to make the image into a link - to itself.

    In the past this wasn't the case, but it seems to be happening for all the writers on my team. They're not very HTML saavy so have no idea they've done it, so I have to go into posts and get rid of the HREF around the images.

    How can I make the default for all users to be NOT having uploaded images be links?

    Thanks!

  2. henkholland
    Member
    Posted 4 years ago #

    Hi,
    In the Visual editor when yuo insert an image there are three choices at the bottom: none, file url or post-url. WP remembers the last choice, at least during the session and maybe untill you make a new choice.
    So, the change is definitely a result from a recent choice.

    I would not know how to make a default setting that cannot be changed.

  3. nickaster
    Member
    Posted 4 years ago #

    Yeah, that's what I thought, but it doesn't make much sense that EVERYONE is now getting saddled with the link choice. For a dozen writers to suddenly start doing it whereas none were before seems odd.... was there some development in a recent upgrade that made this the default? More importantly, why would anyone ever want to do this? It's a real nuisance to readers!

  4. henkholland
    Member
    Posted 4 years ago #

    Usually the image in a post is a thumbnail, say 150 pixels and clicking it shows bigger image, say 800 pixels wide.
    There are some nice plugins to flip through images if you have more than one in a post, like shutter-reloaded. No real changes in this behaviour since 2.7.1 as far as I know.

  5. nickaster
    Member
    Posted 4 years ago #

    Yeah, but it's bad practice to force the browser to make a thumbnail (in my opinion) - slows down the site a lot. This is driving me nuts. All 6 of my latest posts from 6 different authors have this problem. THese are not web saavy people and no matter how many times I explain it, they nod, but don't understand. There's no question that somehow the default became the "linked" version....

  6. henkholland
    Member
    Posted 4 years ago #

    Hi Nick,

    Wp generates a permanent thumbnail in the directory wp-content/uploads/ and that one loads quicker than the bigger image which is especially important if you have, say 10 posts with images on the frontpage.
    The bowser loads the thumbnails and only upon request, i.e. clicking on it, it shows the bigger image.

  7. nickaster
    Member
    Posted 4 years ago #

    Yeah, but I specifically ask my writers to re-size images BEFORE putting them in the posts. I think it's great that wordpress now can do this for you, but it just confuses readers to have a clickable image that, in most cases, just goes to a page with an image on it, so unless there's a good reason to (like some kind of large chart), I'd much prefer the images do NOT become clickable by default.

  8. henkholland
    Member
    Posted 4 years ago #

    I agree Nick but I know no way to make the "none" for link default (allthough it sticks to the setting after choosing it once until you choose a new setting).
    Because I always use thumbnails, I like the sticking to settings.

    I tested a bit with my media settings leaving only one size 800x800 available and no thumbnails and even after uploading an image of 400x400 WP offered an image link (which was useless of course).

    There's always room for things to get better.

  9. nickaster
    Member
    Posted 4 years ago #

    Well, at least I understand the problem now. Thanks for your help!

  10. billzy
    Member
    Posted 3 years ago #

    This didnt even answer the question... There HAS to be a way to do it because it's there in the first place... I hate it when IT people say somethings not possible... its usually always possible, it's just how long will it take is a better question?

  11. keesiemeijer
    moderator
    Posted 3 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic