WordPress.org

Ready to get started?Download WordPress

Forums

Images in Typepad moving to WP (18 posts)

  1. Blazenhoff
    Member
    Posted 9 years ago #

    Hello,

    I have recently installed WP and have been trying to move over my Typepad posts for a few days now. The problem isn't the text, which imported beautifully...it's the images. The images come up but they are being linked to my Typepad site. I thought if I edited the import.txt file and swapped the typepad.com info for my info, it would switch...but it didn't. Is there a simple way to link the images to my database and not theirs? What am I doing wrong?

    Thanks a million.

  2. Blazenhoff
    Member
    Posted 9 years ago #

    Here is an example:
    http://(leftblank).typepad.com/.shared/image.html?/photos/uncategorized/image.jpg
    http://(leftblank).typepad.com/photos/uncategorized/image.jpg

    So instead of linking to the images in my new URL,, they continue to link to the typepad.com info...

    I don't know if that helps or not.

    Thanks again,
    -r

  3. Matt Mullenweg
    Troublemaker
    Posted 9 years ago #

    I wrote a plugin to sideload all the images from Typepad, unfortunately it hasn't been packaged but you can download it here:

    http://dev.wp-plugins.org/file/cache-images/trunk/cache-images.php?format=txt

  4. Blazenhoff
    Member
    Posted 9 years ago #

    Ah thanks...I added this to my plugins and just now (hours later) realized it conflicted with another plugin (a stylesheet one). So, now it lists what images I could cache but when I click "Cache these images", I get a message saying:

    Your upload folder is not writable

    How can I fix *this*? Is this more to do with my host or can I change privileges on my end?

  5. vkaryl
    Member
    Posted 9 years ago #

    You need to change permissions on whatever "your upload folder" is, to allow the server to write to the file. You can do this through your ftp client, or through cpanel if you are on a host that supplies it.

    The minimum chmod for server write would be "666" - occasionally you will have to chmod a folder to "777" but that's not a very good idea. Use the minimum you can get by with....

  6. Blazenhoff
    Member
    Posted 9 years ago #

    That might be the problem...I don't know exactly where my "upload" folder is (be kind, I'm new to this). I created a folder named "upload" with full permissions but it's not working. Is there a simple way to find the upload folder? Or do I have to create it in a special place on the server?

    Apologies if these are basic questions. I have really tried to figure this out on my own. ;)

  7. vkaryl
    Member
    Posted 9 years ago #

    Generally, I would place a folder for uploaded images f'rinstance in the wp-content folder, but that's just me. Others would probably place it in the root WP folder (the same place as wp-admin etc. folders live).

    So using either your ftp client or your cpanel or however you access your site to change things, you'd look for something like public_html/wordpress (or whatever the folder WP is installed in is named)/upload; or if you're like me, public_html/wordpress install folder/wp-content/images (my image upload folder). Once you find it, you need to see what the permissions are currently set at (most likely 644), and change that to 666. If 666 still gives you an error message, then you'll need to change it to 777.

    If changing the permissions isn't an intuitive thing with your host (some aren't, believe me!), then you should email your host support staff and ask them exactly how to accomplish the change.

    Don't apologize for basic questions. We all asked 'em at some point!

  8. Blazenhoff
    Member
    Posted 9 years ago #

    Thanks again. I know how to change permissions but I don't think I know where my upload file lives. So, then I created one as you described and then set the correct permissions and the plugin still doesn't work. I'm wondering if there is something about the plugin that I'm not understanding....like I have to name the upload file something very specific and put it in a special place on the server...?

    Right now, I have an images folder with full permissions set up in my wp-content directory. Maybe it just doesn't know where to find this file...?

    I am lost.

  9. vkaryl
    Member
    Posted 9 years ago #

    I can't tell from looking at the file Matt sent you to. It gets the info through php functions, and I don't "read" them well. This may be something Matt will have to address for you?

  10. Matt Mullenweg
    Troublemaker
    Posted 9 years ago #

    It's the folder specified under Option > Misc.

  11. vkaryl
    Member
    Posted 9 years ago #

    Oops. *embarrassed grin* I forgot about having to specify it there, Matt!

  12. Blazenhoff
    Member
    Posted 9 years ago #

    Laugh...I created an "images" folder in /wp-content/ and then went to Options-->Misc. to "allow file uploads" and dangit! It still doesn't work. It still says it's not writable.

    Suggestions? Tips?

  13. vkaryl
    Member
    Posted 9 years ago #

    You put the relevant path into the destination directory and URI locations, right? And you double checked to make sure the relevant folder was actually showing 666 in permissions?

    Assuming a "yes" to both of those, try changing the folder permissions to 777 for right now.

    [Just for a comparison, here's how the above locations look in my Options/Miscellaneous page:

    Destination directory: /home/username/public_html/wordpress/wp-content/images

    URI of this directory: /wp-content/images

    Note that there are no trailing slashes after "images"....]

  14. n3ldan
    Member
    Posted 8 years ago #

    I have spent 40 minutes trying to get this to work, it jsut wont work. The directory stuff is all right, I knwo how to chmod, i set it in options>misc, and yet it still says that the directory is not writable! Is there anyway to manually specify the directory in the file itslef? That would be *so* much easier.

  15. mashable
    Member
    Posted 8 years ago #

    I can't get cache-images to work either. I activated the plugin, created the folder in wp-content/uploads and gave it 666 permissions (also tried 777, but no difference). But when I run the plugin, I just get the message "Your upload folder is not writable".

    I'm running WP 2.0.

  16. sclark
    Member
    Posted 7 years ago #

    I am having the exact same problem.

    My upload folder is writable - I have tried it at 777 and 666? I am able to upload other tuff - just not this! What's the go? :)
    Can someone please give me some tips?

    Does the plugin not work for WP 2.0? Is there any other way of importing all these images?

  17. goblue
    Member
    Posted 7 years ago #

    This looks like just the plugin I've been wanting to use for quite some time. For now, I've manually coded the folder paths and have gotten it to work with WP 2.0. WP 2.0 doesn't have an upload folder set in the admin (I don't think!) so I'm manually coding these variables for now.

    Everything works OK EXCEPT when I do this: if I write a blog post and link to an image at http://www.somesite.com, and then cache it in the admin, that works perfectly. If I do a second post, and link to another (different) image, and then cache that at a later time, the first image that was in my cache folder gets 'overwritten' and is 0 bytes. So any subsequent cachings seem to render the previous ones dead by overwriting them somehow.

    Is there some sort of file locking I'm missing? Honestly, I was tweaking the "1.0alpha" version of this plugin. I just came across the 1.2 version here. Maybe Matt has fixed this? Or could be I have something set incorrectly. I might try modding this 1.2 file to see if that works any better.

  18. bookchiq
    Member
    Posted 7 years ago #

    I haven't played with the file lock question, but I updated the plugin to work better with WP 2.0 (to get around the "upload folder not writable" error):

    http://www.bloggingexpertise.com/plugins/cache-images/

    Hope this helps!

Topic Closed

This topic has been closed to new replies.

About this Topic