WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Images have all disappeared! (27 posts)

  1. Benjamino1975
    Member
    Posted 1 year ago #

    Hi,

    I am a bit of a WordPress amateur as this is my first site. I logged on today and noticed all the images in my library are not working and have a broken image icon. I have updated WordPress to the latest version thinking this would cure it and done all the updates too. It hasn't so I deleted all my images and tried uploading them to the library once again. I am still getting the broken image icon.

    Please help....

    Thanks

  2. jennybeaumont
    Member
    Posted 1 year ago #

    what theme are you using? try switching to a default and see if that works.
    -jennyb

  3. Benjamino1975
    Member
    Posted 1 year ago #

    Hi, thanks for your response. I am using "Responsive". Will I lose everything else in terms of layout, widgets etc if I swap the theme?

  4. jennybeaumont
    Member
    Posted 1 year ago #

    Well, only temporarily. But if you change to a default theme and your images come back, you'll know that the problem lies within your theme. If that doesn't work, try the same with plugins. Turn them all of and see if that fixes the prob. If it does, turn them back on one by one until you figure out which one is causing the problem. The other thing to try would be re-uploading all your wordpress core files, in case one is missing or corrupted.

    good luck!
    -jennyb

  5. Benjamino1975
    Member
    Posted 1 year ago #

    Hi, I have switched the theme (now Twenty Eleven) and the problem still persists. I notice when I click "Edit Image" it appears, but then when I re-Save it the problem still persists too.

    Any more suggestions at all please?

  6. jennybeaumont
    Member
    Posted 1 year ago #

    try the other above mentioned tests : re-upload all wordpress core files, and turn off all plugins (probably not in that order).

  7. Benjamino1975
    Member
    Posted 1 year ago #

    Thanks - how do I go about that on DreamHost please?

  8. jennybeaumont
    Member
    Posted 1 year ago #

    try deactivating plugins first.
    as for uploading the files, you can download a fresh copy here http://wordpress.org/
    then you will need to connect to your server via FTP if you want to upload the files manually.
    what version of wordpress are you currently running?

  9. Benjamino1975
    Member
    Posted 1 year ago #

    Hi, I have de-activated all active plugins, tried the upload in the library and the problem is still apparent.

    I have upgraded to WordPress 3.5.1 both on the DreamHost server and WordPress Admin.

    The 'beauty' of choosing DreamHost was supposed to be that they had a quick install of WordPress and that I wouldn't have to mess about.

  10. jennybeaumont
    Member
    Posted 1 year ago #

    link to the site ?

  11. Benjamino1975
    Member
    Posted 1 year ago #

    http://www.jamesonstearooms.co.uk/

    Since I have changed the theme to Twenty Eleven, the standard theme images are displaying. Any I upload to the library aren't.

  12. jennybeaumont
    Member
    Posted 1 year ago #

    interesting. it may be a chmod problem. all folders/files on your server have read/write rules, yours may not be set properly. double check for all of your upload folders, they should be at 755. to do this, there should be an "info" button on your ftp manager or interface. click it after selecting the appropriate folder.

  13. Benjamino1975
    Member
    Posted 1 year ago #

    Hmm, thanks again. I have submitted a ticket with DreamHost with your advice to see if they can advise.

    Thanks again for your input - much appreciated :)

  14. jennybeaumont
    Member
    Posted 1 year ago #

    you're welcome, hope you get it worked out!

  15. robertdean09
    Member
    Posted 1 year ago #

    check if your default media upload folder is wp-content/ in settings . Some plugins counter interact with it if you change that .

  16. Benjamino1975
    Member
    Posted 1 year ago #

    Sorry to be thick - do you mean in the WordPress admin panel or DreamHost's?

    Thanks :)

  17. Benjamino1975
    Member
    Posted 1 year ago #

    Help.... please..... I still have the issue and I am a bit stumped as to what to do to rectify it...

    Thanks all

  18. jennybeaumont
    Member
    Posted 1 year ago #

    Heya,
    Did you check your CHMOD settings like I suggested?
    -jennyb

  19. Benjamino1975
    Member
    Posted 1 year ago #

    Hi Jenny - no I didn't due to not knowing where to look. Please can you elabourate. I did issue a ticket to support on DreamHost about folder permissions but I haven't had a response.

    Thanks again :-)

  20. jennybeaumont
    Member
    Posted 1 year ago #

    So when you access your web server via FTP, you can see all of the files and folders that make up your site. The 3 main wordpress folders are wp-admin, wp-content, and wp-includes. Within wp-content, you have a folder called "uploads" - this is where your images are stored. They are further organized by year and month (each represented by yet another folder). If you select the uploads folder, you should then be able to access its information, allowing you to change the name of the folder (don't do that tho) and its permissions. It's these permissions I'm talking about. They should be set to 755 (you'll see this number change as you select/deselect the check boxes, looks something like this :

    X X X
    X X
    X X

    Verify this setting for the Uploads folder, each year folder, and each month folder. If you see less check boxes than this, then make them all like this. If they're already like this, you can try checking all the boxes (777) and see if that works. It's not the best settings for security reasons, but it will help you narrow down your problem.

    To access your site via FTP without going through Dreamhost, there are a bunch of easy to use FTP clients (programs) out there. I use Fetch. Another is FileZilla http://filezilla-project.org/

    Good luck,
    -jennyb

  21. jennybeaumont
    Member
    Posted 1 year ago #

    Oops - the formatting on my Xs didn't take. On the second and third lines, there should be a space in between the Xs.

    In other words - you will have three columns and three rows.
    Row 1 : all Xs checked
    Row 2 : first and last Xs checked
    Row 3 : idem

  22. Benjamino1975
    Member
    Posted 1 year ago #

    Hi,

    Thanks for your reponse again. I have changed the permissions as per your post and have tried uploading images again into the library on WordPress to no avail. It doesn't throw an error or anything, it simply doesn't show the images thumbnails in the library, or when you select one and within a page, it doesn't display!

    As I am logged in via FTP on the server, I can see that the images have uploaded to the following directory: -

    /jamesonstearooms.co.uk/wp-content/uploads/2013/01

    Is this correct?

    Thanks :-)

  23. jennybeaumont
    Member
    Posted 1 year ago #

    ok - I just found another forum post that indicates it might be your .htaccess file causing the problem. If you make it writable (permissions 755-777) you can generate one from your wp admin under Settings > Permalinks.

    Otherwise, you can create one with the basic info :

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    And upload it, hopefully then writing over the one that's there. Because the file starts with a ".", it's not always visible via FTP. But trust that's it's there (at the site's root).

    Give it a try and let me know how it goes.
    best,
    -jennyb

  24. Benjamino1975
    Member
    Posted 1 year ago #

    Hmm, I can't see that file in the route directory as you said so I can't change the permission. Not sure quite how to create one in under Settings > Permalinks either tbh???

    I tried creating a ".htaccess" file in Notepad but it won't let me save it without a file extension to upload it.

  25. jennybeaumont
    Member
    Posted 1 year ago #

    Yeah, that's the tough bit. Can you save the text file, then rename it afterward? I'm on a Mac and have my local settings set to see invisible files. If you can't see invisible files on your computer, well, they disappear! Tis a problem indeed. :-S

    If you want to email me your FTP info, I can (exceptionally) do it for you
    [ redacted, support is offered via the forums and not email ]

  26. Benjamino1975
    Member
    Posted 1 year ago #

    Jenny B has resolved my issue - she's an absolute star :-)

  27. jennybeaumont
    Member
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Topic