WordPress.org

Ready to get started?Download WordPress

Forums

Twitter posts to Blog
[resolved] Images from Tweets not showing (31 posts)

  1. Mimbari
    Member
    Posted 11 months ago #

    All the images uploaded when posting from tweets are in blank. A image is uploaded but I can't see the image because is empty. :(

    http://wordpress.org/plugins/twitter-posts-to-blog/

  2. badbreze
    Member
    Plugin Author

    Posted 11 months ago #

    Contact your hoster to know if your server has "allow_url_fopen" enabled

  3. Mimbari
    Member
    Posted 11 months ago #

    OK! it works perfectly now! thank you very much!

  4. Mimbari
    Member
    Posted 11 months ago #

    I'm having problems yet... It has to be enabled or not? Right now is enabled and it doesn't work :(

  5. badbreze
    Member
    Plugin Author

    Posted 11 months ago #

    need to be enabled. i dont know how to help you, try contact your hoster asking for this problem. sorry

  6. berendvaneerde
    Member
    Posted 8 months ago #

    I'm also getting blank twitter images in my posts. It appears that my host does not have allow_url_fopen enabled, but that they can whitelist some wordpress applications.

    How do I find the IP's that need to be whitelisted by my host in order to show the images from twitter?

    Tanks in advance,

  7. badbreze
    Member
    Plugin Author

    Posted 8 months ago #

    normaly the images are hosted on p.twimg.com but maybe there are some other servers

  8. berendvaneerde
    Member
    Posted 8 months ago #

    thanks!
    My host turned allow_url_fopen on I deleted all posts permanently and reloaded them, but still blank images...
    Is there something else wrong maybe?

  9. badbreze
    Member
    Plugin Author

    Posted 8 months ago #

    nothing in error log? the original images is aviable in wp-content/uploads?

  10. berendvaneerde
    Member
    Posted 8 months ago #

    The images are uploaded to the uploads folder with names like: 'bxlkyqrccaapyha.png'
    But they are 0KB and therefore empty (blank). I'm sorry if I'm bothering you, but I can't find an error log. Where is this?

  11. badbreze
    Member
    Plugin Author

    Posted 8 months ago #

    Deppends on your hoster, in my hosting i have an error_log file on the rinning script folder, eg wordpress main folder and wp-admin folder =)

  12. berendvaneerde
    Member
    Posted 8 months ago #

    There you go:

    [22-Oct-2013 13:35:09] Loop query string \n
    [22-Oct-2013 13:35:12] PHP Warning: file_get_contents(http://pbs.twimg.com/media/BXLkyqRCcAAPYHa.png) [function.file-get-contents]: failed to open stream: Connection refused in /home/vhosts/botoboto.com/httpdocs/wp-content/plugins/twitter-posts-to-blog/functions.php on line 696
    [22-Oct-2013 13:35:16] PHP Warning: file_get_contents(http://pbs.twimg.com/media/BXG_8pbCMAAAdot.png) [function.file-get-contents]: failed to open stream: Connection refused in /home/vhosts/botoboto.com/httpdocs/wp-content/plugins/twitter-posts-to-blog/functions.php on line 696
    [22-Oct-2013 13:36:54] Loop query string \n
    [22-Oct-2013 13:36:57] PHP Warning: file_get_contents(http://pbs.twimg.com/media/BXLkyqRCcAAPYHa.png) [function.file-get-contents]: failed to open stream: Connection refused in /home/vhosts/botoboto.com/httpdocs/wp-content/plugins/twitter-posts-to-blog/functions.php on line 696
    [22-Oct-2013 13:37:00] PHP Warning: file_get_contents(http://pbs.twimg.com/media/BXG_8pbCMAAAdot.png) [function.file-get-contents]: failed to open stream: Connection refused in /home/vhosts/botoboto.com/httpdocs/wp-content/plugins/twitter-posts-to-blog/functions.php on line 696

  13. badbreze
    Member
    Plugin Author

    Posted 8 months ago #

    nice, type this to your hoster and ask for a solution =D

  14. berendvaneerde
    Member
    Posted 8 months ago #

    My host is asking if the plugin is trying to make a localhost connection. (That type of connection is not possible with my hosting or something) Because after including the IP's on the whitelist and enabling the url_fopen it's unfortunately still not working :(

    I'm kind of clueless in this... but I also came up to a possible CURL soloution? Is it possible to make the connection with the twimg.com server with CURL instead of file_get_contents?

  15. badbreze
    Member
    Plugin Author

    Posted 8 months ago #

    yes, the wordpress cron system call itself when run some cronjobs, if your site is not able to make self calls try using this method:
    http://wpdailybits.com/blog/replace-wordpress-cron-with-real-cron-job/74

    =D

  16. berendvaneerde
    Member
    Posted 8 months ago #

    ok so i made a working cron-job that succesfully gets the posts after 30 minutes. But it is still nog getting the images. Is there somewhere in the script a way to adjust the way the images are received that surpasses my hosts limitations?

  17. badbreze
    Member
    Plugin Author

    Posted 8 months ago #

    You can use curl to retreive images, but if you dont know how to use curl wait this weekend, i relase a new version with this function! =)

  18. berendvaneerde
    Member
    Posted 8 months ago #

    You're amazing! I'll buy you a digital beer when it's working!

  19. badbreze
    Member
    Plugin Author

    Posted 8 months ago #

    Wait few minutes, i relase now

  20. berendvaneerde
    Member
    Posted 8 months ago #

    Great that there's a curl option now!

    Unfortunately it's still not working. Still a 0kb image is uploaded to the uploads folder... This is defenitely a hosting problem, but I seem to be out of options here. My host doesn't allow fopen_url or curl apparently. They say they give the option to whitelist some IP's but I already asked this and it's not giving me any images so far.
    Do you think I should just take another hosting company. Is this a problem that occurs with a lot of hosts?

    Or is there still another option to show the images in my blogposts. e.g. by iframe or something else?

  21. badbreze
    Member
    Plugin Author

    Posted 8 months ago #

    i think is better to change hoster, normaly all hosters have curl enabled by default =)

  22. berendvaneerde
    Member
    Posted 8 months ago #

    My host say they're sure there are no outgoing connections being blocked in any kind by there hosting. I'm kind of clueless at the moment.

    I seem to be able to get the posts, and also the right file and link name to the twitter server. But the image is just not uploaded to the uploads folder correctly. Do you have any suggestions left to try or debug, before I go change a host and come to the same conclusion?

    I'm very grateful for your help already. I still hope to resolve this anytime soon. preferable with my current host of course.

  23. badbreze
    Member
    Plugin Author

    Posted 8 months ago #

    dont know where is the problem in your host, what hosting are you using? maybe i know any friend with your hosting and can made some tests =D

  24. berendvaneerde
    Member
    Posted 8 months ago #

    I'm using hosting2go.nl It's a dutch company. You can even do the tests on my wordpress installation if you want.

  25. badbreze
    Member
    Plugin Author

    Posted 8 months ago #

    hmmm ok, send make me an account in your blog and an account ftp to make some test, use this form http://www.divenock.com/contatti/ to send me the data and to avoid spam

    thanks

  26. berendvaneerde
    Member
    Posted 8 months ago #

    I hope you received it. The website gave me a wordpress question after submitting: "Si รจ davvero sicuri di voler far questo?"

  27. badbreze
    Member
    Plugin Author

    Posted 8 months ago #

    is "are you sure to do this" sorry mi site is in italian x)

    wait a minute i fix this and you cand send me data

  28. badbreze
    Member
    Plugin Author

    Posted 8 months ago #

    retry now

  29. berendvaneerde
    Member
    Posted 8 months ago #

    :) I know I translated already of course... The data is now send. To help you maybe:
    My host asks if there is a loopback connection made. Is this the case in the script and is there a way around it?

  30. badbreze
    Member
    Plugin Author

    Posted 8 months ago #

    mark as solved

Reply »

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.