WordPress.org

Ready to get started?Download WordPress

Forums

Images Don't Show Up After Host Move (15 posts)

  1. lukerichardson09
    Member
    Posted 2 years ago #

    I've just moved my website - http://www.cumbrian-properties.co.uk/

    From host to host and for some reason, most of the images no longer show...

    Anyone know how I can fix this?

  2. peter achutha
    Member
    Posted 2 years ago #

    I get a timeout error trying to view your site. Cannot view your site. Is it down?

    1. How did you move your site? Where are your images located - which sub-directory? or are they featured images in /upload/ directory?

    2. What is the setting in Settings >> General for fields WordPress Address (URL) & Site Address (URL)

    3. Is the URL the same as in the previous host?

  3. lukerichardson09
    Member
    Posted 2 years ago #

    Temp links is http://79.170.40.46/cumbrian-properties.co.uk/?page_id=2425

    1) I moved it file by file, like for like. Images are in wp-content/uploads

    2) /postname

    3) Yes, I've set up the whole site the same. It's just the images that won't show : /

  4. rabs
    Member
    Posted 2 years ago #

    check if image url in the post are right

  5. rabs
    Member
    Posted 2 years ago #

    check if image url in the post are right

  6. lukerichardson09
    Member
    Posted 2 years ago #

    they are : (

  7. hauntingreview
    Member
    Posted 2 years ago #

  8. s_ha_dum
    Member
    Posted 2 years ago #

    Some of them, the ones that don't work,...

    http://79.170.40.46/cumbrian-properties.co.uk/wp-content/uploads/2012/02/warrenbankG-220x220.jpg

    http://79.170.40.46/cumbrian-properties.co.uk/wp-content/uploads/2012/03/Lingmoor_front_of_house.jpg

    are triggering 403 errors (Forbidden)

    The ones that do work ( http://79.170.40.46/cumbrian-properties.co.uk/wp-content/themes/simon-wp-framework/images/sale-agreed.png ) do not trigger that error.

    Are you sure the images actually exist on the server? Perhaps your file transfer from the other server was incomplete?

  9. peter achutha
    Member
    Posted 2 years ago #

    I had a look at your site. It is no more at the temp address but moved to your original URL. But your pictures are from different locations:

    1. http://www.cumbrian-properties.co.uk/wp-content/uploads/2011/12/london-marathon-thank-you-300x128.jpg
    2. http://tv180.net/cprop/wp-content/uploads/2012/02/Cottage-Holiday-Group3.png
    3. http://79.170.40.46/cumbrian-properties.co.uk/wp-content/uploads/2012/06/featured.png

    It appears that your images are loading from three different sites: http://www.cumbrian-properties.co.uk, tv180.net and 79.170.40.46 and you may have to 'correct' them.

    I did notice that you said that your site url and WP url is set to /postname. Do check this out. If your site was installed in the root directory that SITE URL and WP Address URL both should be http://www.cumbrian-properties.co.uk/.

    You could have done it this way:-
    1. saved SITE URL and WP Address URL in old host as http://www.cumbrian-properties.co.uk/. Then exported the database (uncompressed) using phpmyadmin.
    2. Install a fresh copy of WP in the new host
    3. Copy /uploads folder to new host
    4. Import database to new host by using phpmyadmin.
    5. Installed themes and plugins.

    Does this help?

  10. lukerichardson09
    Member
    Posted 2 years ago #

    Peter,

    Is there any way to change the URLS in phpmyadmin?

    The site is very big and took a long time to transfer. As the URL's are wrong, it would be helpful if I could make a change to the database to alter the URL's

  11. s_ha_dum
    Member
    Posted 2 years ago #

  12. lukerichardson09
    Member
    Posted 2 years ago #

    I'll take a look at this... the domain hasn't changed. So I'm hoping this can deal with the minor issue of the ip as a domain and the added reference to the domain above

  13. peter achutha
    Member
    Posted 2 years ago #

    Hi lukerichardson09, I think the plugin @s_ha_dum (was apljdi) suggested is your best bet. Especially if your post has many direct links to pictures as they won't be stored separately in the database.

  14. gpmarkerswp
    Member
    Posted 1 year ago #

    I did a search on google for this but the things i found didn't really help me. my website is at http://gpmarkers running wordpress 3.5.1 reflection theme with the Mantra. If i am on my own network i can view my page and pictures just fine. but when i connected to my neighbors network and tried to view it the page loads but not the images, i also had one of my friends that lives in Illinois try to view it and she got the same thing. was hoping that someone could help me... if you need any more information or find anything out please let me know.

  15. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Looks like the file path to your images is wrong - here's one:

    http://localhost/gpmarkers/wp-content/uploads/2013/04/026Roadway-Road-Signs-Set-1-150x150.jpg

    You probably need to use the Velvet Blues plugin suggested above to change the URLs on your site. Make a complete backup of your site before doing so. But if you need further help, please start your own thread per the forum rules - this thread is quite outdated.

Topic Closed

This topic has been closed to new replies.

About this Topic