WordPress.org

Ready to get started?Download WordPress

Forums

Images don't load and "You don't have permission to acess" (6 posts)

  1. wikkew
    Member
    Posted 2 years ago #

    Hello!
    I got a multisite up and running but I got a few problems.
    I created a wordpress site on localhost. (guess it helps to know this)

    The problem is that when i upload a new image (or any of the old ones) they doesn't show up. When i click edit image they do, but not in any post or similar.

    I edited .htaccess in the right way.
    When I turn off multisite in wp-config.php the site works perfectly.all images is shown and my gallery works. But I can't login or access wp-admin. I get a message that i don't have permission.(tried log out and login but when i log in i get the same permission error)

    I tried delete and deactivate all plugins and themes but it doesn't help.

    So how can I get the site to work without loosing access to my dashboard?

  2. wikkew
    Member
    Posted 2 years ago #

    UPDATE#1
    in my-sites.php i found this:

    require_once( './admin.php' );

    if ( !is_multisite() )
    wp_die( __( 'Multisite support is not enabled.' ) );

    if ( ! current_user_can('read') )
    wp_die( __( 'You do not have sufficient permissions to view this page.' ) );

    can I change it in some way? or in admin.php? Then I could turn multisites off and still be able to access my dashboard or admin pages?

  3. Don't edit that file. You will be crying later.

    Per the other thread, ask your webhost if allowoverride is set to all in the httpd.conf file.

  4. wikkew
    Member
    Posted 2 years ago #

    I do that now. Thank you very much!

  5. wikkew
    Member
    Posted 2 years ago #

    They told me they didn't allow allowoverride all on their servers.
    Is there any other way or do I have to change company?

  6. Ask them if they support WordPress Multisite at all?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.