WordPress.org

Ready to get started?Download WordPress

Forums

Images Don't Automatically Go Into Gallery? (30 posts)

  1. sunoftheskye
    Member
    Posted 5 years ago #

    It used to be that when I uploaded images while making a new post, they automatically got added to that post's gallery. So I could upload them, insert the gallery, and I'm done.

    Ever since upgrading, the gallery is no longer automatically made, and after uploading the pictures, I then have to go the media library and insert each picture into the post, which creates the gallery, and then delete all those images and then insert the gallery.

    Is anyone else experiencing this problem?

  2. sybold
    Member
    Posted 5 years ago #

    yep sort of, except for the part when you place each picture into the post,
    the gallery page which should be made automatically loads but doesn't contain any pictures. kinda weird hope there is a fix for it

    here some screenshots
    screen 1
    screen 2
    screen 3
    screen 4
    images were uploaded with the flash uploader, that went ok

  3. esmi
    Forum Moderator
    Posted 5 years ago #

    Have you tried deactivating all plugins and checking to see if this resolves the problem?

  4. sybold
    Member
    Posted 5 years ago #

    don't even have a single plugin installed yet, i made a test on a subdomain to see if any problems would occur. and it does.

  5. esmi
    Forum Moderator
    Posted 5 years ago #

    When you say you ran a test on a subdomain, was that using a fresh 2.8 install with the default theme?

  6. sybold
    Member
    Posted 5 years ago #

    fresh install, custom theme which is still in development but already has the basics for the gallery included to work. on wordpress 2.7 it worked.

  7. Kevin
    Member
    Posted 5 years ago #

    I'm seeing the same problem with one of my 2.8 installs. Have tried disabling all plugins, deleting all WordPress files and reinstalling - nothing works. Had the gallery tab appear on one post but now I can't get it to appear again on a new post.

  8. esmi
    Forum Moderator
    Posted 5 years ago #

    @sybold: can you switch to the default theme on that sub-domain. Just to rule out any theme issue.

    @kpont: Are you using Firefox with Google Gears, by any chance?

  9. sybold
    Member
    Posted 5 years ago #

    sure no problem.

    done that, and the problem is still there, so it's not theme related.

    i think it goes wrong at the point when the uploading is done and it needs to assign a post or page for the images.

  10. esmi
    Forum Moderator
    Posted 5 years ago #

    Agreed. I'm still trying to get my head around the various db tables but I think the Gallery relies upon entries being stored in wp_term_taxonomy and wp_term_relationships at the upload point. If something is stopping those records being created, it would account for the effect you're seeing.

    Long shot - is there anything unusual being run on the server? Some versions of Hyperdb are known to cause problems with post tag storage in WP 2.8, for example.

  11. Kevin
    Member
    Posted 5 years ago #

    @esmi Firefox yes - but I've also tried with Safari with the same results - and no I'm not using Google Gears

    Has anyone had this problem when uploading images before saving the post. I've discovered that if I name and save the post before uploading I'm getting the gallery but if I upload images to a new post before saving I'm not.

  12. esmi
    Forum Moderator
    Posted 5 years ago #

    Has anyone had this problem when uploading images before saving the post

    Just ran a test on my dev blog and confirmed the issue. If an image is uploaded before a new post is saved, no gallery is created. This is despite that fact that the unsaved post shows a clear - and correct - permalink before any "Save".

    I'll post something in Feedback and see if I can add it to trac as a possible bug.

    In the meantime, the only workaround appears to be to save any new post before uploading images.

  13. marc06
    Member
    Posted 5 years ago #

    See also
    http://wordpress.org/support/topic/280366
    check if upload path exists and if image attributes in WP library have the correct path ...

  14. esmi
    Forum Moderator
    Posted 5 years ago #

    On my local copy, the upload folder exists, so that shouldn't be a problem.

    and if image attributes in WP library have the correct path

    Not sure I'm following you but the image I uploaded was stored in the Media Library without any problem and could be inserted into any post without a hitch.

    File paths match pre-2.8 image uploads that successfully populated a post-specific gallery:

    http://domain/wordpress/wp-content/uploads/2009/06/sunflower.jpg
    http://domain/wordpress/wp-content/uploads/2009/01/gallery4.jpg

    Timestamps all appear to be correct.

  15. ejcamp
    Member
    Posted 5 years ago #

    You can upload images into the media gallery but you can't upload into the custom media field. I've spent the last couple of days unsuccessfully trying to resolve this. Has anyone had any luck yet? Seems the developers are sitting out this one too long!

  16. kkreichert
    Member
    Posted 5 years ago #

    I too have this issue from an upgraded 2.7.1 to 2.8 install, although mine seems worse as I tried even saving the post as draft then adding the image and it still does not create the gallery.

    Tried in default theme and turned all plugins off, same result.

    My theme is very dependent on timthumb grabbing an image from the post gallery and thumbing it for the main page... now I'm becoming imageless. The only one's left are those posts created with 2.7.1...

    Dev help would definitely be appreciated!

    Cheers!

  17. kkreichert
    Member
    Posted 5 years ago #

    ...after yet more 'playing' it seems in 2.8.1 Beta2 you can only have an image attached to a single post. I was successful inserting an image from the media library into a test post, this image not tagged to any other post. Publish the post and there's a gallery for the test post. However inserting an image from the media library that is already tagged to another post continues to not generate a post gallery.

    I have a multitude of pre-2.8 posts where images are used in multiple posts without incident.

    Anyone else having this issue...?

    Cheers!

  18. jamesb4551
    Member
    Posted 5 years ago #

    Yep this is stupid, something that seems to have worked forever now doesn't at all after installing 2.8.1 beta 1, no gallery is coming up for any posts, what the...?

  19. jamesb4551
    Member
    Posted 5 years ago #

    I did get it to finally work with the saving a draft method, then going back to the media library and inserting them one by one into the post to finally get a gallery, but how annoying is this, any ideas on a bug fix anyone?

  20. ricardobeat
    Member
    Posted 5 years ago #

    How come 2.8.1 was released without fixing this?? This is serious functionality crippling.

  21. ianatkins
    Member
    Posted 4 years ago #

    I also have this problem intermittently.

    Running wordpress 2.8 windows hosting.

    Has this been listed as a bug / any news?

  22. jamesb4551
    Member
    Posted 4 years ago #

    Did they not fic this in 2.8.1!?!?!?! what the? Everyone's been bangin' on about it how can the miss it? I'm on 2.8.1 beta, but what's the point in upgrading if they don't even fix things like this?

  23. gabi.huiber
    Member
    Posted 4 years ago #

    I ran into this yesterday and googled it. There are several forum threads where people complain that images either can't be upload, or don't go to the right places since WordPress 2.8. I'm not sure if this post will close this issue everywhere, but here goes:

    I upgraded to 2.8.1. That didn't fix the problem but at least it was one less thing off the list. I wasn't going to deactivate plugins because (1) I don't have that many and (2) it didn't sound like most other people had any luck with that.

    What I did was this:

    - go to Settings
    - go to Miscellaneous
    - change the path in the box next to "Store uploads in this folder" to the default: "wp-content/uploads" and nothing else.
    - change the permissions of that folder to 777
    - return to the edit screen; proceed with "add image" as usual
    - change the permissions of wp-content/uploads back to 755

    That worked fine. The picture showed up in the post and in the media library as usual. The problem had been that the "Store uploads in this folder" path on record was a complete path leading to a C:\ drive as if for a local Windows installation of WordPress (not my case).

    I hope this helps.

    Gabi

  24. crabby cliff
    Member
    Posted 4 years ago #

    I'm having same problem, i.e. uploading photos does not create a gallery.
    It seems to be an intermittent problem.
    One think I tried (on recommendation regarding earlier WP versions)
    empty browser cache
    otherwise, this is a nuisance bug.

  25. 3Dog
    Member
    Posted 4 years ago #

    You can find an explanation and fix for this bug here:

    http://www.3dogmedia.com/new-post-ghost-bug/

  26. 3Dog
    Member
    Posted 4 years ago #

    and here is the trac ticket

    http://core.trac.wordpress.org/ticket/9471

  27. ezada
    Member
    Posted 4 years ago #

    You have to save in draft the new page before uploading pictures. After you save it, everything goes in gallery.

  28. alroger
    Member
    Posted 4 years ago #

    Tried saving in the draft and samething.
    For me the solution was to, at the end of the uploads page (using flash), click the Save All button.... then the gallery tab came alive!

  29. anthonylrivera
    Member
    Posted 4 years ago #

    I was experiencing this same issue with my custom theme.
    After troubleshooting, I narrowed it down to functions.php,
    and for some reason if I prematurely closed the main php open tag '?>'
    and reopened it, '<?php' to include more functions, this is what seemed to be causing the problem.

  30. ianatkins
    Member
    Posted 4 years ago #

    You have to save in draft the new page before uploading pictures. After you save it, everything goes in gallery.

    This is the solution.

Topic Closed

This topic has been closed to new replies.

About this Topic