WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Images Broken In MPMU (3 posts)

  1. coreymj78
    Member
    Posted 2 years ago #

    The issue is immediate broken images upon upload to the usual media gallery (or even the set featured image area). I am on a WordPress Multisite Network installed manually. Everything else has worked fine.

    I thought I would start a new thread since the subject of this first one has evolved into a separate issue. I found in my WP Multisite install where to change the upload directory information (Network Admin > All Sites > Edit > Settings Tab) via and Upload URL Path. The Upload Path has this in it:

    wp-content/blogs.dir/2/files

    But the Upload URL Path is blank.

    But I'm not sure if this is where the problem is or not.

    The OP in this thread and this thread had the same issue and found the solution to be some hacking of the httpd.conf and .htaccess files. But they were told that the solution to this particular issue may vary from server to server, so I have no idea if I should use this solution or not and quite frankly feel a bit uncomfortable tinkering with the code in these files since for one, I don't know where they are and two, not sure exactly how I should change it. If anyone can help me, I'd be greatly appreciative. Here are some of my specs:

    WordPress Version: 3.2.1
    PHP Version: 5.2.17
    MySQL Version: 5.0.92-community-log
    Web Server Info: Apache / http://www.WebHostingHub.com / cPanel
    Browser Info: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.2.23) Gecko/20110920 Firefox/3.6.23
    PHP cURL Support: Yes
    PHP GD Support: Yes
    PHP Memory Limit: 256M
    PHP Post Max Size: 128M

  2. coreymj78
    Member
    Posted 2 years ago #

    Nevermind, I figured out how to edit my .htaccess file and everything is working.

  3. coreymj78
    Member
    Posted 2 years ago #

    I solved this issue, but for other's benefit I will describe how I got it working (as I would like other to do for me):

    My problem (and this may not be yours if you set up your Multisite correctly) was that I had skipped a step in setting up my Multisite. On the http://yourdomain.com/wp-admin/network/setup.php page in the 3rd step you will see a code box with this in it:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    Or at least something similar. Make sure you copy/paste this code into your .htaccess file located in the root of your server (normally your public_html folder). If you can't open or edit your .htaccess file, rename it to something like .htaccess2 then try. If you still can't, go into your cPanel on your server and edit / download it that way. This fixed my issue for me and everything is uploading fine.

    Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic