WordPress.org

Ready to get started?Download WordPress

Forums

Images aren't appearing in RSS feed (17 posts)

  1. jessn
    Member
    Posted 6 years ago #

    The images of my posts aren't showing up in my feed and I'm having the darndest time figuring out why. And since my posts are pretty much only images it's a big problem for me. I'm using absolute urls for the images and I have full text enabled for syndication feeds. Anyone have any idea what the problem could be?

    My feed is http://cssdivine.com/?feed=rss2

    Thank you!

  2. iridiax
    Member
    Posted 6 years ago #

    You are using feedburner for your feed instead of the default WordPress feed setup, so I'm guessing that the problem is with your feedburner setup.

    Also, if you have hotlink protection enabled, your images will not show in feed readers. Feeds with nice images will attract hordes of feed scrapers, and I ended up having to use hotlink protection and partial feeds because of these parasites.

  3. jessn
    Member
    Posted 6 years ago #

    Thanks for the reply! Yeah I'm not sure if the issue is with WordPress or Feedburner. Should I disable my feedsmith plugin for feedburner and then check my feed? Also how to I find out if I have hotlink protection enabled?

  4. iridiax
    Member
    Posted 6 years ago #

    Disable the feedburner plugin to see if the problem goes away. If it does, then it's a problem with either the plugin's settings or with feedburner's. If you haven't enabled hotlink protection yourself, then it's most likely not enabled since it's not a default.

  5. jessn
    Member
    Posted 6 years ago #

    Hmmm no that didn't do it for me. The only thing I can think of is I'm putting the images inside the "custom fields" section when I post. Perhaps that's keeping them from showing up in the feed?

  6. iridiax
    Member
    Posted 6 years ago #

    I don't know how feeds deal with things in custom fields, but that is likely the source of your problem.

  7. jessn
    Member
    Posted 6 years ago #

    Thanks iridiax! Yeah further research suggests WordPress doesn't automatically insert images from custom fields into RSS feeds. There are a couple different plugins that look promising and I'm going to try out. I'll post the fix if I figure it out.

  8. jessn
    Member
    Posted 6 years ago #

    Ok here are the plugins that I found in case it helps anyone:
    http://wordpress.org/support/topic/63420?replies=12#post-356315
    http://justintadlock.com/archives/2008/01/27/custom-fields-for-feeds-wordpress-plugin

    I also tried inserting a second thumbnail inside my post content area, and still none of these things worked for me. Anyone have any other ideas? How can I check to see if I have hotlink protection enabled? It's the only other thing I can think of at the moment......

  9. jessn
    Member
    Posted 6 years ago #

    Sorry to keep writing to myself. I kind of hope this will help someone else. I logged into my cPanel and found out I did have hotlink protection enabled so I disabled it, but *sigh* nothing has changed. At least not for me. Could you let me know if you see any images in the following feed:

    http://feeds.feedburner.com/cssdivine/feed

    Thanks!

  10. iridiax
    Member
    Posted 6 years ago #

    Hotlink protection is found in your .htaccess file outside of the WordPress stuff.

  11. jessn
    Member
    Posted 6 years ago #

    I have no idea what this means. Do you think the problem is here? This is my .htaccess file:

    # -FrontPage-

    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName cssdivine.com
    AuthUserFile /../public_html/_vti_pvt/serv.pwd
    AuthGroupFile /../public_html/_vti_pvt/serv.grp

  12. iridiax
    Member
    Posted 6 years ago #

    None of that is hotlink protection, so it looks like that is gone.

    I'm only seeing excerpts in your feed, and these do not include images (only full content feeds show images).

  13. jessn
    Member
    Posted 6 years ago #

    All the post is is an image and a title, so only the title is showing up. I have it set to full content for the feed already.

  14. iridiax
    Member
    Posted 6 years ago #

    I see the following in your feed, which shows that it is an excerpt:

    [[ This is a content summary only. Visit my website for full links, other content, and more! ]]

  15. jessn
    Member
    Posted 6 years ago #

    Yeah that comes from feedburner, not my site

  16. rleap
    Member
    Posted 6 years ago #

    jessn

    When you login to feedburner and edit your feed details, what is your original feed link? I had the exact same problem as you and I finally figured out I was using the following link in error.

    http://www.twoguysnamedrob.com/feed/rss/

    I changed the link to this:

    http://www.twoguysnamedrob.com/feed/

    and that solved everything. My full feed showed up along with all pics.

  17. Seaborn
    Member
    Posted 5 years ago #

    I had the same problem. Realized my feed settings in WP were set to summary and not full text. Changed it, fixed the problem. Might work for some of you out there.

Topic Closed

This topic has been closed to new replies.

About this Topic