WordPress.org

Ready to get started?Download WordPress

Forums

Images are not showing up, just small icon (7 posts)

  1. thesporg
    Member
    Posted 3 years ago #

    My website was running great, my images were showing up and I had no problems at all. But just like two days ago my images on my front page stopped showing up. This small icon is shown where the images are supposed to be showing up. Also, if I click on another page, the images show up on that page. This problem is only affecting my front page. Any help to fix this problem would be greatly appreciated. Thank you.

  2. stvwlf
    Member
    Posted 3 years ago #

    Often people use relative file paths to images. These don't work consistently in a content management software like WordPress.

    Your image URL's should start at your website's root folder.

    paths like this "images/filename.jpg" or this "../images/filename.jpg" need to be replaced with full paths. If you can't resolve it, post the homepage URL for further help.

  3. thesporg
    Member
    Posted 3 years ago #

    http://www.thesporg.com

    I still can't resolve this problem.
    I don't know how to do what you are talking about on wordpress.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    How are you inserting your images?

  5. thesporg
    Member
    Posted 3 years ago #

    By using the insert image icon.

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    Do your images show up in your Media Library? What uploads path do you have in Settings -> Media?

  7. stvwlf
    Member
    Posted 3 years ago #

    Hi - Your theme is using a PHP program to create thumbnails on the fly. They are not being created.

    The image code for the home page's upper left corner is:
    <img class="postimage1" alt="That’s your wife?" src="http://thesporg.com/wp-content/themes/bignews/thumbs.php?src=http://thesporg.com/wp-content/uploads/2011/07/cameron_diaz-500x375.jpg&h=250&w=280&zc=1">

    The full sized image, http://thesporg.com/wp-content/uploads/2011/07/cameron_diaz-500x375.jpg, does exist. Because the image being reduced in size to a thumbnail by thumbs.php exists at the URL it is supposed to, this means either thumbs.php file is not found wher it's supposed to be at http://thesporg.com/wp-content/themes/bignews/thumbs.php - or if it is there, something about the way it is configured is not correct.

    I'd start by looking at the Big News theme options settings in the WordPress Dashboard. They would be found either under Appearance, or some themes install a menu section of their own. See what is offered for thumbnail configuration.

Topic Closed

This topic has been closed to new replies.

About this Topic