WordPress.org

Ready to get started?Download WordPress

Forums

WP Original Media Path
Images are giving 404 error. (26 posts)

  1. ananddesigner
    Member
    Posted 1 year ago #

    i have installed this plugin in my website.now my website images path has been changed.i can see my images in my new images path via ftp but in browser my images are giving me 404 error.please guide me.

    http://wordpress.org/extend/plugins/wp-original-media-path/

  2. RVOLA
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Ananddesigner,

    the easiest way to understand the error 404 is:
    - Define the domain or subdomain for images.
    - Verify that the domain or subdomain are active in the right place.
    - Define the exact location of the folder for uploads
    - Verify that the path is followed.

    To verify and understand the error, simply move the media library and watch the permalink of a picture.
    By analyzing this address, you normally find out what is wrong.

    You can also give me the link of your website in order to solve the problem together.

  3. ananddesigner
    Member
    Posted 1 year ago #

    sir,it is necessary? i am using folder for images it should be sub domain or domain rather than a simple folder.

  4. RVOLA
    Member
    Plugin Author

    Posted 1 year ago #

    Not the subdomain is not required.

    For example my website is http://siteweb.com

    By default the images folder of WordPress expected to be here:
    http://siteweb.com/wp-content/uploads

    I decided to rename my file uploads in 'my_images' directly to the root of the website, which gives:
    http://siteweb.com/my_images/

    With the plugin WP Original Media Path, you must fill out 1 field options:
    my_images
    and the second field:
    http://siteweb.com/my_images

    Be careful with slash unnecessary.

    Yet another example to understand:
    I want to rename the file uploads in 'media_thumb' and put it in my folder in my theme 'twentyten'

    The first field looks like this:
    wp-content/themes/twentyten/media_thumb
    the second looks like this:
    http://siteweb.com/wp-content/themes/twentyten/media_thumb

  5. ananddesigner
    Member
    Posted 1 year ago #

    i have changed my images path...
    http://mysite.com/library/
    but when i uploaded a images and check them in browser it is giving me 404 error..and when i checked in my ftp that images was there.

  6. RVOLA
    Member
    Plugin Author

    Posted 1 year ago #

    OK
    the first field settings page media must be:
    librairy

    and the second:
    http://mysite.com/librairy

    Normally it should work, to check if the same image is 404, the inspector look into the URL problem

  7. ananddesigner
    Member
    Posted 1 year ago #

    yes sir i am doing this..but it is not working..image path has been changed and image is also in my this folder..i can see this image..but it is not opening in browser..it is giving 404 error

  8. RVOLA
    Member
    Plugin Author

    Posted 1 year ago #

    it must necessarily have a problem with that slash behind.

    You have a sample URL?

  9. ananddesigner
    Member
    Posted 1 year ago #

    in first column : library
    in second column : http://mywebsite.org/library/

  10. RVOLA
    Member
    Plugin Author

    Posted 1 year ago #

    Do you put other conditions in the wp-config.php file that could taint the URL changes?

    Did you try to check the WP_DEBUG = true
    to understand the problem?

  11. ananddesigner
    Member
    Posted 1 year ago #

    sorry..i do not know about this..what is this..

  12. RVOLA
    Member
    Plugin Author

    Posted 1 year ago #

    some reading to identify problems servers;)
    http://codex.wordpress.org/Debugging_in_WordPress

  13. ananddesigner
    Member
    Posted 1 year ago #

    can you tell me.. i am feeling strange now my new image folder contain a new htaccess files..i dont know how is this file here and that htaccess file contain this text:

    Order deny,allow
    Deny from all
    <Files ~ "^[0-9A-Za-z]+\.(jpeg|gif|png)$">
    Allow from all
    </Files>

  14. RVOLA
    Member
    Plugin Author

    Posted 1 year ago #

    Ah!
    That's the problem ...

    try to rename the file. back.htaccess htaccess and verify a URLd'image

  15. ananddesigner
    Member
    Posted 1 year ago #

    ok now i am understand..i am using wpcf captcha..thats why..this file is here...

  16. RVOLA
    Member
    Plugin Author

    Posted 1 year ago #

    I do not know. Now it works?

  17. ananddesigner
    Member
    Posted 1 year ago #

    no images is not working..this file is here beacuse of wpcf7 captcha

  18. RVOLA
    Member
    Plugin Author

    Posted 1 year ago #

    Ok so the problem is not on my side. Try disabling the plugin and / or find an alternative http://wordpress.org/extend/plugins/really-simple-captcha/

  19. ananddesigner
    Member
    Posted 1 year ago #

    yes sir i am using this plugin..but i have deactivated it but our problem is still here...

  20. RVOLA
    Member
    Plugin Author

    Posted 1 year ago #

    I understand trying to delete the file and htacces captcha plugin deactivated.

  21. ananddesigner
    Member
    Posted 1 year ago #

    yes i have do this.

  22. RVOLA
    Member
    Plugin Author

    Posted 1 year ago #

    I do not really understand what is happening.

    Original WP plugin media path does not change the folder structure, it does not add htaccess file.

    It only makes visible the hidden fields WordPress.

    You should find the error by looking at the URL of the images and analyzing the debug provided by WordPress.

  23. ananddesigner
    Member
    Posted 1 year ago #

    okay sir i will try..thank you

  24. RVOLA
    Member
    Plugin Author

    Posted 1 year ago #

    sincerely sorry. This plugin is simple, just get a good recognized trade directory servers with absolute and relative.

    Good luck for the future

  25. ananddesigner
    Member
    Posted 1 year ago #

    i will check this and tell you after.thanks

  26. abinashm
    Member
    Posted 1 year ago #

    Please ignore the bad formatting which was posted by me earlier. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.