WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Images Appear - No Upload Folder (4 posts)

  1. mawdizzle
    Member
    Posted 3 years ago #

    I recently got hacked. I took my whole site down and got to try my backup procedures from scratch. Yay! I finally got to prove myself worthy of the junk I talked about backing up your files.

    I reinstalled a fresh copy of wordpress 3.1.2. I copied in my most recent db backup and modified my wp-config.php file. I got my site working again and I was very happy.

    One thing that puzzles me though and this is more out of intellectual curiosity... All my images are displaying on my blog. You would think, yeah, this is great. This is what you'd want.

    BUT!!! I haven't copied my upload folder over from my backup! How the hell is wordpress retrieving my images to show them? I click on view source and the HTML shows the path to my upload folder, but I don't have an upload folder yet because I haven't copied it over.

    Is wordpress magic? How is this happening? If anyone can enlighten me, I sure would appreciate it as it would satiate my intellectual curiosity.

    site is http://www.mawdizzle.com

    PS- Hack was through FTP not wordpress. So good for you wordpress. I use SFTP now in order to close one more security loophole. I suggest you use SFTP too. It's a little pain to setup, but it's free through GodDaddy - all you have to do is ask. FTP is new the way hackers are gonna gitcha if you don't watch out. SFTP is no longer an option as much as it is a requirement.

  2. Curtiss Grymala
    Member
    Posted 3 years ago #

    I suspect you might be seeing cached copies of your images, as I am just seeing indicators that the images couldn't be found.

  3. esmi
    Forum Moderator
    Posted 3 years ago #

    No images here either.

  4. mawdizzle
    Member
    Posted 3 years ago #

    I suppose I should have suspected that. I didn't even think of it because I've been so hopped up and fired up about getting my site back online that I didn't even take a minute to think.

    Thank you so much for the quick response. I cleared my cache and they disappeared. Makes sense.

    I guess there's no such thing as magic.

    This topic is closed - thanks again.

Topic Closed

This topic has been closed to new replies.

About this Topic