WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Images All In One Column (76 posts)

  1. cwp2013
    Member
    Posted 11 months ago #

    I have been using nextgen for years. This latest update has made it virtually useless for me. Sure there's lots of encouragement to upgrade to "pro", but I cannot even get the free version to work. When adding a gallery to page, (which used to be a simple as two clicks) all of my images are in one column. I have tried to adjust number of columns. Nothing works. Anyone know what I might be doing wrong? Nextgen was one of the most useful and popular plugins available for wordpress. What happened?

    http://wordpress.org/plugins/nextgen-gallery/

  2. luke1978
    Member
    Posted 11 months ago #

    same problem here :-(

  3. ogu007
    Member
    Posted 11 months ago #

    Same thing here!

  4. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    Hey Everyone,

    We just released v2.0.7 update, please give that a try if you haven't already to see if that clears that error. If not, would you mind temporarily deactivating all plugins (including NextGEN Gallery) and reactivate NextGEN Gallery only? Clear your browser cache and reload your site. If that works, reactivate each of your other plugins one at a time to see if the error comes back.

    Hope that helps!
    -Becky

  5. ogu007
    Member
    Posted 11 months ago #

    Hi!

    It was working fine for with v2.0, but now with 2.0.7, images are displaying in one column. I did what you mentionned in your last post, and it's still in one column.

    Also, all the options in the backend are displaying pretty strangely. Not like in v2.0.

    Thanks for your help!

  6. Gavomatic57
    Member
    Posted 11 months ago #

    Same here! Phew, not just me.

    Is anyone else finding single images ignoring the "float" left or right? Has left-aligned images in posts too.

  7. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    Hi all - I'd like to ask you to try one more thing. If you could please go to Gallery > Other Options > Miscellaneous and click to clear your image cache and let us know if that resolves it. In most cases where we've seen this it's been a caching issue of some kind.

    If you've cleared image cache like that, and you've cleared browser cache, and you are running NextGEN 2.0.7 and still having the issue, you can send a bug report with your WordPress and FTP login credentials if you like and we'll troubleshoot it directly.

    http://www.nextgen-gallery.com/report-bug/

    That will just send an email directly to our tech support and developers.

  8. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    One more thought here. If you have a caching plugin installed that might cause this as well. Try deactivating and reactivating the caching plugin. Thanks.

  9. cwp2013
    Member
    Posted 11 months ago #

    I took your advice, updated to the "newest" new version (still willing to give this a chance) and boom..My entire theme was broken. Luckily I am using on a test site. I deactivated nextgen and my website returned to normal. By the way, this test site is a fresh install with no other plugins installed besides Nextgen. I understand, trying to capitalize on one of the most popular plugins ever for WordPress, but you should have just left it ALONE. It was an awesome plugin. I would have paid for an upgrade of that. But not this.

  10. identity1998
    Member
    Posted 11 months ago #

    I had to completely remove the WP Super Cache plugin, then everything worked. Images are displaying properly now.

  11. neotsunami
    Member
    Posted 11 months ago #

    I did all of this and it still didn't fix it. The problem here with mine is a bit different. It doesn't put them all in one column. What it's doing is, regardless of what number of columns I put in, it ALWAYS puts the last one below the row it should belong to.

    Let me explain. I choose 5 columns and the images should show up like this:

    X X X X X

    but they show up like this:

    X X X X
    X

    Now, I thought they were just not fitting, but if I put 4 columns it goes to this:

    X X X
    X

    And if I choose 3 columns it shows this:

    X X
    X

    Also, for some reason if there are more than one pages to a gallery, once I jump to any other page, it doesn't show the images, it shows the following text:

    Default Gallery Type Template

    This is the default gallery type template, located in:
    /home/ixnetwork/hitoken.net/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_gallery_display/templates/index.php.

    If you're seeing this, it's because the gallery type you selected has not provided a template of it's own.

    Which I have no idea what the hell it means :\

    HELP

  12. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    @neotsunami: What happens if you don't enter a number of columns and just let them wrap normally? Also, are you adding - via NextGEN options, via custom css, or via your theme - anything like extra borders or padding around your thumbnails that would cause them take up more space and wrap to the next line?

    Also you said "more than one pages to a gallery, once I jump to any other page, it doesn't show the images, it shows the following text" - I'm not quite sure what you mean by jump to the next page?

    For both of the above: can you provide a link so we can see what's happening?

    -
    @identity1998: Thanks for the update. I'm glad that worked and it does sound like it was a caching issue. You should be able to reactivate WP Supercache and it will be fine now. I suspect some of the code before the update was getting cached, now that it's reset, that old code should be gone.

    -
    @cwp2013: NextGEN has always been a great plugin, but this was its first major overhaul since it was created in 2007. That's a long time and NG, while performing some basic functions quite well, was getting dated. I do apologize that the transition isn't going smooth for you - I honestly feel the pain there - but I suspect once the current issues are ironed out, the vast majority of users, perhaps yourself included, will consider the rework to be a dramatic improvement over NextGEN Legacy.

    In any case, for now if you'd like to roll back to 2.0.0 or 1.9.13, you can do so. You just need to download the old files (http://wordpress.org/plugins/nextgen-gallery/developers/), unzip them on your computer, connect to your site via FTP, and copy up the old files to your nextgen-gallery folder. Here are more details about how to do it:

    http://www.nextgen-gallery.com/how-to-rollback-a-version/

  13. cwp2013
    Member
    Posted 11 months ago #

    You seem to genuinely want to help. Even with all of the complaints, you seem to be keeping your composure, so kudos for that. I know how to get the previous version up and running. My concern is not being able to use the plugin in the future. It has been great and easy to use for myself and clients. It's not anymore. I know that nextgen hadn't had an "overhaul", but it didn't need one. It was a great plugin, just the way it was. That is why it became so popular. I'm sure it's popularity is what attracted you to it. On the plugin page, it says something like "One of the most popular plugins ever. Over 7.5 million downloads" That is a bit misleading with this overhaul. It was the previous version of this plugin that was downloaded 7.5 million times. This is not the same plugin.

    It doesn't make sense to me. It would be like buying the Chick Fil A company and then immediately starting to sell fish sandwiches instead. Wasn't it the chicken that made them famous? Would you buy the Coca Cola company and immediately change the recipe to something you think might be better? You cant change what works and expect to succeed.

    You should have left the plugin alone, added a nag that showed your version and used it as the upgrade. That is my opinion. You would have done better in the long run. However, I wish you luck with the plugin and thanks for taking the time to try to help.

  14. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    @neotsunami: Just FYI, I think I've duplicated your issue with the one thumbnail wrapping to the next line. I'm wondering if we've adjust something so the math on the column sizes isn't quite right and so the last one doesn't have space and is wrapping. I've confirmed it's happening across themes.

    I'm creating an issue for the developers to look at this. For now, you may want to just use columns = 0 and let them wrap naturally.

  15. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    @neotsunami: Actually just finding that this only occurs for us if you are using the Caption Template. Is it possible that you are using the caption template? If so, can you try removing the caption template and let me know if it works correctly?

    If so, then it's just an issue we'll need to resolve for the caption template.

    Thanks.

  16. malmilligan
    Member
    Posted 11 months ago #

    This upgrade has left me with single column thumbnail displays on a number of production websites. I disabled all plugins, cleared browser cache, restarted the NextGen plugin, cleared the NextGen image cache, and I still have single column thumbnail displays. In addition to that, when I click on a thumbnail, the old familiar display is now very different... with the arrows missing and previous functionality completely gone. I'll downgrade every site I mistakenly upgraded and I hope you fix all these issues. It seems like the release was rushed and there was inadequate testing.

  17. johanna2patricia
    Member
    Posted 11 months ago #

    I have the images in a single column too.
    At my site it has to do with the cooperation between Nextgen and the W3 Total Cache plugin. When I deactivate that one all is good.
    When I activate it again, again the single column images.
    Cleared the cache and also of the browsers, but no luck.
    I really want to use the W3 Total Cache plugin, so I hope the developers find a solution to this.

    Johanna

  18. ogu007
    Member
    Posted 11 months ago #

    Hi,
    I had the same problem after the update of v2.07. After analyzing everything, I discovered I had a code in my wp-config.php file that create that bug (it was a line of code that I added for caching). I remove the code and everything works fine!
    Hope it helps someone!

  19. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    Based on the few people who've resolved this with caching plugins, I'd still guess that most people having this are having a caching issue. But it's troubling that it comes back after @johanna2patricia reactivate W3 Total Cache.

    @johanna, or anyone who can't clear this problem by clearing cache, I'll again reiterate that if you submit a bug report with login credentials, we'll have our developers look at this and see what else may be happening.

    http://www.nextgen-gallery.com/report-bug/

  20. johanna2patricia
    Member
    Posted 11 months ago #

    Hi Photocrati,
    I already did submit a bug report with my login details hours ago. But will this be looked into even if you dont have the Nextgen pro version?
    In the meantime I rolled back to the 1.9 version of Nextgen. I dont want my site to have those single columns images. With the 1. 9 version and the Slimbox Colorbox plugin Nextgen works well and also the W3 Total Cache plugin.
    It must be possible for your developers to reproduce this kind of behavior.

    Johanna

  21. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    Hi Johanna: I see your bug report and was just going in to take a look, but it appears you've rolled back, so we'll leave that for now.

    For you and others with this issue: This does seem to be something triggered by caching plugins. Unfortunately deactivating them is not enough. I think they add lines to your wp-config file which linger after deactivation. I just solved this for one user by deactivating WP Supercache and commenting out those lines by adding // to the start of both of them.

    @ogu007 found something similar.

    One person here, and one via support ticket have sovled it be deactivating and deleting/removing the caching plugins, which may also remove those lines.

    -
    So it seems that there's something going on with how caching plugins are caching code/styles before and after the update that's triggering the loss of styling.

    One thing I'm still trying to diagnose is if, once you resolve the problems, you can reactivate the plugins without having issues. I'll be testing that shortly and will update here.

    -
    Beyond that, we'll look into this to see if there's anything we can do about it on our side in the next update. But in the short term, it appears you'd either need to deactivate/comment out/remove your caching plugins.

  22. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    Since I know many people are using caching plugins and may experiencing this issue, I'm sticking it to the top of support forum for now.

  23. johanna2patricia
    Member
    Posted 11 months ago #

    Hi Photocrati,
    Yes I think that is right, that the cache plugins put lines in the wp-config file.
    But I dont want to deactivate the W3 Total Cache plugin.
    As you say a lot of people are using cache plugins, so I hope you and your developers find a solution for this.
    The weird thing is, that 2 of my 4 blogs work well with Nextgen version 2.0 and W3Total Cache. The other 2 work now with Nextgen version 1.9, slimbox colorbox and W3 Total Cache. But I couldnot get Nextgen version 2.0, 7 to work on any of them.

    I hope you get to the bottom of this soon.
    Good luck!

    Johanna

  24. edanzer
    Member
    Posted 11 months ago #

    @cwp2013: Thanks for the feedback and tone of your response. I recognize there's some risk with moving it in a different direction. I guess time will tell if we made the wrong decision.

    I do suspect that within a version or two, we'll have the kinks worked out, and I'd be interested to see if you still feel similarly if you have a chance to work with the new version without being inhibited by the various bugs we're seeing now.

    Regardless, I appreciate the feedback.

  25. edanzer
    Member
    Posted 11 months ago #

    @neotsunami: If you happen to be back in here, I'm still wondering if you can tell me if you are using a caption or other template, or just a plain thumbnail gallery with columns?

  26. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    By the way @cwp2013, that @edanzer is me too. Just realized I responded above with my personal account, but I'm usually responding via the Photocrati account on the forums (Erick).

  27. AndersPH
    Member
    Posted 11 months ago #

    All my galleries, Next Gen och New Photocrati gallery, doesnt work any more. I have empty cash and it helped some but not all. I cant add any images or create new gallery. I hope you fix this soon. Great support page and feedback.

  28. johanna2patricia
    Member
    Posted 11 months ago #

    Hi Photocrati,
    I agree with cwp2013. I don't understand why you changed the interface. It was really clear and simple. The new one is more difficult to understand.
    What bothers me the most is the fact that when you upload images you can't see the option to resize or not. In the previous Nextgen that was visible. You could tick the box or not.
    Having said that, I hope you all can get the bugs out of it.
    Else why not rool back to the 1.9 version and work form there?

    Johanna

  29. DreamnetRob
    Member
    Posted 11 months ago #

    Thanks for this post and thanks to @Photocrati for all his replies.

    I was having the exact same problem ... i.e. all images in column, no formatting and no scrolling through images.

    I disabled WP Super Cache ... commented out the WP Super Cache line of code from wp-config.php and it fixed my problem.

    @Photocrati ... so how do we move forward. Obviously on a photo intense site WP Super Cache is important.

  30. DreamnetRob
    Member
    Posted 11 months ago #

    @Photocrati

    Oh ... also wanted to add. This problem did not happen on 2.0.0 and 3.6 ... only showed up in 2.0.7

Reply »

You must log in to post.

About this Plugin

About this Topic