WordPress.org

Ready to get started?Download WordPress

Forums

image.jpg has failed to upload due to an error Missing a temporary folder. (8 posts)

  1. robobobo100
    Member
    Posted 3 years ago #

    Hey guys,

    I know you've probably seen the error code a lot now

    image.jpg has failed to upload due to an error
    Missing a temporary folder.

    I've tried all I can to fix it, tried all the permission tricks and the folder is correctly defined in the wordpress settings-media

    A clean install doesn't do it either

    I've read that it could be to do with the .htaccess file or php.ini but i've no idea how to sort that out

    The sites http://www.cowicklowltc.com

    Any help would be much appreciated
    Thanks

  2. Tiffany_R
    Member
    Posted 3 years ago #

    I'm having the exact same issue. Any help would be appreciated.

  3. transom
    Member
    Posted 3 years ago #

    A missing temporary folder is a hosting issue. This isn't something you can likely fix (securely) via WordPress.

  4. Tiffany_R
    Member
    Posted 3 years ago #

    For the record, I'm pretty sure that this is NOT a WordPress problem. I believe that this is an issue with the webhost not allowing the root /tmp directory to have permissions above 755. I was told by the web host I'm working with at the moment that they don't allow customers to CHMOD that directory "for security reasons". This is me, rolling my eyes.

    I'm trying to sweet talk the tech into changing the permissions for me. If it works (and I think it will, if he decides to do it), at least we'll know WHY the "missing a temporary folder" admonishment comes up. Will post with an update presently.

  5. Tiffany_R
    Member
    Posted 3 years ago #

    Ah, transom, I missed your post. Sorry to repeat what you just said.

  6. transom
    Member
    Posted 3 years ago #

    That makes sense - 755 is all the permission that is required (there is never a need to execute an uploaded file).

    What doesn't make sense is why your setup is not correctly finding the TMP file. Have your tech install a phpinfo.php file on your site and confirm that the PHP.ini setup is correct.

  7. Tiffany_R
    Member
    Posted 3 years ago #

    Transom, you were right. The php.ini file had a messed up path in it. It wasn't even finding the temp directory. Thank you for the great direction!

  8. shudson71
    Member
    Posted 2 years ago #

    Enable Directory Browsing on your web server! It'll work. You don't need to tweak code and such.

Topic Closed

This topic has been closed to new replies.

About this Topic