WordPress.org

Ready to get started?Download WordPress

Forums

WP Photo Album Plus
[resolved] Image weight higher after upload (8 posts)

  1. grudz
    Member
    Posted 1 year ago #

    Hello,

    I have just recently been using wordpress and wppa, so excuse me if my question is stupid, i have searched all forums but i havent found what I am looking for.

    When I upload a picture into an album, the "weight" (kb) is 3 times higher after my upload. Ex: lets say the picture I upload is 40kb, once it is on the site, it has become 130kb. I cannot find any notion of it in the settings and I dont understand why/how this happens.

    Also, is there a way to keep the filename as is? instead of changing it to a number? SEO helps when the image file describes the image.

    Thank you

    George

    http://wordpress.org/extend/plugins/wp-photo-album-plus/

  2. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    Try uncheck Table I-A2.

    Also, is there a way to keep the filename as is? instead of changing it to a number? SEO helps when the image file describes the image.

    Not as filename, you can have photo names in links (Set Table IV-A2)
    You can make photos easy findable by setting the status to featured on the Manage Photos page, and configuring Table IX-A9 and 10. Read the helptext unde the '?'

  3. grudz
    Member
    Posted 1 year ago #

    Thank you for taking the time to answer my question.

    Unfortunately, I tried your first suggestion "Resize on Upload" (uncheck Table I-A2) and the next image I uploaded became 150kb even though I uploaded an image of 35kb. My site already has about 500 pictures and will grow every week therefore I am scared my site will get progressively slower.

    Thank you for the type of featured image and meta tages, i did not know that.

  4. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    I think your photoa are very compressed and therefor of low quality.
    WPPA+ manipulates photos during upload/import, and saves the jpg image in a very high quality, this results in larger files.

    If compression is more important to you than image quality, you can lower the imagequality during resize by changing in wppa-class-resize.php line 207:

    function saveImage($numQuality = 95){

    Change 95 to a lower number.

    and during adding a watermark in wppa-common-functions.php on line 1441:

    case 2: imagejpeg($photoimage, $file, 100);

    lowering the number 100

  5. grudz
    Member
    Posted 1 year ago #

    hi, sorry for the late reply, a personal situation has kept me out of working on this.

    Anyway, I tried what you said, I put both numbers to 65, but I uploaded an image that was 69kb. Now on the site, it is at 220kb.

  6. grudz
    Member
    Posted 1 year ago #

    i just realized I never indicated an important piece of information. It is not the thumbnail that I need to stay the same weight, the problem is the image AFTER i click on it, the larger version.

    hope that helps.

    thank you

    George

  7. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    When you UNcheck Table I-A2 ( Resize on upload ) AND do NOT use watermarks ( UNcheck Table IX-D1 ) The photo files are COPIED, and not reconstructed. They will have exactly the same size on the server as on your local computer. (The disk space may differ, depending on the blocksize the operating system uses).

  8. grudz
    Member
    Posted 1 year ago #

    my problem was the watermark was still checked. It works correctly now.

    I appreciate the time you took to help me

    thank you

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic